SOLVED! How to fix Rachiio 3 WiFi not connecting first time

This is what I did that solved the WI-FI Rachio 3 controller not found issue for me, hopefully this helps you as well. I was able to get it registered, then success came rapidly after that, got my zones all entered, and now my sprinkler schedule is complete, and I used my phone to test all 4 zones of our sprinkler system with success.

Here’s my steps taken:

1) Since my Rachio 3 controller could not connect to my home network, Let’s see if home network can find and connect to the Rachio 3 access point. I went onto my Windows 10 desktop PC and scanned for Wifi networks, finding the Rachio-C219DE, so I had my desktop PC disconnect from my home network, THEN connect to my Rachio 3 WiFi controller access point, and of course there’s no internet available but the PC is connected to the Rachio 3 at this point.

2) While my desktop PC is still connected to the Rachio, let’s check if we can talk to it, so I used the cURL commands in a DOS/command prompt window, by typing CMD in the windows search bar. cURL is a command line program which sends and receives data between a client and a server or 2 machines connected over the internet.

I then got the Serial # from the bar code sticker on my Rachio 3 controller after removing the magnetic lid, and obtaining the Serial # off the sticker, I entered the following command in my DOS command window, replacing my SERIAL NUMBER below:

curl -k -X GET -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" "https://192.168.0.1/conn"

Command entered successfully! I then see output response from Rachio 3 controller that says this in the command window:

{"con_state":{"current":"WIFI_CONNECTING","furthest":"WIFI_CONNECTING","code":0}}

3) Next we force feed the my network’s SSID and password to the Rachio 3 controller:

I replaced SSID, SERIALNUMBER, and PASSWORD with my specific numbers with this cURL command:

curl -k -X POST -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" -d "{\"ssid\":\"SSID\",\"pass\":\"PASSWORD\"}" "https://192.168.0.1/config"

After this, I checked the LED bar across the front of my Rachio 3, and BEHOLD! The quadrant that was blinking yellow before was now blue all the way across, meaning Rachio 3 is now connected to my home network.

4) I then disconnect the Desktop PC WiFi connection from the Rachio 3 access point, and reconnect it to my home WiFi network to get back on internet. I look at the status page of my home network’s ATT Uverse router and now it shows Rachio-C219DE as one of my connected devices where it did not before, so now I know we are good to go.

5) Go back out to the rachio 3 controller, and on your smartphone Rachio app, start the Add Location process all over again, enter home address, then scan bar code, hold breath for 2 minutes, and it clears past the finding controller part, and the phone app said the controller was found successfully!

Then the Rachio app on my phone immediately went into the menus to start setting up the zones. Very relieved! I hope this helps you solve your initial connecting issue.

4 Likes

Thanks for this - it indirectly helped me. Thought I’d add my experience in case anyone is in a similar spot.

I couldn’t get the Rachio 3 to connect to WiFi with my iPhone (SE 2nd gen). I found this post with a search and said “it’s worth a try with my MacBook - it can issue curl commands also”.

When I connected to the Rachio WiFi, however, Airport Utility came alive, recognized the Rachio, and asked if I wanted to connect it. About a minute later it was up and running.

So… if you have a Mac on WiFi, there is another thing to try.