Unable to connect to controller after power outage


I’ve been a happy Rachio user since 2016! Unfortunately, on Friday, my power blinked a few times. Afterward, my Rachio 3 went offline and wouldn’t connect to my wifi. I tried unplugging and plugging back in, a wifi reset several times, a hard reset a couple times, rebooting my phone, and trying to connect it on a second device. Nothing would get it to connect: I’m able to connect to the temporary Rachio-XYZ network but then configuration fails to set it up. I contacted support and they concluded my controller is broken and I need a new one (and it’s out of warranty).

I thought I’d see if I could debug further before giving up. I found this post detailing how the setup process works:

Unfortunately, although I can ping the device:

$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=126 time=11.1 ms
64 bytes from icmp_seq=2 ttl=126 time=12.6 ms

I can’t connect to its HTTPS server:

$ curl --verbose -k -H "x-api-key: <REDACTED>" -H "Content-Type: application/json" ""
*   Trying
* Connected to ( port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*  CAfile: /etc/ssl/certs/ca-certificates.crt
*  CApath: /etc/ssl/certs
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS alert, handshake failure (552):
* error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure
* Closing connection 0
curl: (35) error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure

I tried several different versions of openssl and curl. I also tried running sslscan against it and every single cipher failed. It doesn’t seem to have a non-SSL server (port 80 doesn’t respond). Any other ideas for how I might be able to connect to it before I give up and trash it?


The Rachio does not have a direct web server. What lights, if any, are on the front of the controller itself?

It gets stuck on first light blue and second light pulsing amber.

Did you go through the troubleshooting at Light Codes (Rachio 3)

Yes. Did you see the list of troubleshooting I tried in my post? As I mentioned, I also already went through support.

1 Like

Sure did. I might suggest double checking to make sure that the power supply is putting out 24VAC. I doubt it is that, but worth double checking. Power going off and of can cause voltage spikes and that can blow electronics (you probably already know that). However, I believe that usually seems to blow the circuit worse that what you are describing, like it bricks it. This gets beyond my knowledge if it can cause what you are talking about. I will let someone that knows more jump in.

Great idea! Just checked and I’m getting 28.8V AC from the adapter. A little bit higher than the 24V spec but doesn’t seem too far out of range.

@jterrace ; You describe a recent experience on a new Pro 16 I was installing with some frustrations. The Light bar you describe showing a WiFi issue second light amber on a new installation.

With out all the details, installed a WiFi extender cleared out controller, updated WiFi , verified a newer router, made sure credentials were correct and solved this issue.

Not sure if you had any changes in your installation , router failure, credentials incorrect, but this worked for me. I don’t recall ever replacing a "bricked " unit on a second light flashing amber WiFi issue (usually, clients equipment, or credential error)

Unless of course it was a second light solid red. Flashing red, I have mostly found is a temporary service provider issue.
It is possible the range in the router was affected by the outages. Found this link below Hope your able to share your solution. Good Luck!

Thanks, but I don’t think it’s the wifi. One of my wifi routers is only a few feet from the Rachio, I tried power cycling my routers, and then I also tried the wifi hotspot approach where I tried having it connect to my phone’s wifi hotspot sitting right next to it, none of which helped the situation.

The curl commands in rachio_linux_connect.sh (from Rachio 3 WiFi Troubleshooting: Quadrant 2 Flashing Yellow) are getting SSL errors, so there’s just no way to connect to it to provide it with the wifi network details. My leading theory is the disk/flash on the device might have been corrupted.