Connection issues with Gen 3

I would reach out to our support team (https://support.rachio.com/hc/en-us) and they should be able to troubleshoot and determine if the unit needs an RMA.

:cheers:

What is an RMA?

Sorry, a return merchandise authorization. If the unit is defective they will send a new one out asap.

:cheers:

I am also unable to connect my Rachio 3 to my Wi-Fi, even after taking all the steps in troubleshooting I could find on the forum. My RouteThis code is: RRFASTCN
There is nothing fancy or complicated about my Wi-Fi setup. A single router/modem and a single 2.4 Ghz network.

I’m using Android and an Orbi mesh network. Here’s the code I got QB7UF4T8
1st white light goes solid, second yellow light just blinks and never goes solid… I’ve tried resetting network several time and did a factory reset on the rachio 3 nothing works…

Can you try creating a separate network on your main router (not range extender) and connect from there? Also, if you have access to another smart phone that’s another good place to start.

Let us know if either of those two options helps get connectivity.

:cheers:

Seriously?? I just installed mine and didn’t realize how terrible your software engineering is. How can you roll something out for $200+ that has major issues with Android, or doesn’t like any of the common wifi tech in homes today. I’ve tried with my Android and now my daughters iPhone. I’ve set up countless devices (many much cheaper) without issue. This isn’t 2000. Either figure out how to code and stay current with home Integration (what this thing is designed to do), or get out of the business. After spending way too much time and then reading through all the other people having similar issues, I’ve realized I’ve wasted a bunch of time. I’m in CO, was happy to support a CO company, but this is piss poor to have to have some basic stripped down solution. If you can’t figure out device and hardware qualification at least make an Ethernet port. How about step one in the directions is see if this brick can. Connect to your wireless to save pissing off the consumers that took our old unit down and then found out your solution is to RMA or troubleshoot endlessly. Seriously, I’m not trying to be a jerk, POORLY thought through.

Sorry to hear you are having so many issues connecting the controller. I always hate to see this, especially with folks in Colorado. The majority of our customers do not experience connectivity issues, but with the varied smart phone and router landscape connectivity issues do exist.

Were you able to get the controller connected? If not if you run this and provide the code I can have the engineering team review for you today.

Have a great weekend.

:cheers:

Yes, after trying 3 different devices. My Android didn’t work. My daughter’s iPhone 11 did not. My son’s iphone XR did. It seems to be a device qualification issue and you really need to change that. Or offer some discount for people to do this for you via your direct site or something. Basically own and correct the issue in the best way for consumers.

We are basically doing UAT for you in production. Enabling wifi connectivity is a prerequisite and tablestakes for your platform. Between 2 places I have Arlo, Nest, Simplisafe, Ecobee, Wemo, Sonos, Chamberlain garage door app, Lutron, and probably a few more and this was by far the most frustrating. You can’t expect people to adjust their home network to your limited wifi capabilities. I have 2 WAPs with a router and everything else works in both locations.

At the very minimum change step 1 to be try connecting to the wifi to avoid people having to install/uninstall your system and then reinstall their old system. This would go a long way.

After I was able to connect the controller I was able to setup things via my Android device.

@Jester139 Thanks for the feedback and I agree the experience you had is not the one we would like our customers to have, especially just starting out. The team is working on mobile updates to help mitigate some of the issues you mentioned but agreed we need to expand our capabilities to be more proactive.

Thank you for your patience and I will provide this feedback to the product and engineering team. Please let me know if you have any other questions or feedback regarding the controller.

:cheers:

Totally agree with Jester139 on that, the controller is really bad for wifi connectivity and I had bad experience with it and couple of hours loosed, ending up returning it for a refund, hope they will solve the issue and at least put an Ethernet port

I am also really fed-up with a 200$ device bought in 2020 which cannot stay connected to a simple Wifi network. It shows connected when I go to bed in the night, next morning it is no longer connected. Watering is ignored. We have three neighbors purchased this from Costco a week back and all three having similar issues cannot be attributed anything but the product itself. Never had issues with Costco purchases before. Probably going to return my device and call Costco Customer Service to evaluate the products before they put on shelf. :unamused:

Not our typical customer experience for sure. I can have our engineering team review your network connectivity if you would like to run this and provide the code generated. Thanks and have a great weekend.

:cheers:

I have a google wifi. The RouteThis code is 46F6JNFM

I have the same issue Fanz. Don’t want to be a jerk here but I agree with the comments in this thread. I have spent 4 hours trying to troubleshoot this using the community and FAQs from the Rachio website. I am returning mine. You say not a common experience but there seems to be quite a few. Seems like the company should look into thier quality inspections.

Oh, really? The forum note above your post says “This is the first time bluebandit has posted …”
If you used a different moniker, please post a link to your other thread and we’ll try to help.

Otherwise, please post:
What do the light codes show now?


When attempting connection, what is the highest blinking quadrant you achieved?
When you visit app.rach.io from your computer, does the controller appear in your account? If so, what state does it show?
Describe your home network: Modem make/model, separate router (if any), separate access point(s) (if any). Any firewall settings more restrictive than the default?
What resources do you have that may be useful in establishing a connection (Android and iOS phones and tablets, even if without a SIM card, desktop or laptop computers)?
1 Like

The company I purchased the Rachio 3 from sent me a replacement. It took me less than 15 minutes after plugging it in to get it set up. So it was a bad unit. I wish there would have been something somewhere that described if you have a blinking 1st quadrant that has an intermittent red, then there is something wrong with the units wifi reception. I spent well over 6 hours trying to troubleshoot the unit and felt there should have been a quicker way to find the problem. I have the tools to check the signal even though the router was less than 20ft away and was still told by tech support to run through all the troubleshoot tips I found here and elsewhere on the web and had already performed.

Now that it is up and running I can see why people like this device. I wish they would spend a little more time on quality checks and customer support. Email support only with a 24-48 hour promise of response is a bit antequated for such a high tech device/company although I did get a response with in a few hours. All that said, so far I like the ease of use and the capabilities of the Rachio 3 but I have only had it up and running a couple of hours.

Stewart, here is the response I sent to you via email last week but see it did not show up here.

"I have used youtube, the Rachio website and read through many of the community posts to no avail. This is my first post.

The unit, when plugged in only shows a flashing blue/white light in the first quadrant with an intermittent red one. The wifi signal from the unit will only broadcast for a few seconds before it disappears only to come back about 20 seconds later. My router is only about 20 feet away from the unit. No firewall. I have used my Samsung 9, Samsung 7 and windows 10 laptop to try to connect to the unit, again to no avail except the intermittent connection before the unit drops signal. I can’t get past trying to connect in setup with the app so the app is useless at this point."

We’ll…I’m gonna have to jump in here. I would think after this much time this issue would have been fixed. I just got my unit hooked up and I’m getting the same issue unable to connect to the Wi-Fi. I have an Android phone and Google Wi-Fi. I’ve tried repeatedly and just can’t get it to work. Does anyone have a simple solution to get this working? I can’t believe it takes this long to figure out a Wi-Fi connection issue. It’s 2021 after all…

First, confirm that you can get the controller into ‘awaiting Wi-Fi’ state (2nd quadrant blinking).

Then, turn off mobile data on the phone. Open your Wi-Fi settings and you should see a Rachio-xxxxxx network, where xxxxxx is the last 6 characters of the MAC address. Connect to that network (of course you won’t have internet access) and let the phone sit for two minutes. If a message pops up warning you of no connectivity, choose the option to remain connected. Now, reconnect to your Google Wi-Fi, run the app and try to connect the controller.

If you fail (still quadrant 2 blinking), try to use a different device (Windows, Mac or Linux) to provision the controller. See

OTOH, if you fail but you get a different error (report details), then your Wi-Fi or network configuration may be blocking the controller from connecting to the cloud. To confirm this, temporarily set up a phone as a mobile hotspot (confirm with a second phone that it’s working properly) and try to connect the controller to that. If it succeeds, we can then see what’s different about the Google connection.

If you don’t have two phones for the hotspot test, use your working phone as the hotspot and use an old phone or tablet (no SIM card needed) to run the Rachio app. If you don’t have an old phone, use your phone as the hotspot and a desktop or laptop (as described above) to provision the controller.

ISP? Modem make/model? If modem is a gateway (has more than one Ethernet port), do you have it in bridge mode? How many Google Wi-Fi devices do you have? How are they connected to your modem? Are they in bridge mode?