Rachio 3 Not Responding in Homekit (Again)

Dear Mr. Blasta,

I wouldn’t relax just yet - my Rachio3 now works about half the time (which is a huge improvement over this time last year when it could not be introduced to HomeKit for love nor money.)

But for the other half of the time it’s angry red icon central.

Nothing I do on my iPhone iPad or Mac makes any difference. Unplugging the Rachio and plugging it in again mostly gets it back into the HomeKit setup. Perhaps I should use a Smart plug for the Rachio, so if it isn’t responding I can turn its power off and on again using something reliable.

On just have the smart plug on a timed automation to turn off and on again at midnight and noon…

Jon.

Dear Mr. Brawn :slight_smile:,

I am wondering what you’re using for WiFi network hardware, if you don’t mind?

Thing is: An iOS update should have no effect on existing Rachio 3 <-> HomeKit connectivity whatsoever. Once an iOS/IPadOS device has been used to get things set up, it need no longer even be present for the association to remain. Please see: Apple HomeKit, iOS/iPadOS, and the Rachio 3 (And other networking notes)

Is it possible there was a coincident HomePod, or whatever you’re using for a HomeKit host, OS update, too? We don’t have any HomePods, yet, but t’s been my experience that when Apple releases a major iOS/iPadOS update, there’s often a tvOS update at the same time.

If you work in I.T., then you should be aware that if you change one thing in a network environment and network behavior changes, odds are the one thing you changed is the reason for the different behavior.

This is basic Troubleshooting 101.

You are missing the point… all other HomeKit accessories are, and have been, working fine since iOS updates and whatnot. This is simply a poor integration of HomeKit on the Rachio. Apple is aware of this as well.

Thanks,

-Dilan

2 Likes

I gave up on trying to fix this. *Mine just works and I hate it that others are having problems…

I keep an eye on this thread that I started 2-1/2-3 years ago and I really don’t think this is something the community can fix. It is simply up to Rachio… Life is too short to worry about these kinds of things for me.

3 Likes

[spot check: Today my Rachio is: ONLINE]

I’m using a mix of assorted eero hardware. I have most of the fancy features turned ON, though the HomeKit feature is in a screwed up state at the moment - eero thinks it’s on, Home app doesn’t. I’ll mess with it next time I’m feeling brave.

Jon.

1 Like

Hmmm… Sensing a pattern, here :wink:

Me too… everything in my network works all the time except my Rachio, which has intermittent HomeKit functionality.

I’m really not going to let you tell me that my Wi-Fi hardware should take the fall for Rachio’s flawed software. Eero is pretty mainstream, and at least their support people keep me up to date with my queries (enabling eero DDNS with Google Fiber before you get on your damned high horse about how there’s problems with my network). If you want to defend Rachio’s flagrant incompetence, go ahead, but you’re the fool if you do. Or in their pay.

2 Likes

Have it your way. It’s no skin off my nose ¯\(ツ)

Hallelujah!

“The Apple team has replicated the issue on their Rachio controllers. Our teams are working together to analyze the logs. We will be meeting next week to review next steps.”

Hopefully they will share what they found as I would love to know in addition to it getting fixed.

2 Likes

Now that “The Apple team” has replicated the behaviour we’ve all had for months and months, hopefully this issue will be fixed once and for all.

In the meantime I’ve added my Rachio to my Hombridge server and I’m joining @Macsterguy’s “mine just works” club :grinning: Not the ideal scenario, but it will do for now


1 Like

Welcome to the Club!

1 Like

Hallelujah!!!

Ok. So I’m in the functional club with 632 and UniFi non-mesh access points.

Mine worked for months, then dreaded no response in HomeKit yet fully functional in rachio app.

Was digging through this thread and tested a new UniFi feature, not sure when it showed up, and when I clicked manually add accessory in HomeKit it actually showed up in HomeKit! Entered my pin and boom!

In UniFi controller v6.2.26
Settings>wifi>Select wifi name(mine is a shared 5/2.4)>edit>advanced>Optimize IOT wifi connectivity

I turned this on for both. It reprovisioned the AP’s and instantly worked.

IF your on UniFi. Give it a try.

1 Like

Glad you got it sorted-out.

Could it be your Rachio 3 <-> HomeKit connectivity went away about the same time that feature was added to your UniFi AP(s)?

BTW: I recommend against using the same SSID on both 2.4GHz and 5GHz networks. It’s been my experience band-steering usually creates more problems than it solves–particularly in multi-AP networks.

That update came out months ago so I just don’t know. None of my other HomeKit stuff has an issue so I think something finally happened like a power cycle or whatever that caused the issue to manifest.

Thanks for the feedback on the separation. I think the biggest culprit here is the fragility of the HomeKit integration on rachio with lots of contributing factors that should be non issues, but are.

Thanks for steering me into the unifi config to overcome this.

You’re welcome.

I’m trying to find out what the option actually does. Tried searching on it every which way and came up bupkis.

1 Like

It appears to set DTIM to 1. You could of course do this manually on each AP. But it appears this is a blanket setting.

There might be more it changes, but that’s what I found in a thread on the UniFi forum.

Interesting. Yeah, setting DTIM to 1 is all anybody’s found it appears to do.

It would seem Rachio 3 owners weren’t the only ones to have experienced “issues” following one of Ubiquiti’s UniFi firmware updates. And others found changing that setting solved their problems, too.

What I don’t get is why this should be so, unless one of their firmware updates set DTIM to an inadvisedly high default value.

Whatever the case: Ubiquiti has a bad habit of arbitrarily changing things in updates without warning their existing user base they’re doing it. That’s one reason I switched-out our UniFi AP AC Pro for an EnGenius AP and why I’ve always been very, very careful about applying firmware updates to my ERLite-3 router.

1 Like

Is this an option only if you are using the same SSID for 5 and 2.4? I have an SSID for 2.4 only and don’t see that option. I am also on 6.2.26.

EDIT: Found it in the UniFi app on my phone, not sure if its just me but I dont see the option to enable this in the web GUI.