iOS 14.2 WiFi issues

Agreed. Having same issue with iOS 14.2. It’s still not working.

Where are we with the fix to this? I still cannot gain access to Rachio Gen 3. This is horrible service in my opinion.

Is this the same controller that was replaced almost a year ago? If so, do you know how you lost access (nearby lightning strike, new router or access point, etc.)? How have you tried to regain access (list all devices you used including iOS version)? What errors did these show?

When you log in to app.rach.io, is the controller in your account? If not, do you know what may have caused that (even a factory reset of a controller without Wi-Fi couldn’t affect the back end)? If it is in your account, what is shown for the state e.g. offline?

Is the controller presently connected to your Wi-Fi? What do the light codes show? What have they shown when you attempted reconnection?

Do you have access to any phones, tablets or laptops that you have not yet tried (wife’s or kid’s phone, old phone without a SIM card, etc.)?

The workaround has been out for about a week. I was asking above for some additional details that I could use to provide further details. If you can get me that info, I may be able to help.

System hasn’t been responding. Reset the wifi to my controller. My controller says it is connected, but system still will not work. Is there a new app?? Happened after ios update.

Also the video in the reset mobile instructions is so small i can’t see it and the volume doesn’t play

When you log into app.rach.io from your computer, do you see the controller? Does it show as online? Can you run a zone manually? Do your schedules show as upcoming? Can you run a schedule manually?

I have the same issue. Can’t connect to HomeKit so stupidly tried to reset wifi and now won’t connect to wifi.

  1. I see the controller on app.rach.io but offline and can’t run anything manually
  2. trying steps to add via the instructions in app for iOS 14 via the setup new device rachio network results in failure with no indication why
  3. tried troubleshooting which repeated #2 with addition of airplane mode on phone (iPhone 11 pro running 14.2) which did nothing

Need this fixed urgently as I have new grass seed I now can’t water easily.

Were you able to get the controller into the ‘awaiting Wi-Fi’ state?

Assuming yes, what devices not running iOS 14 have you tried? What Wi-Fi devices not running iOS 14 do you have access to (old phone without SIM card, spouse’s or kid’s phone, Android or iOS tablet, Windows / Mac / Linux laptop, etc.)?

If you’re just trying to update WiFi, don’t attempt to add a new controller. You can actually update your Rachio’s WiFi without even opening the app.

If the second light is blinking (meaning your Rachio is waiting to join the network) follow these steps. If the second light (or quadrant if gen 3) isn’t blinking, reset the wifi again on your controller to get to that state (you can see here how to do that).

  1. Go into the iOS settings app
  2. Go to WiFi settings
  3. Under your network name and other networks around you, you should see your Rachio appear under accessories. Tap your Rachio
  4. Follow the instructions that iOS provides to select which network to connect the Rachio to

Zachio, I tried all that before I posted as I mentioned in my second point. I can connect to the Rachio network to set up new accessory, but it doesn’t complete and says that the process failed without further detail. Not very helpful of iOS.

Stewart, unfortunately I don’t have any iOS 13 devices. I didn’t realize I could doo this on a laptop, so I can try that.

Stewart, that worked THANK YOU. I was able to use a MacBook Pro (running Big Sur) to complete the setup. Clearly an incompatibility issue with iOS 14.2, but for others in the same boat, try a laptop if you have one.

I have a gen 3 that I am setting up for a client. I held down the reset Wifi button on the rachio, went into settings on my phone > wifi > selected the Rachio in “set up new device”. It goes to the "Setting up the accessory to join “wifi network name” for a while and ends up with… “Acessory set up - An unexpected error occurred. Try again.” I’ve tried over a dozen times and have ended up at the same error screen.

iOS 14.2 on an Iphone 11 Pro.

Please help.

Do the lights on the controller advance past the second light? Sometimes iOS gives us a false error even though the Rachio connects. If not, it could be related to this. Depending on when your device was manufactured, it may have an old firmware that doesn’t contain a fix for new iOS devices and some of the messages they send when connecting. That post outlines some workarounds you may be able to try.