Wont work with iPhone 11 & iOS 13.4.0

Please confirm that you tried the temporary iOS downgrade noted earlier in this thread.

Awesome. What do you call her?

My fiance has not done the upgrade so i tried her phone standalone and also as a hotspot. neither method worked.

Thanks!

Bill

Using your wife’s phone (running 13.3.1), please report:

Can you get the controller into the state where quadrant 2 is blinking (manually, not using an app)?

If so, can you see its Rachio-xxxxxx network on her iPhone?

If so, can you connect to that network (of course, there will be no internet access)?

If so, can you remain connected for at least two minutes?

If so, can you open 192.168.10.1 in your browser and see the expected ‘not found’ error?

If you get this far, run the app and try to configure Wi-Fi. If you fail, please post the exact error(s) reported by the app, and the state of the controller lights after the operation.

I can get Quadrant 2 blinking in orange. There is no rachio network showing in her phone.

Assuming that other networks do appear:

Try a factory reset (use option 2):

If her phone still can’t see the Rachio-xxxxxx network, this is most likely a hardware failure and you should contact Rachio support. Otherwise, continue with setup and report any problem.

Hey bilwilvegas,

Quadrant 2 means you’re controller is ready to connect. Franz mentioned above that we’ve found an issue where iPhone 11s running iOS 13.4(.1) don’t work with our accessory setup. We’re working with Apple on a more permanent fix, but I wanted to provide some work arounds that will help get you online!

These work arounds (especially on Windows and Linux) are very technical. If you don’t feel comfortable with the instructions, feel free to wait for us to get a better solution out. I just want to provide a current solution in case it helps you or anyone else here.

Note: These workarounds require a computer with WiFi capabilities


If you’ve got an iPhone 11 running an iOS version less that 13.4, you should be able to connect through the app via the update network settings.

If you don’t have any other iPhone / version combinations, we can get your controller online with a computer. The steps are a bit involved, but they should get you up and running!


If you’ve got a Mac

Make sure you’re Rachio controller is showing the orange second quadrant blinking. Open up the WiFi settings on your Mac and you should see your Rachio-XXXXXX listed under the networks. Click on your Rachio and a new window will pop up asking you what network you’d like to add the Rachio too. Click next once you’ve selected your network and it should get your controller online.


If you have Windows or Linux computer

This one requires you to enter some commands in a terminal or command prompt.

On Windows open a command prompt by tapping the windows key and typing cmd followed by enter.

On Linux you can use your favorite terminal application.

You’ll need to grab the serial number of your Rachio controller. If you’ve already onboarded and can see your controller in the app, you can find the serial number in the More Tab -> Controller Settings -> Technical Info. It’ll look something like V31234567. If you have not yet onboarded your Rachio, open its faceplate and look for its serial number listed near the barcode. Write this down as you’ll need it shortly.

You’ll need to connect your computer to the access point the Rachio controller sets up. Go in to WiFi settings on your computer and look for Rachio-XXXXXX (the XXXXXX will be different based on your device).

Once your computer is connected to the Rachio network, go back to your command prompt or terminal and copy/paste the following command then press enter. You’ll need to replace SERIALNUMBER with your serial number you looked up before.

curl -k -X GET -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" "https://192.168.0.1/conn"

You should see output if the command you just entered successfully communicated with the Rachio controller. You should see something like:

{"con_state":{"current":"WIFI_CONNECTING","furthest":"WIFI_CONNECTING","code":0}}

If you don’t see that, make sure you entered the command correctly and make sure you’re still connected to the Rachio-XXXXXX network via WiFi and try again.

Next we’ll send your WiFi information to the controller. You’ll enter another command just like you did before. This time, replace the SERIALNUMBER with your serial number and replace SSID with the name of your WiFi network and PASSWORD with your WiFi network password.

Windows:
curl -k -X POST -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" -d "{\"ssid\":\"SSID\",\"pass\":\"PASSWORD\"}" "https://192.168.0.1/config"

Linux:
curl -k -X POST -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" -d '{"ssid":"SSID","pass":"PASSWORD"}' "https://192.168.0.1/config"

After sending this command, you should see the orange light on your controller turn white and eventually fill all the way and flash blue. This means your controller is fully connected to your network and the Rachio service!

5 Likes

It really isn’t paranoia.The facts are not in evidence. I have a $200 + investment for this. First, it was, “It won’t work with dual band routing.” Then it was “port 53 needs to be opened”, after running a route check app. When I did the last thing, the Rachio created its own network and all of my devices joined it, thus shutting down the house. (Wife wasn’t happy.) Then I get a note from someone named John that the iPhone 11 is “the problem”, running iOS 13.4. Well, gee, excuse me for updating my phone. And no, I don’t keep old phones around. To top it off, NONE of this is actually true, because I have an iPad Air running a little earlier iOS and it doesn’t work either. This thing is a piece of junk.

This was a day late. Sorry. Returned the unit after working with multiple people several days who were guessing. At over 200 bucks, this thing should just work—I don’t care what iOS you are blaming. You need to be ahead of these updates like everyone else selling connected devices. This is a shame really, because I really wanted this controller. When you guys figure out what you are doing, I might come back.

2 Likes

Actually it is a problem with iOS 13:4. I was in the same boat as you, both my and wife’s iPhone updated the day I needed to reconnect the controller to my network. My friend had not updated, used his phone and had no issues.

I do wish I had t he computer instructions though, should have been easy with my Mac.

Thank you for providing this solution. This was an easy way to get the system working. You guys should include this in the basic setup instructions as a second option if people have issues with connection. The system works great now!

1 Like

Hey Zach, many thanks for posting this solution.

Note that cURL is pre-installed in Windows 10, though users of older versions can download it at https://curl.haxx.se/windows/ and run your setup.

However, I suggest that you make two tiny changes to the firmware, which would make it much easier and more useful:

  1. Allow the parameters to config to be passed by GET (as well as POST). Many request parser libraries support this out-of-the-box.
  2. Allow x-api-key to be passed as a request parameter (as well as in a special header). This should take less than ten lines of code.

Then, one can provision Wi-Fi from almost any device by connecting to Rachio-XXXXXX, typing
https://192.168.0.1/config?x-api-key=SERIALNUMBER&ssid=SSID&pass=PASSWORD
into the address bar of a browser, then proceeding past the certificate error.

These same steps should work in Windows, Mac, Linux, Android, iOS (and probably Blackberry, Windows Phone, …)

If someone has a problematic network requiring them to reconnect Rachio repeatedly, they can save the above URL as a favorite and can then reconnect with only a few taps.

IMO there is nothing in Rachio that should require a smartphone. Planning and modifying schedules is best done from a computer with a big screen and a physical keyboard. Sure, control from a phone is occasionally useful e.g for adjusting sprinkler heads, or to cancel a scheduled run if you’re about to mow, but the web portal is more than adequate for that.

FYI, up until today after reading the latest posts on this subject, I can tell you that my iPhone 11 Pro Max was setup with iOS Version 13.3.1, which is the version that I have been successful with recently installing and connecting to the Rachio 3 controller over the last couple of weeks. I haven’t seen a notice about a newer version of the software being available to download for my iPhone, which is why I haven’t updated it until today. But now after reading the latest post, I can tell you that I have downloaded and installed the latest iOS Version 13.4.1 on my iPhone 11 Pro Max, and I can tell you that it was still able to connect to the Rachio 3 controller after the new iOS software update. I also updated my iPad Pro with the latest iPadOS Version 13.4.1, and after updating, it is also still able to connect to the Rachio 3 controller. The Rachio 3 app on both the iPhone and iPad still appear to be working normally without connectivity problems. I never had the iOS Version 13.4.0 loaded on either the iPhone or iPad, so I hope that I have skipped over the connectivity problem reported in the previous posts with the iOS Version 13.4.0 software.

I believe that the problem noted with 13.4.0 was an inability to “provision” Rachio, which involves connecting via Wi-Fi to the controller (which is acting as an access point) and sending the SSID and password. But once the controller connects to your network, ordinary operations in the app (such as modifying a schedule or doing a quick run) go via the cloud back end, for which 13.4.0 worked fine.

So, unless you successfully provisioned a controller using 13.4.1, we don’t know whether the problem is fixed. Of course, I don’t suggest trying that, because you may lose control of the device.

1 Like

Will there be timely announcement on this thread once the iOS issue has been resolved? I cannot afford the time to play with work-arounds if I upgrade my 13.3.1 phone software however, there are unrelated lingering issues with the phone that are best addressed with the latest iOS version. Is the resolution going to take weeks/months or is it days? I may need to choose my problems to endure.

Thank you for everyone’s patience. We have an MFI ticket and WAC defect troubleshooting tickets open with Apple. We are also working with our WiFi module vendor to expedite. From what I’ve initially heard from Apple since it is so specific (iPhone Pro 11, iOS 13.4/13.4.1) it does indeed seem like a defect in their WAC provisioning process that was introduced with this version of the OS. We’ve received signals from Apple that since their full team is remote and WWDC20 (Apple developer conference) is around the corner it’s all hands on deck in that direction, which unfortunately might mean a bit longer than normal to identify and fix this. We also have one of our expert network engineers investigating this to see if there are any workarounds that can be introduced in the meantime until we get an Apple fix. As soon as we get more information it will be passed along.

Thanks again for your patience.

:cheers:

3 Likes

@purson - if your Rachio is already provisioned and set up you should be fine.

The latest Rachio version works fine on my iPhone Xs running iOS 13.4.1 for both the Gen 2 and Gen 3 devices that are already provisioned.

Is your iPhone a Pro 11, as the defect may be related to just that phone?

1 Like

Thanks for the encouraging information. I got a new IPhone 11 Pro at the end of February and have spent about 60 hours trying to get data installed that my old iPhone 7 had but am still having issues with loss of iCloud connectivity. I’m told troubleshooting is best done with newest iOS. Rachio had not been affected but I run two locations, one of which is 500 miles away and I don’t have physical access for months at a time. Both controllers have been working ok for a year so it sounds like I won’t have an issue by updating the iOS. I’ve become too dependent on my electronics and have no backup or Plan B for irrigation functions.

Would I receive an email from Rachio to warn about a software issue that might shut down or lose connection to my controllers? In my case, I would not know for a long time if it stopped working.

I’m so glad I found this thread, I tried a hundred times to get my new Rachio 3 (new user here) connected to wifi in a hundred different ways. I was using an iPhone 11 with 13.4.1 to no avail. Found this thread and used my wife’s iPhone Xs, and BAM!, it connected just like it was supposed to. Thank you everyone, but this needs to get sorted.

Side thought - This community is cool, but Rachio, you really need some tech support that you can actually reach. Buying a new product only to be on your own is not a good feeling. The only reason I didn’t take this thing back was that my old system was broken and I didn’t have a backup plan in place.

2 Likes

If your controller is already connected this iOS issue will not impact it. Only for controllers that are being newly connected and only with the specific iPhone and iOS combination (iPhone 11 with 13.4.1).

Hope this helps.

:cheers:

As a side note the engineering team has also been rolling a firmware fix out to existing controllers (already connected) so if you need to change or upgrade wifi this will not be an issue in the future. The firmware version is 632 (only for gen 3 users) and can be found in the technical info section of the app.

Thanks for your patience and the team is doing everything possible to make sure customers are not impacted by this.

:cheers:

1 Like