Rachio 3 Not Responding in Homekit (Again)

@zhazell - did you see these comments, relative to Ubiquiti APs and IoT devices, back up-thread?

[Rachio 3 Not Responding in Homekit (Again) - #1368 by Scaryfast]

Thanks, but that options has since been removed in the later firmware versions. It optimizes the 2.4Ghz band DTIM setting to “1”. However my Rachio is connected via 5Ghz. Just for the kicks of it, I set my wifi to only be 2.4 Ghz (disabling 5Ghz). That still had no affect. I can see the Rachio connected on 2.4, but still no response in the Home app. Even closing the home app and opening it back up to force a refresh does not get it out of the No Response state.

@zhazell, is your LAN/WLAN set up as a single, “flat” address space (everything on a single /N netblock, so no internal routing) and without client isolation on the WLAN?

Are you running your three Ubiquiti APs as three independent APs, or in a mesh mode?

Are you using the same SSID on both 2.4GHz and 5GHz, perhaps with band-steering enabled, or different SSIDs for each band?

You mentioned “a single VLAN.” Are you actually using VLAN tagging?

Are you using WPA Personal (WPA PSK) with Fast Roaming enabled?

I’m trying to understand why the R3 and HK seems to work reliably on some networks, but not others.

Yes it’s a flat network, sorry for the confusion. When I meant single VLAN (like the default). One subnet, one network, no VLANs in use.

They are independent APs that all have a Gig backbone back to the switch. They do not run in a mesh mode. They are all the same SSID across the 3 for seamless roaming across the house. This 1 SSID is for both 2.4Ghz and 5GHz. Clients seemlessly roam between the two channels depending on range. (Inside it’s on 5Ghz, when I go in the backyard it usually switches to 2.4 if I’m in the far back). Never any issues with any device.
Fast roaming is enabled.

I have no idea. I disabled my 5GHz network to test. Everything, including the Rachio connected to 2.4Ghz. Still no response in the home app.

1 Like

Nonetheless: Using the same SSID and band-steering is known to cause problems with some wireless clients. Common recommendation by network professionals is to avoid it.

But, if you want to keep it for your mobile clients, I’ve a work-around for you. Maybe.

That, also, is known to cause problems for some clients in conjunction with WPA PSK. (I’m assuming you’re not running WPA Enterprise, with a RADIUS server.)

If you don’t want to run separate SSIDs for 2.4GHz and 5GHz, and want to retain band-steering for your mobile clients (e.g.: phones, tablets), then add a new SSID (I assume Ubiquiti APs support multiple SSIDs/channel, now?) on 2.4GHz only, force your Rachio 3 off the existing WiFi network, and re-associate it with the new one.

Maybe start off putting that new SSID only on one AP? The one closest to the Rachio 3?

I would recommend you disable fast-roaming for all. See: WiFi Fast Roaming, Simplified

Bottom line:

Lastly: You didn’t mention client isolation. Make certain that’s not enabled.

For reference:

I’m running two EnGenius APs. One hardwire-backhauled, the other backhauled with a 5GHz wireless bridge. No meshing. Separate SSIDs for 2.4GHz and 5GHz (so no band-steering). WPA PSK. Fast-roaming disabled. Client isolation disabled. Flat address space. No VLAN tagging.

My WiFi network never gives me any trouble with any client. HomeKit added the Rachio3 and retained it all last season. It’s been back in HK for a couple days or three. Still there.

1 Like

I’m not using band steering. It is done at the client level automatically. Nothing from the wifi APs or controllers are forcing the clients to use one band or the other. This is the preferred implementation and commonly done in the IT world. It is done in our office buildings and various locations.

I have disabled it, to test. So far, even after reboots, it still shows up as “No Response”

I might setup a new SSID and try to associate the Rachio to it.

It is not enabled. That would prevent all my devices from talking to one another, airplay would fail to my apple TVs and associated speakers around the house. I can communicate with all devices on the wifi/LAN.

I am, like you once were, in the IT/Networking space. I can see all my other homekit devices MDNS responses on the network, except for the Rachio. My network is setup just like yours, but with different hardware. :man_shrugging:

1 Like

The reason I recommend turning off all the modern bells & whistles is this: I suspect the Rachio 3’s network stack isn’t particularly robust. I suspect that’s what’s causing (most of?) the problems. (But not all. Sometimes, I’m certain, it is the network.)

This suspicion was reinforced, lately, in an experience I noted up-thread, following my doing firmware upgrades on my two APs and the backhaul bridge. Long story short: I managed to break the R3’s WiFi–and only the R3’s. I’m now doing additional experiments to figure out just what gave it heartburn. (This will take days. When I try something new I make sure the R3 stays working for at least two days before trying the next thing.)

Also note my last edit to my prior post: Put the new, 2.4GHz-only, SSID on only one AP, at first.

ETA: Are you using WPA3 or WPA2? WPA3 is supposed to be backwards-compatible with WPA2 clients, but I found that not to be strictly true. At least not with some of the clients on my WLAN. (However, that became immediately obvious when some of them simply would not connect to the APs at all.)

1 Like

I had been trouble-free all year, and this morning got the “no response” issue.

Since I use Apple Watch to control zones when I’m in the yard, it’s an actual issue.

Fortunately I was able to resolve it by going to More > Controller Settings > Update Wi-Fi Network

No idea how long the fix will last, but nothing has changed about my Wi-Fi network this year.


"When you have a device that’s the same everywhere and the only difference between locations is their network environments, logic would dictate network environments may be an issue.”

Absolutely, 100% agree. I’d even go as far as to say ‘must be the issue’.

My hunch is that it’s not the hardware though, but the traffic on the network. Sure, if you’ve got your network setup to not allow MDNS from one side of your network to the other then of course it won’t work - but in that case nothing on the same side as the Rachio would work, wouldn’t you agree? I’m suspecting that the Rachio can’t cope with networks with a lot of HomeKit traffic on them - When I went from around 75 HomeKit devices to around 40 or so my Rachio 3 suddenly became happy. None of my hardware changed, just the amount of HomeKit traffic. The scenarios I’m imagining are: 1) a memory leak. 2) incorrect handling of the situation when all network buffers are full. 3) the microcontroller they’ve used doesn’t have good enough performance to handle high volumes of network traffic.

  1. and 2) can be fixed with a firmware upgrade. If it’s #3 then we’re sc… well, we’re not going to get a fix.


1 Like

… But, if it’s #3, then those of us sufficiently savvy can solve the issue with proper VLAN design and subnet bridging.

Possibly, but surely only a small percentage of those experiencing problems have 50, 60, or more IoT devices on their networks, talking to HomeKit?

Normally, yes: I would. But I have seen evidence of certain networking products apparently arbitrarily filtering service/device availability traffic.

E.g.: We have an OTA TV network tuner and networked DVR on our network. In forums dedicated to these products I’ve seen people complain of erratic performance of these products on their networks. In one case, in particular, the guy would reboot his network devices and everything would be fine–for about 24 hours. Then not. When I suggested he do some packet-sniffing for MDNS/Bonjour traffic: Sure enough, it was mysteriously disappearing–never to be seen again until he rebooted all his network devices. (I forget which he was using, but I’m pretty sure it was either Eero or Google.)

That’s just one of many such reports I’ve seen, here and there.

ETA: Btw, the guy had been blaming the OTA TV gear because “everything else on his network worked.” Look familiar? :thinking:

Perhaps. Perhaps @Badxhabit could do some MDNS/Bonjour traffic snooping on his network? Might prove enlightening.

Were that true, one would expect all Rachio3/HomeKit installations would suffer the same fate, eventually, no?

Possibly, but MDNS/Bonjour packets aren’t very big. I just ran a query. Query packets I saw were 75-391 bytes, responses 107-1487 bytes. (Sure is noisy, though. Holy smokes.)

You can’t “bridge” subnets. You can only route them. (Bridging is Layer 2. Routing is Layer 3.) MDNS/Bonjour doesn’t route. (I have seen suggestions it’s possible, on some routers, to get MDNS/Bonjour through a router. I didn’t pay them any heed, because I’m not doing any internal routing, so I had no use for the information.)

Wandering a bit OT, here, but…

You also don’t necessarily need to deal with subnets if you’re using VLAN tagging. A tagged VLAN port will discard any frame not destined for that VLAN, incl. untagged frames.

You do need to use subnets if you’re using tagged VLANs and you want to route between them.

Back on-topic…

It would be nice if Rachio would share with us what their thinking is wrt the possible causes for the problems so those of us with some network tech. chops could do a little informed digging.

I have 9 HomeKit Hubs that often change*, but only 1 “no response” this year. I don’t know if that’s the root cause, but it’s the current working theory based on the most recent update from Rachio.

*I hate that we can’t set a prioritization order (like we can on Mac network interfaces), or exclude certain HomePods from taking over as hubs.

Yep, I have like 6 HomePod Minis and 3 ATVs, so lots of hubs.

Fascinating. I just did a little bit (a very little bit) of research. Not only can you not exclude HomePods from playing HomeKit hub, but some users report their previously-stable HomeKit systems became unstable after they added HomePods to the network.


Interesting. For testing we could unplug a few hubs…

I have 3 ATVs, 2 HomePods (3 iPads). My Rachio is working well and I just tried to break it by randomly unplugging the hubs. Rachio seamlessly keeps working…. I don’t get it.

1 Like

I often have to switch hubs (by powering down devices) since my original HomePods don’t save HKSV recordings.

Not once has this caused the Rachio no response bug.

A month ago, I connected an unused Apple TV HD to my router via Ethernet to force it to have priority as a hub (which worked). My “no response” issue occurred while the Apple TV was the hub, had been the hub, and still is the hub.


1 Like

So are we still looking for root cause or onboarding developers?

I have five home hubs in my network and they occasionally change… My Rachio stays connected at all times. Again, the only problem I have is having to long press twice occasionally but works eight out of 10 times:

21 days until summer. Are Rachio users going to go through their 4th summer without a working homekit? This version 3 was released March 20, 2018, and we are now almost into June 2022, and the feature is STILL BROKEN