Rachio 3 Not Responding in Homekit (Again)

I’m not certain what you mean by “talks directly to…”

We’ve three Apple TVs currently on our network. I tested the stuff linked to HomeKit (Lutron Smart Bridge controlling our Caséta devices and Rachio 3) to see what would happen when the currently-serving hub went off-line by the simple expedient of powering-down whichever one it was. Everything moved over to another ATV. (There was a display, somewhere, that would show which hub was active and which was/were waiting in the wings.)

IIRC, I did that a couple more times, and everything chose, or was directed-to, a new hub and there it was.

(HomeKit was kind of cool, but, except for Siri voice control, which I found erratic, at best, I really didn’t see what it brought to the table, so I stopped using it.)

1 Like

When I switched hubs everything worked except the rachio which requires a power cycle to go back online in HomeKit. I did this a few times with always the same result.

As far as Siri and voice control that works really well for me.

The role of HomeKit hubs is so that IOT devices can communicate with your HomeKit network through the Home app. Talk to Siri blah blah blah. It doesn’t affect in anyway using the IOT device app or it’s workability. Just interaction with HomeKit

I just want to chime in and update, since it has been awhile, but I STILL can’t get my Rachio device into HomeKit.

I sold my Rachio 2 and upgraded to the 3 solely because of HomeKit integration. I paid an extra $100 to get this feature and you guys have failed to deliver.

At what point do you just admit defeat and refund our money back?

This is getting ridiculous. I don’t have time to keep checking back and waiting to see if there is a solution, I just want my product to work as advertised.

1 Like

I checked, and nowhere have I found your description of your network or what you’re using for HomeKit (only mobile devices? Anything for a hub?)

So: Please describe what you’re using for WiFi networking gear and what, if anything, you’re using for a HomeKit hub.

Ok, just to see…

I just re-enabled HomeKit on our Apple TVs and added our Rachio 3 back into HomeKit. Most annoying part was having to cancel the “add accessory” dialogue on my iPhone so I could access the Rachio app screen that had the code on it, write it down <smh>, and re-start the “add accessory” process.

It’s added. Just turned Zone 1 on and off with HK.

I have 3 AppleTVs and 3 HomePods that act as Hubs.

Also, I was using 2 Apple AirPort Extremes, but I recently switched to 2 Linksys MX5300.

It doesn’t matter which device acts as the hub, I still get the same issue.

1 Like

I presume you were you having the same problem with HomeKit with the AirPort Extremes?

Who cares what the network is? Rachio has acknowledged they are working with Apple and have been able to reproduce the problem.

I fail to see how any of this is relevant.

I should be able to use a RaspberryPi Router and it should still work as advertised.

Yet, oddly, they’ve yet to have arrived at a solution. Hmmm…

It is a known fact that some network infrastructure devices interfere with MDNS (Bonjour), upon which some IoT devices depend for functionality.

Depends upon where the RPi router is in relation to the IoT devices. E.g.:

LAN <-> Router <-> LAN

MDNS broadcast queries and responses will not get across that router.

Another thing that can kill MDNS is APs with client isolation set. In such a case WiFi clients cannot “see” one another, thus they don’t see one anothers’ MDNS query or response broadcasts.

I’ve mentioned these issues in this thread many times before. Nobody ever wants to believe it’s their network. Nope. Gotta be Rachio’s fault. Thing is: The effects of Certain Network Gear are real, and they impact not only the Rachio 3.

If you know what to search on, you’ll find examples such as Client Isolation Issue. Note, in particular:

[Note: Emphasis added]

My “flat” LAN/WLAN network, with no router between LAN and WLAN, no wireless repeaters, no mesh, client isolation turned off, the AP not “optimizing” bandwidth by “helpfully” removing “unnecessary” traffic, has been 100% stable both with the Rachio 3 remaining connected to the network and to HomeKit.

It’s not by happy accident I designed our home network the way I did :wink:

Yes, it’s everyone else’s fault. The hundreds of people, all having the same network issue, with this one device.

Nevermind, that I have 86 other HomeKit devices (6 different bridges) that all work flawlessly. Nope.

“But, buT, iTs yOuR nEtwOrk!!”…GOH!

1 Like

Except it’s not “hundreds of people” and it’s not “with this one device.”

I just reviewed the thread–all the way back to when @Macsterguy started it in April, 2019. By my count there have been 156 contributors that appeared to be posting with Rachio3 <-> HomeKit problems.

156 is a disconcerting number, but it’s not “hundreds.” Plus some of them appeared to have solved their issues by one means or another.

Secondly: Perhaps for you the Rachio3 has been your only HomeKit problem child, but many others have had experiences similar to those related by @SalisburySam, where he related

Look familiar?

Do a web search and you’ll find lots of stories like his. (I think there might even be one or two more in this thread. Three years of posts was a lot of slogging.)

And you know what is most common among those experiencing HomeKit issues? Precisely the kind of things I’ve noted in prior posts.

One guy, as a work-around, even went so far as to record the MDNS response broadcasts for “non-responding” devices and clone them into an avahi-daemon on an RPi <smh>

(Why <smh>? Because that’s what we call a “kludge.” If your network isn’t properly propagating MDNS/Bonjour broadcast traffic, the proper fix is to fix your network, not hack around the problem.)

Y’see, I asked about your network. You failed to mention that. Were I not so trusting of my fellow man, I might suspect you were laying a trap for a “Gotcha!” :wink:

That’s really not helpful. But I know how to take a hint. I’ll stop trying to help you.

1 Like

86 devices? That’s where I was. All of them broadcasting away like mad. All that chatter on the airwaves.
Then, for a completely unrelated reason I decided to swap out all of my HomeKit light switches to Lutron ones, with a single bridge to rule them all.
That got rid of over three dozen HomeKit devices from the WiFi.
And my Rachio sprang into life and has been mostly fine ever since. I have to power cycle it after thunderstorms, but other than that it’s been online when I check.
I haven’t changed my mesh network at all between before and after. The only change was replacing the old switches that never worked correctly with the Lutron ones.

I’m not saying that Rachio don’t have a problem - they most definitely do - I just don’t think it’s got anything to do with the network routers we’re using.

Jon.

I’m curious: In what way(s) did they never work correctly?

Nor am I arguing there’s nothing amiss with Rachio’s code. I’ve said this all along. But…

Disagree.

When you have a device that’s the same everywhere and the only difference between locations is their network environments, logic would dictate network environments may be an issue.

N.B.: I’m not saying the Rachio 3 shouldn’t work in some of the networking environments in which it’s not. Only that those networking environments may be a factor.

In other cases, where network devices are known to interfere with network device and service discovery protocols such as MDNS/Bonjour: The network is definitely at fault.

Just had an interesting experience. For the purpose of this discussion I had re-awoken HomeKit and added our Rachio 3 to it night-before-last. (When I had it in last season it worked flawlessly.) Just went to check. It wasn’t there! Tried “Add a device.” The Rachio 3 wasn’t showing up. Killed the Home app and re-started it. Still no Rachio 3 to add.

Thought “Oh wow. I’m gonna have to eat my words.”

Exited the “add device” dialogue.

Guess what showed up? Yup: “Irrigation,” the name I had given the Rachio 3. Also showing up was the Apple TV I realized, after all this, had also been missing. So it was a Home app glitch.

1 Like

Still shocked us users are in the 4th watering season now, and the HomeKit feature is still broke

So I decided to try to re add my Rachio 3 to HomeKit. After resetting the Rachio I got it in HomeKit and to my surprise it worked! BUT…… 2 WEEKS LATER ALL OF A SUDDEN WITH NO CHANGE, NO POWER OUTAGES I GOT THE DREADED “NO RESPONSE” So frickin disappointing……every thing else in HomeKit works flawlessly.
Using the Velop 3 node WIFI

Just want to chime in. I have had the Rachio for a few years now and Homekit has always been a problem. If I do a complete reset, reconnecting to wifi, and re-adding it to Homekit, it works for a few days. Then goes back to “Not Responding”.

I have tried the MDNS “hack” that rebroadcasts the mdns as mentioned earlier this year, but that doesn’t seem to work or resolve anything. I can see the broadcasts from my Rachio and Raspberry pi and then they stop from the Rachio but my pi keeps sending them. Homekit reports “not responding”

I have a simple single VLAN network using Ubiquity equipment. 3 APs across my house and a USG as my router all with the latest firmware. My Homekit network consists of 35 devices and the only one that has issues is my Rachio. Every other device has rock solid wifi access and I have never once had an issue except for the Rachio. I never touch my network equipment except for the periodic firmware updates. Other than that, it just works.

Not sure why the Rachio has such a hard time with Homekit. One of the selling points of getting it was because it was Homekit compatible, but never have been able to use it. I just use the Rachio app.

I really don’t understand but mine is working 99% perfectly. When I press into HomeKit I’ve got to hold my tongue just right and 10% of the time that doesn’t work. Otherwise it just works.


@Macsterguy: Your front yard looks a little under-watered. :grin:

1 Like

They say that Texas is nn for one of those summers…97º and windy today. Supposed to go to 102º… Sheeesh :hot_face: