Rachio 3 Not Responding in Homekit (Again)

To be fair, 15.4 seems to have at least somewhat borked homekit in general. I’m having issues with a bunch of other devices as well (like siri saying she’s not capable of turning then on or off…like she could before that update)

1 Like

Same for me. Now Homekit is totally useless for me.

If I open and close it a bunch of times sometimes it will show up properly and work but then it goes back to a blank screen.

If I open it by doing a long press zones show up but if I open it by clicking on it then I get the blank page.

This does not work in Home on my M1 mac as there is no way to do a long press in Home on a Mac

It seems to work fine on my Apple Watch.

Wow! You are exactly right. With a long press within Home on iOS, the zones will show up, but a tap they will not. Crazy.

Apple Watch works.
Mac Home does not.

With the issue on both my iOS devices and my M1 Mac but not on my Apple Watch I would say it’s an issue with the latest Apple update.

So now we have to wait for a fix from Apple or an update from Rachio.

I don’t care about it not working on my M1 Mac issue and now that I figured out a workaround it’s just yet another annoyance with the controller.

For now I dumped the native HomeKit and moved to Homebridge.

1 Like

I am as frustrated as everyone else.

If you long press in the Rachio Icon in HomeKit, you will indeed see what you posted. (System On/Off)

What a user needs to do then is scroll down past a few white/dark pages (Depending on Mode) of nothing, PAST the settings icon and then BAM, there’s the controls.

I don’t know who to blame here as I am not a coding expert. But it’s definitely backwards.

Maybe Rachio can fix this easy enough now that it’s been pointed out.

I have a Yardian scheduled to be delivered today. Really hurts to install it as I have been with Rachio since Gen 1.

HomeKit is honestly not the end all needed feature. I’m just upset that this fix could have been addressed months ago. It is also the reason I upgraded my Gen 1 to 3. - Lost cash on this.

I have recommended Rachio for Years now and have sold plenty of their systems by word of mouth. (100+)

I can’t in good conscious continue to do so unless Rachio will buyback my panel without hassle.

It’s an all around shame.

Macsterguy here (Chris) here - I’m happy to report that my Rachio is having HomeKit problems!

Some of you may be new and some I’ve been around in this thread for a long time. I actually started the thread when I was a younger man :stuck_out_tongue_winking_eye:

For the most part since I think I fixed my issues with a new router that I love (and I can’t wait for the next version when it comes out by Synology). My Rachio has been nearly rocksolid even re-joining the network after the electric goes out, or whatever… I could be wrong but that’s why I think mine just “WORKED” so well up until now… For the first time in a very long time it is acting flaky with some of the things you guys are saying is happening do you were you got a long press to get it to pop up. Probably works 3 to 4 times out of 10. Again, I have gone back-and-forth with some that it wasn’t there wasn’t my router I will I won’t respond but my router I think was able to correct one or more flaws in the firmware / software of the Rachio 3. Early on, while beta testing a firmware update brick to my controller in Franz really impressed me with how fast he got another controller out. That second controller had the same issues before the beta testing. Everything started working with the router. Just saying… If I replied in the thread that mine worked good I got accused of being a Fraz / Rachio lover and on and on… Blah blah blah.

I’m guessing a month or 3 (there’s no way I can remember that long) after I started the thread, I never really thought that much about HomeKit integration of my irrigation controller. I think the built-in Rachio app is top-notch and the HomeKit integration is very very limited. I have stated that in the past and wow did I take a beating from those that want it to work so don’t go there. It’s just how I feel and I understand why others feel the way they feel. It’s always a great thing when people keep promises…

Oh and by the way, my grass looks great least I forget to mention it… :rofl: :joy: :innocent:

So Now… “WHEN IT DOES” pop up it works great and I won’t miss it if it breaks forever.

What I don’t appreciate like most of you is that Rachio has not stood behind the product, the advertising is completely false. But other than HomeKit integration I still think it’s a great controller and I would keep it and buy the next version and who knows maybe HomeKit will work (maybe not)…

I did notice that there was an update to the Rachio app last night having to do with (crop coefficiency) or whatever and when I went to rejoin HomeKit it joined immediately without issue first attempt and I saw a quick moment where it looked like the firmware was being updated at the same time… It was too quick to see detail but I think at least I hope they are trying to fix this in the background.

I’m a kind of person that never gives up on people and always give them a second (sometimes more) chance. Depend on what the topic is. I’ve been in business for 42 years and in business you’ve gotta speak what you know to be the truth. Unfortunately Rachio has not done this and for that I don’t know that I would forgive them for HomeKit integration…

I probably won’t reply unless I can be of help in anyway I’ve wasted far too much time on this and life is too precious at my age! I do sometimes find that it’s fun to fix a problem and see a good result but I don’t think that’s going to be the case here so I’m not gonna work this problem just reporting what I see. Hell I can’t even type and Siri did this whole thing without mistakes (I think)… HaHaHa

I don’t know how many pages are in this thread but I don’t mind working with technology if it can improve my life. I’m pretty good at that and I know one thing for sure this is not worth my time…

I just did a couple of test a few moments ago. When the stations popped up it worked as expected and I will probably never use it again until I want to test it again

1 Like

OMG! I am speechless…



There was an OS update today that supposedly fixed some Siri issues, at least with HomePod but worth a shot for other things too

I got the Yardian up and running and wanted to report my findings.

Homekit still acts the same way as I reported above a few posts back.

It reads system off. Have to scroll down past the setting icon to see the actual settings.

Guess that parts on Apple.

I cant report on other things as it will take some time to find any other bugs as with the Rachio.

Hoping it stays connected and works as advertised.

Really would appreciate Rachio to do the right thing and buy back my panel. This is the way to get me to keep faith and look forward to future products from them.

As I said before, its kinda a sad day for me as I hung in there as long as any consumer could.

Will miss my Rachio notifications….

I have been using the Homebridge plugin for a couple of weeks, Rachio should support the development till they find a “fix”.

3 weeks and no official updates. If they literally needed to hire someone new, there’s absolutely 0 reason to believe this will be fixed anytime soon. It takes quite a while for a new employee to get familiar with a new code base.

Yeah. 15.4.1 seems to have fixed some of the really odd stuff I was seeing with Siri interacting with other devices in HomeKit. I don’t even bother checking the Rachio though as I’ve basically given up; I haven’t been able to add it back in for over a year now, we’re moving to a new home in the next 6-ish months, leaving the Rachio behind and definitely not getting one for the next house.

Yep. I’ll be shocked to see any significant movement this year.

We got one, they ordered equipment. Let’s hope its not being delivered by the same carrier pigeon that delivered the equipment to Apple.

Would love to know what this new equipment is and how it’s going to help us?

Our Homekit engineer has completed the first season of Ozark and is ready to begin thinking about this problem with a fresh, unexpected perspective.


Been watching this thread since the beginning but pretty much gave up. Well, mine just started working after being dead for months. Never even bothered taking it out of HomeKit. It’s been good for a week or so now. Something change? HomeKit says I’m on firmware 5.632. I’ve got UniFi access points running on an older Linksys router with Wifi on that unit turned off.