Rachio 3 Not Responding in Homekit (Again)

:rofl: We are waiting on the carrier pigeon too return from delivering the test hardware to Apple to delivery him his job offer!

1 Like
  • I was able to get the Rachio unit added to HomeKit in Feb 2021, but it always threw the No Response error and never worked inside the Home app
  • Today, I removed it from Home
  • I tried to add it using the code and tried unsuccessfully 5-6 times
  • I did a reset on the unit and could not get the code to work 2-3 times
  • I did the Wifi Reset and could not get the code to work 2-3 times
  • I then tried the code “one last time” (and I literally touched my iPhone to the Rachio to get it as close as possible distance wise) and it successfully finally saw the Rachio unit and I was able to add to Home
  • When adding to Home, the Home app notified me that there was a firmware update but I could not click it fast enough to update it. It is currently running 5.632
  • Now, Rachio is successfully added to Home with no error (that is new)
  • However, the buttons are not visible in iPhone Home to control Rachio (see attached screenshot).
  • It will show that Rachio is “Running” or “Off” in the top label, and I can see the custom labeled Zones that pulled in from the Rachio app when I click the gear icon
  • But crazily, in Apple Watch, the buttons are visible to control Rachio and I can successfully start and stop Rachio in each zone

So basically there was BIG progress. I can now control Rachio from Home on Apple Watch, but not iPhone (the buttons are not visible in iPhone Home app)!



1 Like

Yep I am noticing the exact same thing.

Still cracks me up that they advertise it on their website as Apple Homekit compatible.


1 Like

You know, maybe we ought to have a law about this sort of thing…

Oddly it does work fine for some. I have mine working and stable after months of tweaking my network although it can still be flaky of times.

Maybe it’s time for a Rachio 4 with new architecture: Thread, no wifi.


A free Rachio 4 for all Rachio 3 customers perhaps?


I love my Rachio, purchased my first “Iro” at the end of 2013, it was a pre-order for the v1. Through the years I have upgraded to v2 and then v3 specifically for HomeKit. Not sure I will stick around if we don’t see meaningful update on the “weekly” updates.


We haven’t seen “meaningful updates” in that thread in 6+ months, no reason to think it will start now…

1 Like

This may apply to the issues with rachio.
I have an Apple TV 30 feet from my front door that has a smart lock that uses Bluetooth and the Apple TV is its Homekit hub. I upgraded the Apple TV in my bedroom to an Apple TV 4. Then my smart lock started going off-line and it took me a few days to figure out what was happening. Turning off the HomeKit hub on my new bedroom Apple TV fixed the issue. Seems it did not like having more than one Homekit hub.

I know nothing about Homekit because I’m not an Apple guy, but this makes a lot of sense. I have other home automation products, and with multiple hubs present, it can be tricky to make sure what is pointing where.

1 Like

Did you designate one as master and the other as backup?

I’ve had 2 in place for over 4 years and they work flawlessly — it’s not an issue. They actually recommend it. So, I suspect you had two both trying to be a master. One should say connected and the other I believe will say standby.

My first generation of AppleTV 4 has been my hub for some years now. I don’t really use this Apple TV other than this hub. So almost everything is on its default settings as I don’t really use this Apple TV.

My front door is about 30 feet away and communicates with the Apple TV using Bluetooth. Works perfect for years.

My bedroom is on the other side house and I got sick of dealing with an Apple TV3 obsolescence. So I got the latest version of the Apple TV4. This one I am using. I turned on HomeKit and downloaded the apps I needed to watch the shows I wanted to watch on my version 3 AppleTV.

Then my front door lock started going off-line over and over again. I did the usual troubleshooting of rebooting the lock rebooting the Apple TV, rebooting my phone. It didn’t just go dead to HomeKit it went dead to its native app that communicates directly to it using Bluetooth. The only way to get the lock back online was to remove the battery tray so the lock would reboot.

I’m gonna take another look at the settings on my Apple TV I don’t remember seeing anything making one master.

Not sure about Apple TV but in iPhone homekit app home settings you can see details of hubs

On the Apple TV my choices are connected or disabled and are reflected in the home app.

Maybe a HomePod is different

Looks like we are back to no weekly updates.


The new guy they hired 2 weeks ago, probably saw what a sh|t show the IT department is here, and left already =(

Side note, WHY is amazon still showing this unit as Homekit compatible? False advertising


Mine finally went off-line after no real issues for many months.

Only the first two LEDs were lit with the second one pulsing.

I was getting ready for the nightmare of adding it back into HomeKit but first tried cycling its power and was amazed it went right back online.

I’m using an iPhone 12 Pro with the latest iOS, and Rachio 3. It’s been working great since I got it 1+ years ago. However, ever since the last iOS 15.4, it seems the sprinkler zones are no longer showing in the Home app. I removed the device and added it: nothing.

As suggested by Rachio support, I reset the device: still nothing.