Rachio 3 Not Responding in Homekit (Again)

Never had Leviton, but I am certain my environment is not congested. Makes sense though that no device would like a congested network.

I suspect you’re correct regarding “a small number of a small number.” I would never have bothered with putting our Rachio 3 into HK had it not been for the threads complaining of problems provoking my curiosity. And I’ve since removed it from HK.

Besides the incentivization, there’s the question of replicating the failure mode(s), then determining what condition(s) provoke it/them. Speaking as an ex-software developer: This is not always as easy as it would seem to the uninitiated.

I’m not making excuses for Rachio. Just noting facts.

FWIW, I was also pushed “iro-firmware-hk-15-3” around the same time, and for a while I also had problems re-adding the controller to HomeKit. The issue was, when I tried to add the Rachio to HomeKit, it did not “see” the controller, even when I entered the HK code number.
First, I did a power recycle (unplugged the controller and replugged it back in). No dice.
Then, I disconnected it from WiFi, power cycled, and reconnected to WiFi. Again no dice.
Then, I held down the “Stop” button for about 15 seconds, let the controller reboot, reattached it to WiFi, and it still didn’t make a difference.
Finally, I unplugged the controller and left it unplugged for about 10-15 minutes, then plugged it back it, let it restart, ensured it connected to WiFi. With this last try, I was able to re-add it to HomeKit and I have been able to control the Rachio with Siri.

It’s been reconnected to HK now for 14 days and the connection is “solid” - no drops and no errors and no hiccups.

I have no idea if it was my brilliant troubleshooting, or just witchcraft, but I did end up having success with this firmware. I’m sharing this in hope it might help you, too. Good luck!

(PS obviously make sure you are using the latest version of the Rachio app and latest release version of iOS.)

1 Like

Thank you! I was able to get it reconnected. Regrettably I still have the dreaded No Response message. It also tells me a firmware update is available.

Er, it has been over two years. Our definitions of “in a hurry” are widely divergent.

1 Like

That’s British sarcasm - they’ve not been incentivized to fix anything even slowly, let alone in a hurry.

Instead of calling the toilet “the John”, I call it “the Jim”…
That way it sounds a lot better when I tell people I go to “the Jim” first thing every morning…

1 Like

Hi

I’m sorry to jump into this particular thread real late – and no I didn’t read all 1386 replies to this thread, so please tell me if what I’m saying or asking has been asked/solved/not solved.

I purchased Rachio in 2019 and yes I was amazed the Homekit integration was half-baked and broken. I believe I spoke to somebody in customer support back then and they confirmed HomeKit wasn’t really working and for me to wait – but they said it was going to “be awhile”. I kind of gave up on the entire idea and am kind of amazed its now Sept 2021 and the issue still isn’t exactly solved. I guess the suggestion “It’s going to be awhile” is still true.

I recently for a different project setup Home Assistant within an xcp-ng hypervisor as a VM for a different camera setup. I’m still really new to working with this Home Automation software so I can’t give firm recommendations or setup advice. Because it’s a Home Automation program, if offers various plugins and tries to seemlessly recognize other home automation devices on the LAN. On my LAN – among others I have an Apple TV stand-alone box and a Rachio – both devices were identified right away and I was able to add them within Home Assistant. Home Assistant also provided an option to install a HomeKit wireless bridge integration.

The setup looks like below:

Once I set this up and registered with homekit, I found all the rachio zones and schedules to show up within Apple Home Kit

Honestly I’m not sure the status of Rachio and Homekit - it appears they are really working on it (maybe). I was really surprised however that a free program such as Home Assistant was able to offer this level of functionality and discovery. I’m just passing this information along to users requiring homekit integration at current time. HomeKit can be installed as a VM, or stand-alone program, or docker image. I’m aware some users may not have the home network to set something up like this, however just figured I’d pass it on as a way for those users familiar with setting up other projects.

1 Like

Broke down and configured my Rachio with Homebridge. Works perfectly. Should have just done this a long time ago.

2 Likes

2 weeks now without a status update… :sleeping:

1 Like

I will likely regret this but “iro3-firmware-hk-15-3" is working for me. It was bumpy ride to get it connected to the home app but once I did it’s been online for a week with no issues. I do have a notification in the Home app of a firmware update but it online.

1 Like

WTF does that even mean? They have a Rachio 4 in testing they are sending to apple? What apple to the wifi chip maker? Was the test units sent 2 weeks ago? Man, this is just ridiculous…
Also find it strange they don’t post updates anymore unless someone calls them out on it. Truly obvious they don’t care about fixing this. :-1:

1 Like

I think you made the right move. I posted about this recently myself and it has been working great ever since. Meanwhile, Rachio toddles along on the testing.

1 Like

Just turned off most of my watering for the season…fall is finally arriving and no fix

2 Likes

I’m in south Florida
Summer, Winter, Fall, and Spring it’s all the same here. lol

I have not had to re-add it back in since turning off IP6 but it is flaky and constantly goes off-line and back online. Really annoying when I’m in my yard working on stuff and I have to wait until the controller feels like going back online again as I’m standing there getting soaking wet by the sprinklers.

Someone please tell me todays official update is a joke?

1 Like

Comical. They send the units via Pony Express? This is becoming an ongoing joke this whole beta/HomeKit update :woozy_face:
They should be embarrassed for these posts. Do they think their customer base is that dumb?