Rachio 3 Not Responding in Homekit (Again)

:sweat_smile: Sorry to hear Rachio is back to offline, but glad to hear the solution isn’t replacing all of my Gen 1’s.

1 Like

I’m not certain, either. I read two posters saying that. Not certain if you were one of them.

Hmmm…

Summer is almost over, another season has practicly come and gone, new IOS due out in October, and we no closer to getting HOMEKIT fixed on this POS.
Not sure who they hired to work on this, but it’s time to bring in a new crew. By the time you figure this out, IOS 15 will be out, new homekit SDK probably, and we will be back at square one (2+ YEARS ago…) We should be seeing a new beta WEEKLY on here, if this was a priority

Every IOS update i keep my figures crossed this issue is fixed, Sadly, just cosmetic issues, and a memory leak fix (not sure who was complaining about a memory leak on the app…)

To be fair, my iOS app crashed a ton when going into Irrigation > Calendar and was super annoying.

I live in South Florida so summer here is endless.

1 Like

iOS updates aren’t going to fix any issues with HomeKit/Rachio 3 connectivity or connection reliability. Please see Apple HomeKit, iOS/iPadOS, and the Rachio 3

The dreaded “Not Responding” just showed up for me, on my iPhone, this evening. Interestingly, I opened the device, anyway, and turned on a zone. Unexpectedly: It did turn on. I turned it back off, went back to the HK home screen, and the R3 was no longer “Not Responding.” Strange.

I wonder if there’s some kind of heartbeat or keep-alive devices and HK are supposed to exchange, so HK can know if the accessory is reachable/available, and that’s getting dropped?

Don’t know, but this happens with my Wemo smartplug and even my ecobee smart thermostat from time-to-time. :man_shrugging:t2:

I am amazed that in the weekly update thread it is stated that the Apple testers do not see the same issue. Makes me wonder what they are doing, because for me as a user, this was a regular occurrence.

What would be really nice would be if I could get off the beta firmware that is in my unit that does not even seem to let Homekit work for the Rachio3 at all. This is my only Homekit device that is chronically not working.

Also, @Macsterguy - your’s is working fine. So say we all. : )

1 Like

IIUC (if I understand correctly): They’re talking about two separate, but possibly related, issues: Rachio 3 <-> HomeKit issues and Rachio 3 network connectivity issues? If so: I read their last post as in reference to the latter issue.

It has been my suspicion all along that most, if not all, of these issues are network related. I know few, if any, of those suffering these problems agree, but that remains my belief.

I come to this belief from having seen these same kinds of seemingly arbitrary connectivity and performance issues affect users of other WiFi-connected products that depend upon persistent connections and network discovery protocols. In nearly every case the problem ended-up being the network.

Tag one or more of the Rachio peeps?

You can add me to that list–though I’ve avoided posting and re-posting “Mine works!” :wink:

Mine has been on-line since June 3. I connected it to HomeKit a couple days later or so. It’s remained on the network and registered with HK ever since. <knock on wood>

We’ve had two or three power outages since then. The WiFi never went down, as the AP is on PoE and the PoE switch is on a UPS with the LAN server and all the network gear, but the R3 has definitely lost power each time.

1 Like

I’m visiting my son in Colorado and I just checked. Working fantastic!

1 Like

Mine has only needed to be put back online once in some months now after I turned off IP6 to fix the problem of my internet going down. Internet has never gone down again as well.

The rachio does sometimes so offline but it always fixes itself now. Actually I have a few devices that do that.

Hey @dane
Yesterdays update, you said " We continue to work with our partners to review the logs from controllers experiencing the issue."
Really bud? You have been collecting logs now for over a month now, can we please get a better update to the solution than this?? Not sure how many beta testers you have, but I can’t imagine its that many that you can’t go through the logs in a month’s period.
Again, seems like Rachio is just kicking the can down the road on this issue. If this was a priority like you all claim it is, we would be a lot closer to a solution by now, don’t you think?

2 Likes

Spot Check!

My Rachio 3 is OFF LINE and has been all week as far as I can tell. This is ’normal’. If I can be bothered I’ll go and re-introduce it to HomeKit.

Jon.

1 Like

Yes I cannot add my rachio to HomeKit. I use eero pro 6 WiFi. It is mesh but it actual real mesh. I get 230 into my modem, standing beside my rachio I get 225mpbs on a speed test. The rachio app shows -42RSSI signal. I have a ton of devices made by different companies in HomeKit, rachio is the only one that I have problems with.

It doesn’t work. You know damned well it doesn’t work. When will it work? I’ve had this Rachio 3 for over a year and it has never connected reliably to my HomeKit environment, the longest it has been connected seems to have been about two weeks.

1 Like

@Willygoat , is HomeKit security enabled in you eero Pro mesh network? (Don’t ask me where that setting is. I just spent fifteen minutes trying to find a flippin’ eero Pro 6 user’s manual and I’ll be darned if I can find it.)

I did find these articles:
How to use HomeKit with your eero Network
and
Tip: Problem setting up HomeKit with eero? Disable Thread

HTH

@jonbrawn , it doesn’t work for you and @KidCapri. There are others for whom it does work.

They are enabled in my HomeKit, but they are not an accessory like an ecobee, etc where the security level can be changed. Is that what you are asking?

@Willygoat , try alternatively disabling Thread (as per the second link I posted), Homekit Security, then both, to see if either or both of those is affecting your issue.

I held the reset wifi button under the Rachio cover and it finally showed up as an available accessory to add. I tried the stop button hard reset numerous times over a few weeks. Not sure why I never tried the reset wifi button, I guess because the hard reset makes you re-add the wifi network, Anyhow, it is now in my HomeKit.