Rachio 3 Not Responding in Homekit (Again)

I saw your previous comments about doing that and tried it as well. It didn’t work :frowning:

Well I would not mind being “downgraded” as well back to the standard version of the firmware. I am not getting this device added back into homekit. Bummed, but it was a beta so I was playing the odds.

Is there a way to get downgraded to the normal software since the beta now has it where my homekit doesn’t work at all?

Well, it took three attempts to get my Rachio 3 into HomeKit - and there it stayed for around 24 hours, and then wandered off somewhere else.

I think this glorious Beta scores a resounding F-

If your controller is still online you should be able to contact support and they can push it out to you

1 Like

Thank you macsterguy - I fired off my email to them yesterday when I saw your message. I just needed the shove in the right direction.

Should be 5-632 (if I remember correctly, on the road right now). Let us know if you’re able to get on HomeKit with that firmware

Yes. Mine is currently at iro3-firmware-hk-11-8 and now their support team has advised me:

“Actually, your controller is already running the standard firmware. We haven’t released any beta firmware yet so HomeKit should not be working as of now for some customers. We hope to have more updates for you soon.”

lol…it’s like the left hand doesn’t know what the right hand is doing. I’m so disappointed now.

Right now, I can’t even get their support to acknowledge that I am on a beta firmware. I seem to have fallen through the cracks.

See if you can’t DM or private message Franz.

They re-read my message and now understand I am on the beta. Support advised:

“upon checking with our Engineering Team, I was told we can’t downgrade firmware on controllers as it will cause them to get bricked. If you really want to have the old firmware back, we would have to send you a new controller.”

So I think I will just ride this out. I don’t have the energy to replace the controller over this.

Wow, that must be how my controller got Bricked Back when the beta first came out. They shipped me a controller very quickly. Great support in that regard

I guess so. I am thinking about doing a factory reset to see if that gives me back the ability to add to homekit…but maybe I should just leave it alone. I’m still mildly annoyed that I have no homekit functionality. This is a primary reason I purchased this device. We will see.

My new normal since turning off IP6 is open the home app and see the Rachio not responding. Put phone in airplane mode, open HomeKit app see everything no response, take phone out of airplane mode, open hone app and watch everything update As the Rachio goes back online.

At least this is only a bit annoying. Have not had to re-add it since turning off IP6. Each time I have to do this I think this is the time it won’t fix itself but so far it has worked every time.

Not normal behavior but way better than before when I would have to spend a long time trying to add it back in.

I wish there was a way to see its logs.

Mine is working perfectly other than one hiccup I have back when I lost Internet for a day. I’m glad but it’s just strange that it works

1 Like

And just like that we are back to crickets on Fridays, no more weekly updates despite the commitment just a month ago. :-1:t3:

@laura.bauman @dane @franz
Can we get an update please?

Just in case you haven’t tried this.

Power cycle the Rachio.
Then Hold down the stop button on the rachio until it resets as this is different than holding down the WiFi button.

Delete the rachio in HomeKit if it is still there.

Restart your gateway or whatever is doing your routing.
Then restart any hubs.

Go chill for about 15 minutes while apple updates HomeKit on their end and your router does its thing.

Restart iPhone.

Add to HomeKit using code.
It may not show up right away but should show up before it times out. If not try adding again. Be sure to have your iPhone very close to the Rachio as it seems to also use Bluetooth or something during the add.

At some point the Rachio will turn blue.
Then on your iPhone it may look like it failed with your only option is cancel.
Hit cancel and then on the next screen you will see it is still adding and at some point it should say added,

Anyway the above worked for me in tines when nothing else worked.

1 Like

Thank you, I am going to follow this recipe and see what happens later today. I am hoping for the best.

It seems like they just want to problem to go away. Maybe they are hoping people will eventually give up asking for this to be fixed, and just be content with the current broken Homekit status. Again, if this was a priority, then they would be treated like one. We’ve gone through 3 different people at Rachio posting update status for users. Seems like they just kick the can down the road…
First beta’s rolled out when, last Fall? And we are no closer to having it fixed 6+ months later?
And @franz, 3 weeks ago you asked me to DM you my rachio 3 controller info so you would push the beta through to me. It’s been 3 weeks, 2 DMS from me, and I’ve seen no update. Appreciate the help bud! :-1: Support like this isn’t encouraging with your product, Im sorry to say.