Rachio 3 Not Responding in Homekit (Again)

So what are our options? Law suit? Bombard Social Media with the truth that it may or may not work with HomeKit? I’m really frustrated, I did use Siri at times to turn on a zone here and there, plus I like to get what I paid for……

Well an update only every two weeks supposed to be easier? I guess not…

I understand the frustration expressed in this thread, and I would like to address @VillageIdiot as well as @KidCapri the best that I can.

I locked the thread because it was supposed to be locked like the previous “Official Update” thread. While not having the time to properly respond, I left it for visibility so that your candid feedback would be exposed on a pinned topic. I want you to know that I am not trying to hide feedback or silence anybody. I am going to delete the comment after I post the latest update tonight. I will post the original below in this comment, which is a highly visible topic for feedback and user details on network/HomeKit topology, troubleshooting, and other discoveries made by users.

I’m sorry to say that we cannot provide a deadline at this point. But we have made progress and I am confident that we will be able to share more details. To be clear, most Rachio HomeKit users do not encounter “No Response” and the behavior does not reproduce in most network/HomeKit configurations.

We’ve been working with contracting partners who we work very closely with and they have provided us with valuable work. We determined that we needed an internal resource. We needed time to find the right candidate, which is what we have done here.

I’m also sorry to see that mentioning our partners has been perceived as placing blame on them. It is definitely not our intent. When we mention a partner by name in an update, it is not an attempt to shift responsibility, but because we are working with the partner directly to troubleshoot the issues and it is therefore relevant to the update. We take this feedback seriously. Going forward, we will only refer to “our partners” when mentioning them in updates. We want you to know that we are not doing this alone, but we are actively engaging with our relevant partners and earnestly working toward a solution.

The original post, which I will delete from the “Official Updates” thread after I post tonights update.

Your process on fixing these years-old HomeKit issues is in slow-motion, completely unserious, and obviously incompetent. This is very disappointing. You apparently sent Apple a sample device in September and, as soon as you dragged Apple’s name in, you started blaming them week after week, giving reports that you’re sitting on your thumbs “waiting for Apple.” You milked the “waiting for Apple” until well into this year. You should have onboarded this so-called “expert” long, long ago—at least once these problems started emerging years ago—and the reason we have these problems is obviously because you never had such an expert going back into product development. Forget why you didn’t have this expert to begin with, why didn’t you hire him during the nearly half-year that you spent blaming “waiting for Apple?” Not only are you throwing Apple under the proverbial bus, we now hear you throwing Cypress into the mix as well. Why are you name-dropping all these other companies except to create some sense of blame on them, a false sense that all these companies are responsible to us to fix this mess, and blaming them for your slowness? You have our money, you are responsible and no one else. Please stop with the BS. Cypress has its chips inside of Apple’s highly sophisticated HomePods that are the backbone of HomeKit. CNET says Cypress chips are part of “the brain of Siri,” so stop implying they don’t know what they’re doing. Stop shifting our attention and the blame. You need to stop worrying about Apple and Cypress and worry about yourself because it’s clear that you don’t know what YOU are doing.

The first thing professionals do when tackling a problem is establishing a deadline. Your deadline should have been the beginning of the watering season, but you were too incompetent to set any deadline at all. And now you’re telling us your meaningless updates will be fortnightly, so that we stop expecting even what little we were already getting. We never got a working product, nor a solution, all we got from you was the weekly meaningless screed, and now we aren’t even getting that anymore because you are unserious. Since you think some of the outraged comments have died down, you now have the nerve to update us “fortnighly” instead of weekly. The outrage has NOT died down. It’s multiplied. No one imagined in Spring of 2022 we would still be hearing the exact same gibberish from you people. Stop name-dropping all these other companies, accept responsibility for your own mess, and fix it with a hard deadline.

Now it’s the watering season and your device is still defective, and you’ve decided to prioritize this less by making “fortnightly” your meaningless updates that are absolutely devoid of any concrete information. So what is your deadline? What is the deadline? What is the deadline? What is the deadline? That’s effing Step #1, to establish a deadline. Do you get it now? Tell us what is the deadline.


As you can see on the below screenshot from my Home app, it’s currently in No Response mode on HomeKit as it has been for over a year.

As a LAN guy myself, I also a highly organized Home topology. I’ve also tried to keep to all-Apple or Apple-approved devices, and don’t have Homebridge or anything like that mucking things up.

1 Like

Mine has been working about 80% of the time. The only thing that doesn’t work is when I press the controller in the home app. If I do I just right I can get it to work most of the time…

1 Like

@Macsterguy This issue that you’re reporting here seems have occurred after the 15.4 update. There are other device manufacturer’s that are experiencing this as well. I am trying to get an answer as to why it is happening and will update here when I do. I’ve looked through some other product forums and it seems to be consistent with what users are reporting here; you have long press on the icon - or if you get a blank screen you have to back out and open up multiple times. It seems like it mostly occurs on iPhones/iPads but it seems like Apple Watches and Macs don’t have the issue.

I can confirm this is accurate.

Until Rachio resolves it I have moved to Homebridge.

Thank you for jumping in, I think you should do this more often. I don’t think the silence from Rachio on this thread helps.

1 Like

This is noted. I do read and document this thread everyday. I’ll try to leave comments where it is helpful.

1 Like

If you get a moment and it’s not too much effort, would you DM me your network topology (or post in this thread if your comfortable with that - although this is not necessarily related to HomeKit - DM might be best, whatever is easier for you) - and also the firmware version that you were upgrading to.

If you get a moment and it’s not too much effort, would you DM me your network topology (or post in this thread if your comfortable with that - although this is not necessarily related to HomeKit - DM might be best, whatever is easier for you) - and also the firmware version that you were upgrading to.

Hi @dane

Public is ok. My network security doesn’t rely upon obscurity :slight_smile:

From a network topology perspective it can’t get any simpler: It’s a “flat” LAN/WLAN topology:

Internet <-> router <-> switch (backbone) <-> LAN/WLAN

The border router has both primary (Comcast Business High-Speed Internet w/static IP) and fail-over (T-Mobile 4G LTE) Internet connections.

The “backbone” switch feeds everything on the LAN/WLAN. Some directly, some with intervening (additional) switches, and, of course, APs for the WLAN.

There is a LAN server (Linux) that provides dhcp and is an authoritative dns server for the LAN. (It also provides file [nfs and smb], ntp, email [smtp, imaps, submission], ssh, ftp, dlna, web, etc. services.)

There is a dhcp pool for “unrecognized” MAC addresses, but every known device has a reserved assignment.

All network infrastructure bits are commercial-, prosumer- or carrier-grade hardware and, other than a couple WiFi bridges, on UPS’.

In all: There are over forty devices on the LAN/WLAN side, consisting of network infrastructure, servers, desktops and laptops, mobile devices, and IoT thingamajigs.

The WLAN used to be served by a single EnGenius EAP1300 WiFI AP, located on the ceiling, almost exactly in the center of our ±1300 sqft. ranch house. It adequately covers the entire home, corner-to-corner, incl. the basement, on both 2.4GHz and 5GHz, as well as the attached garage and the patio at the back of the house.

I do not have band-steering enabled.

The Rachio3 irrigation controller is located on the back wall of the garage, just outside the connecting door to the kitchen area, 30-35 ft. from that AP.

The three HomeKit hosts (when I was using it) were Apple TV 4K’s. Two on WiFi, the third wired.

The Rachio3 was rock-solid. And I do mean rock-solid. It never once hiccuped–even through power failures and restoration.

However: During that time my network infrastructure never went down, either. (Though the Rachio3 and the ATVs did.)

When the trouble started was when I added an EnGenius ENH1350EXT AP to our shed (aka: the “µBarn”) about fifty feet behind the home, to give the back yard WiFi coverage. (It was backhauled via a Comtrend G.hn poweline Ethernet bridge. It’s now backhauled via an Engenius ENS500-AC 5GHz WiFi bridge.)

Even then the trouble didn’t appear right away. It was when I was in the process of updating the firmware on all three EnGenius devices, and it went Horribly Wrong on the main AP in the house, that things went south. What happened then was a number of devices, unable to connect to the AP in the house, thought “Oh look, another AP on the same SSID” and moved over to the one in the µBarn.

After I got the home’s AP straightened-out I went into the µBarn’s AP and “kicked” all that stuff off, which also caused their MAC addresses to be permanently entered into an access deny list.

I suspect that’s when things went south for the Rachio3. (Though it could have happened earlier, and I simply hadn’t noticed?) I suspect that it “sees” the same SSIDs on that AP, tries to connect, cannot, because it’s MAC address is denied on it, and gives up, rather than find the other AP and try it.

I do know that, the first time I found it off-line, I re-did the WiFi setup and it came on-line. Yesterday evening I noticed it was off-line again.

I just this morning added another SSID to only the in-home AP and associated just the Rachio3 with it.


I’m new here. Without an avalanche of trashing Rachio, can I please get a recap and current status of the HomeKit issue? I realize from reading this forum that some of you have been dealing with issues for a long time. I can appreciate everyone’s frustration but I’m not looking to turn this into a gripe session, I just want to get an honest assessment of what the problem is and what’s being done about it as a latecomer to the party.

I am a new user and purchased a Rachio3 specifically to add to a robust HomeKit setup. I can’t even get the Rachio to show up in HomeKit to attempt adding it. I see other’s screenshots so it looks like at least at one time it did connect for some of you.

Mine is connected to my wifi and I can use the Rachio app, but I’m a little frustrated that I can’t use it for the specific reason I bought it.

It is part of my job to recommend HomeKit compatible products and right now I have to suspend this from the list, since I can’t speak from any experience at all what it can do.

My key learning points right now are:

  1. How do I get it to appear in Home app to setup?
  2. How do I connect it to Home App?
  3. What exactly are the issues with its compatibility?
  4. What is the projected time frame for the next firmware update?
  5. How long are we looking to see the final fix so I can resume recommending?

I’ve witnessed other products’ success in resolving issues (IKEA Trådfri, Leviton 2nd Gen switches and dimmers) and I think that should be to goal here.

In short homekit works for some people but doesn’t for others. Sometimes a reboot or reset will fix it while for others it doesn’t. Nothing has really change wrt this in the last couple years. Doesn’t seem to be a definitive answer on why. Rachio team had to hire a firmware engineer to try to debug. They have been able to reproduce the error but no fix yet. And no ETA.

1 Like

FYI @dane one OBVIOUS problem (I’m also a long term network engineer, and I know it’s DEFINITELY not my network) is that the mdns from the Rachio device stops broadcasting. Cloning it (I posted a link to this previously in one of the threads) has kept it working, or at least visible, in Homekit. I check it intermittently and maybe 20% of the time I see the mdns info from the device, 80% of the time only the clone. I can tell you (as a IOT developer of Homekit devices in the past) this isn’t an uncommon problem with other devices as well.


What are you using for a WiFi network?

I know of at least two wireless networking products that have been known to interfere with certain service broadcast traffic–incl. MDNS.

That’s not the way MDNS works. MDNS works by devices sending a broadcast querying for devices that match the query. The devices listening that match the broadcast query send broadcast responses.

E.g.: I’m sitting here with wireshark running, watching for MDNS traffic originating from various /24 subnets on my network. The subnets with devices that aren’t often asked about generate no MDNS broadcasts… until I run Flame (a Bonjour browser) on my iPad or mdns-scan on my Linux box. Then those devices generate all kinds of MDNS response broadcast traffic. This includes our Rachio 3.

Conversely: The subnets containing our Apple devices (Apple TVs, Apple mobile devices) have frequent MDNS response broadcasts, because other Apple devices are constantly asking “Where are youse guys” questions.

If everything on a network constantly sent unsolicited “Here I am! Here I am!” broadcast traffic, a busy network would be overwhelmed with repetitive broadcast traffic for which many devices would have no use whatsoever.

1 Like

Thought this was strange.
I switched which Apple TV is my hub and all my devices connected except the Rachio which I had to power cycle to get it to reconnect.
So the Rachio talks directly to the HUB for HomeKit?

The only way that IOT devices can work in HomeKit is thru a Apple Home Hub. Apple TV, iPad, Apple speakers… I think is all there is now

Apple TVs and HomePods are the only devices that are constantly on your home network, if they are kept powered on. They are the only devices that would allow you to control HomeKit devices from your phone, iPad or macOS computer, when you are away from home and not on your home network.

Those mobile devices can be a hub, but are obviously not tied to the home network. During times, when they leave the home network, no Automation can run, therefore.

1 Like

But the Rachio uses WiFi.
I thought the hubs were just for remote access and automation.