Gen 3 won’t connect to wifi

OK, so this sounds like a firewall issue. One approach is to confirm that by connecting to an alternate network. Do you have a mobile device that you could set up as a temporary hotspot? If so, reset Wi-Fi on the controller and try to set it up on the hotspot.

Alternatively, please post some details:

Router make/model? Any non-default settings? Signal strength at controller? If router does not have a public IP address on its WAN interface (double NAT), also post modem make/model and any special settings in it.

Thanks for the suggestions @Stewart.

@fredbastien If you want to run this and provide the generated code I can have the engineering team review your network details.

:cheers:

I had this issue today.

Rachio 3 would not connect during setup. It would hang at the yellow light, and the app would show the oops message.

What I did to solve the issue:

Start the setup on my Android phone
Select the network, enter the password
While its sitting there doing nothing, I set up the wifi connection on my MacBook
When the phone detected the setup was complete, the app progressed to the next setup step.

Clearly the wifi setup on android need some work.

2 Likes

I really need to get my controller working ASAP. I had a application of some strong fertilizer and they recommended using the sprinkler few times before I let my dog outside. It’s not expected to rain these days.
I’ve tried everything possible - old Android. Iphone. I’ve tried the .bat file for windows, which does a REST request to /config end-point. I’ve tried to manually run the http client (curl) to POST the serial and wifi credentials - it returns HTTP response 200 OK, but it actually does not get my controller online!

My support # is 769491
My RouteThis code is NNBDMSAF

(BTW, why is this support site requiring different account from the main rachio one?)

I have the same problem and I already tried the wifi reset button 3 times. I’ve also tried both 2.4G and 5G, no dice.

I bought mine from Costco.

My phone is Galaxy Note 10 Plus.

This Rachio 3 is a replacement unit. The first one (from Amazon) set up without a hitch.

I’m replacing it because Costco was selling it $30 cheaper.

Do you have another mobile device to try other than the S10? I believe we have seen issues with that particular phone. iPad, iPhone, Android tablet…

:cheers:

1 Like

I believe iPhone 11 and Samsung S10 have issues with initial pairing (with a certain batch of controllers). Other iPhones, iPads, Android, Tablets should work. After connecting the controller to the internet any phone will do.

Also, is there a way to create a dedicated network that is either 2.4 or 5g and name it differently than what you currently have? It looks like you are running a merged network.

:cheers:

Hi franz,

Thanks for your reply. I have pixel3, and like I said I tried all kinds of devices including my old Samsung Galaxy7 which has not been used for 2+ years, and windows, and hitting the Rest API directly. So, it must be the network.
I was able to connect it to a mobile hotspot (hosted on pixel3) using the app on a iPhone. It did blink a lot (perhaps it was doing software update) and then the light went away completely (per settings) which suggest that it was all set. Unfortunately right after that I decided to try to connect it again to the main Verizon Fios network and it failed again. Then it failed to connect to the pixel3 hotspot!!! The app thinks that it’s connected - not issues reported while the device lighting in blue/red colors. The Firmware version is iro-firmware-hk-5-632. There is no way to tell if this is latest firmware (why don’t you add a date?). There is no way to do a health-check the device from the app. If I try to turn on one of the zones it just spins forever.

BTW, since the app thinks it’s still connected - how can I tell which wifi network it’s using? The app has an Update Wi-Fi Network option only. Is there a way I can connect to the device via SSH and look at the log files?

This is the latest firmware and should work with any phone.

What failure are you seeing? Can you create a dedicated 2.4g network with a different name of the mesh 2.4g/5g network you have and try connecting? This shows how to update the WiFi network.

If you go to controller settings --> technical info it will show SSID information.

:cheers:

If there is also a way to bypass the range extender and connect directly to the router that can eliminate some variables.

:cheers:

OK, it shows my temporal hotspot: pixel3 as a wifi network! Why is the app not recognizing that the Wifi is Off? I did turn off the hotspot.

The failure that I saw on the iPhone is “Unexpected error occurred” or “Unknown” or something like that. I’ll capture the exact message next time I get it.

I am using latest Verizon router which was released at November 2019: G3100
You will have lot of customer complains if you don’t figure it out, since Verizon will start rolling it out to everybody.

I will try to create a dedicated network for it now, but I don’t get why are you not taking on the opportunity to assign somebody to debug it with me?

You will have to go through normal support channels (https://support.rachio.com) if you would like to work directly with an agent.

:cheers:

This is par of my first message - what else do you need to get me connected to your support?

Its just a queue, and when they get to your ticket they will reach out. I was trying to help out to see if we could bypass that team since they do have high volume at the moment due to in-season.

:cheers:

OK, Understood. Thanks!

I am connecting directly to the main router, which is just 2ft away.

I was able to connect again to the mobile hotspot (on the 2nd try). FYI - this is a good temporary workaround. The system is running now, so it is not urgent for me anymore.

I’ll wait for support to reach out to get it connected to my main network.

Thanks again for your help.

1 Like

Key: 6RTR53WR

@fredbastien It looks like your firewall might be blocking ports we use?

Screenshot%20from%202020-05-21%2010-56-20

:cheers:

Galaxy Note 10 Plus worked with flying colors the first time.

I have a Galaxy Tab S3, I’ll try that on Sat.

Thanks Franz!