Gen 3 won’t connect to wifi

Do you have a firewall blocking ports? According to this that could be one of the issues.


Thanks for your reply, Franz. No I don’t have a firewall. However, one of the great Rachio community friend here helped me to sort out that it’s due to my iPhone 11! I finally was able to use an older device to reset Wi-Fi network. Thank you for your time anyway! :slight_smile:
(Sorry that I replied here late. I didn’t get any notification from website that my question here was answered… :frowning: )

Ok great, glad you got it sorted out!


Hi. I am having the same problem. I can’t re connect my gen 3 controller to my new WiFi network. Pulses yellow but when I try to connect it says error occurred can’t connect try again. Please help! Attached is picture of Rachio lights. Also did the diag test with route RouteThisHelp. My key is GJM4FPYE.

What are the old and new networks?

Did the Rachio stop working when you changed Wi-Fi? If so, did you set up the new network with the same SSID and password (otherwise you would have to reconfigure every Wi-Fi device) and try simply rebooting the controller?

Or, did you lose the Wi-Fi connection some days after changing Wi-Fi?

Can you see (with your phone, laptop, etc.) the Rachio-xxxxxx network being broadcast by the controller? If none of your devices show the network, try Wi-Fi reset:

If you still don’t see the Rachio-xxxxxx network, try a factory reset. Use Option 2 but don’t remove the controller from your app:

If you do see the Rachio-xxxxxx network but still get the error connecting, try from another device. A tablet or an old phone without a SIM should be fine, as long as it can connect to Wi-Fi, install the app and run it.

If you still have trouble, post details of what you have tried and what resources you have that may be useful (phones, tablets, laptops, etc.)

Hi, first time caller. We are having a similar Wi-Fi connection problem.

If you want help here, please post details (about your network, the devices you have tried, what you see on the controller and in the app, etc.)

Or, try calling 844 4RACHIO (844 472 2446)

The solution to wifi connection can be found here.

Connected and up running flawlessly on Google WiFi and my Samsung Galaxy Note 9.

1 Like

I have tried these steps and I am getting nowhere. I need some help please.

(1) I have had my Rachio (gen3) working for some months
(2) For some reason, it has been showing “offline”
(3) Went outside (iPhone 12mini, latest iOS) and tried the steps.
(4) The problem is that I never get to “yellow”. There’s a solid blinking blue in sector one, seven times, and then a solid red one time. Then the sequence repeats.
(5) I’ve pressed the WIFI button and held it as well. Nothing changes this sequence (to the best of my understanding)
(6) Even though I did not have a Yellow Pulse, I still clicked on the app to configure wifi.
(7) It found the Rachio, and did its thing, but ultimately it came back with an error message (“something went wrong”)
(8) I did all the above steps also with an iPad Pro. Same results.

Incidentally, when I initially pressed “troubleshoot” in the app, it asks “which light section is blinking”, since it was the first section blinking solid blue I select “1”. But then it asks which color, and the two options are “white with red” or “red” (I think)… For sure there’s not a “solid blue” for some reason. In any case, if you select either of those two color options in the app, the advice is to power cycle the device…which I did, out of an abundance of caution.

Of course, everything else connecting fine, have had same network setup for months, etc.

Please help. Thanks!


I was in the middle of posting that I was having the same issue, but as I was running through my steps to make sure everything was correct, it connected!

My phone is LG V40 ThinQ, running Android 10, and it did not work. My problem was one I have not seen mentioned. After entering my network info, I could see the app screen saying it is trying to connect, but I also kept having a pop up box asking which network to connect to, with only the Rachio network appearing. Anytime I clicked on the network or on “Connect”, I would get a toast saying “Connection successful”, but the box would immediately pop up again. Clicking “Cancel” would cause the connection to fail. I know if it ever tried to connect. My phone screen times out after 5 minutes, I think the longest I was able to let the app run was around 15 minutes. The app screen never changed, saying connecting with the “Select Network” pop but box. When I would unlock my phone it would be at the fail screen.

What worked was the laptop method, some combination of running the connect script and power cycling the unit (a few times each) worked.

If it matters, RouteThisHelps key DC8YRE5K
I also saw it update the firmware twice (not sure if two updates or if the first one failed)
Wifi is Google Fiber, just the base unit (no extenders or mesh or anything)
In the US
Gen 3e model

Again, everything is working now, this is more FYI to the support team and maybe helping future people reading this forum.

I don’t know if the instructions say so but when configuring an iot over WiFi using Android it’s a good idea to put the phone in airplane mode and then switch wifi back on. Android tends to switch back to mobile data if wifi has no route to the internet.

I have found that many iot devices don’t handle certain wifi configurations well. Some can’t handle wep. Some can’t handle wpa3 or even wpa2/wpa3 mixed mode properly. Many can’t handle mesh modes or even shared ssid’s. Remember that guest networks are isolated access points where clients can’t see each other directly.

Franz. This is my second Rachio. Same problem both times. Impossible to connect. I spent 4 hours connecting my first one. I’m already 2 hours into this one. I’ve tried samsung s10, iPhone 12, wifi reboots, router reboots, unplugging the device, removing the device and replacing it on the app and RouteThis Helps app. I don’t want to give up on Rachio, but this is getting crazy. Pleeeease help.

Is the first currently running at the same property? If so, that’s great, because we are certain that your Wi-Fi and router are compatible. Otherwise, describe your network.

What other devices do you have that may be useful in setup (old phone with no SIM, tablet, Mac/Windows/Linux laptop or desktop computer with Wi-Fi)?

This is at a rental property. I don’t have any other devices with me. I can bring a tablet or a laptop if I need to. How would that help?

Most likely, you have one of two common issues:

  1. If you can get the controller into the ‘awaiting Wi-Fi’ state (quadrant 2 blinking), but it remains in that state after attempting to set it up in the app, your phone is incompatible with the old firmware that the controller had when shipped. One workaround is to use e.g. a tablet with an older version of Android or iOS. Another is to use a laptop (easiest with a MAC); see

  2. If the controller advances to the third or fourth quadrant blinking, but doesn’t come on line, this is likely a router/firewall or Wi-Fi access point issue. A quick way to confirm this is to set up a second phone as a temporary mobile hotspot, and connect Rachio to that. If that succeeds, post details about the network environment – with luck a simple settings change will fix the problem.

1 Like

Thanks @Stewart @Colleenshane1 What error are you seeing?

What iOS version are you on? I know older firmware had issues with a hardware change from phone vendors (

If you run this and provide the generated code I can have the engineering team review.

Here is the code: WYX6PBMP. Please advise. I’ve been hand watering every day since I bought the rachio. I even tried following the DOS prompt solution that can be found in the rachio community forum as a solution. Didn’t work.

THIS!! I have two devices that I could NOT connect, the Rachio being one. After finding your reply, I was able to connect my Rachio. Still working on the other device.

Hi Stewart,

I think what you have described is my problem. How/ to what do I change my settings?