Wireless flow meter stopped working and won't pair anymore

I’ve got a gen3 controller and wireless flow meter which worked flawlessly for 6+ months. Then earlier this month, the flow meter stopped reporting any measurements. When I started poking around, I noticed that the app shows the flow meter as “Disconnected” and that it “Requires Pairing”. However, I cannot get the meter to pair anymore. I’ve tried swapping in new batteries, I’ve confirmed that the green LED flashes when I re-seat the batteries, but none of this allows the meter to pair. I’ve also tried power cycling the controller. No luck.
Please help!
(Note that I also filed support request #726641.)

have the exact same issue after a firmware update

FYI, Debora R. (Rachio) responded to my ticket… she had me do a factory reset then repair and it did the trick! So if you have that issue see the below response from Tech Support:

Debora from Rachio Support, here, thanks for reaching out. I’m sorry to hear you’re experiencing this unfortunate issue with your flow meter.

You said to me on the phone that you already changed the batteries and the light continues blinking. Is this the green light?

Befoe anything, would you mind trying to do a factory reset and then reconnecting your controller? Don´t worry, all your settings will be kept in your app.

To do a factory reset, please follow these instructions at your Rachio controller:

  1. Unplug the controller for about 5 seconds
  2. Plug the controller back in and hold down the Stop Button (top of the white circle). The light bar should illuminate orange, once it flashes Blue you can release the button.

Once you have completed these steps, go into your Rachio app, click on the " More" tab > Controller Settings > Update WiFi.

If you still have issues to pair the flow meter after that, another possibility is that the flow meter may be too far from the controller, or there may be obstructions (such as objects, walls, soil, etc.) preventing pairing.

Take the flow meter to the location of the controller. Remove the batteries, then put them back into the flow meter, and check the Rachio app to see if the pairing is successful.

If it pairs at this point, the flow meter installation site is too far from the controller, or there is other interference.

Are there objects between the flow meter and controller? If there are, move them and try to pair again.

Please let me know if this is successful for you! I will look forward to hearing back.


Yup, this worked for me. Be sure not to ‘remove’ the controller in the app, or you’ll lose your configuration. Just do a factory reset using the ‘stop’ button on the controller, and then repair the wifi using the app. After that, you should be able to pair the flow meter. Note that I was advised to ‘remove’ the flow meter in the app before starting this whole process. So, once wifi was repaired, I had ‘add’ the meter in the app, re-scan the serial number, and then cycle the batteries to trigger a re-pair. Win.

fyi my flow meter stopped working again-- will try the same method this afternoon

1 Like

Bad news. A week later, the pairing was lost again. However, now, there’s no option to ‘remove’ the flow meter, or to re-pair it.
So, what’s the appropriate process to correct this now? Same? Different? And why does this keep happening?

1 Like

2 of my 8 R3 controllers updated to 632 yesterday. The flow meter became unpaired (again) on both of them.

I had to perform the @Deborah factory reset on both of them for the flow meter to pair back up.

Is this going to happen on every firmware update going forward? It’s not very hard to do, but driving to 7 locations around town and wasting both mine and renters time doing it sucks. This is the 2nd time this has happened to me (631 and 632).

Can we get an official word on this please?

I’m still at 615 and don’t wish to go beyond that until any HomeKit &/or WFM pairing issues are resolved. Did your R3 controllers update automatically? Hope not. I was under the impression that f/w was manually updated via the app. My controller is still in Standby from late last fall but will be firing it up soon. Don’t want to be surprised with a forced f/w update.

Controllers said update available in the app so I manually updated them. Was not forced.

1 Like

@though @Deborah @franz I’m having the same issues. Saw the available update today and manually started the update. Once finished, the Rachio Flowmeter is disconnected. What is the “factory reset procedure”? Remove batteries and reinstall?

For flow meters you should have the 615 firmware (you can view by going to the technical info section in the app under device settings). If you don’t have that I will have the engineering team get that onto your controller. If you do have it these steps will help you connect the WFM.


@franz As of today I have the 632 firmware. I hit the update button and it updated from 615 to 632. Didn’t realize I wasn’t supposed to update with a flowmeter installed. Can you please have the engineers revert my controller back to 615 please? I want the flowmeter active. Thanks!

@franz what info do you need from me? Is this enough?

unpaired— AGAIN, rather annoying this keeps happening

my controller version is 632

I guess i’ll do a reset and restart of my flow meter (I did not have to repair, just restarted my meter)

@franz, how do I get my firmware downgraded? I’ll pm you my info

My problem is the same. As of today I have the 632 firmware. I hit the update button and it updated from 615 to 632. Didn’t realize I wasn’t supposed to update with a flowmeter installed. Can you please have the engineers revert my controller back to 615 please? I want the flowmeter active. Thanks!

If I do the suggestion above to reset controller do I lose all my settings? I do not look forward to setting up all my Zones again.

I’ve also sent requests to support/customer service via the app. Only get Auto-reply that they’ll respond in 24-48 hours. More than a week has gone by and nothing but crickets. Very disappointing…

i pm’d franz and he had it taken care of on the back end

he said some flags were not set correctly, fixed it and had me reboot

Feature flags set, should be able to reboot and good to go :smile:


@franz, does this feature flag setting fix apply to all of us with -632 and these flow meter disconnection problems?

@nick1 Yes, if you power cycle the controller should be good to go. I had the engineering team verify you do have the correct feature flags.


So a reboot followed by pulling battery on WFM got them to sync correctly. Rebooting does not lose settings, so that was a big plus. I am using 632 firmware and Wireless flowmeter with no issues for the past week.