Unexpected error during setting up wifi

I bought R3 last year from Costco and have not been able to setup wifi. Every time getting error “an unexpected error occurred. Try again”. I tried on iPhone 8 and iPhone X on ios 14.6.

Pls help with wifi setup also while I figure out wifi is there a way to manually run sprinklers.

Does this thread


describe your issue? If not, please provide more details (light codes, step where error appears, ISP, router/firewall, Wi-Fi access point(s), etc.)

Unfortunately, manual operation is very limited; see
https://support.rachio.com/en_us/rachio-3-manual-controls-ryBTDLkFP
However, that will at least allow to test the system to confirm that it is wired and plumbed correctly.

This is really annoying and a big problem right now as it is close to 100 degrees here and don’t want to have my grass die.

This device is faulty and I have tried everything and nothing seems to be working and since manual options are limited for scheduling, so it is sort of useless device for me. Can I get new device?

Here’re the troubleshooting steps followed:

  1. Clicked on troubleshooting on app
  2. Selected second section since yellow light blinking
  3. Airplane mode turned on
  4. Wifi reset done on device
  5. Accessory setup finds wifi name. Selected wifi and it says joining wifi
  6. After sometime get the “unexpected error”

Let me know if you need any other details.

Possible, but IMO very unlikely. See

https://support.rachio.com/en_us/light-codes-(rachio-3)-B1t8wUkKv

What are the light codes before running the app? It should be Awaiting Wi-Fi.
What are the light codes after running the app? If it is still quadrant 2 blinking, use a different device to configure the controller. What do you have e.g. other mobile phones, tablets, laptop computer (Windows, Mac, Linux)?

If the lights advanced to quadrant 3 or 4 blinking, please post:

ISP? Modem make/model? Separate router/firewall, if any? Separate Wi-Fi access point(s), if any?

Before and after running the app same light code (yellow blinking in second section). Did use different devices (iphone 8 and iphone x).
ISP: Xfinity
Modem: Xfinity XB6 , also known as the Arris TG3482G
I have another wifi access point (orbi RBS50) and that also is not working.

See
https://support.rachio.com/en_us/issues-connecting-to-new-model-iphoneipad-and-samsung-phonestablets-HJIBvLyFv
Or, if you have access to an Android phone or tablet, older iPhone, or an iPad, try that.

Thank you Stewart for your help. I connected using my iPad and looks like firmware also updated as I’m able to connect from my phone. This must have been issue for many users, may be add this step of connecting using iPad/laptop to your troubleshooting steps it self so users don’t have to go through this pain. Thanks!