Smart Hose Hub Firmware Upgrade Keeps Failing

I have a smart hose timer and the iOS app keeps telling me there is a firmware upgrade for the hub. I’ve tried the upgrade 20+ times and it gets right near the end, and then stops there for about 10 minutes then fails with a message to power cycle the hub and try again. I keep doing that but still cannot get it upgraded. Any ideas how to get it upgraded?

1 Like

I’ll follow up with our customer success team and let them know you are having these issues.


Thanks, this is all I get from the iOS app.

@ddeacon22 You should be good to go. Thank you for your patience.

Base station and valve have been updated to latest firmware.


1 Like

Well that was easy…thanks!

1 Like

Can you help me, I have the same exact problem. 2 hubs update required and fail to update, very frustrating.

Everything looks updated already, what issues are you having?

It still pops up the Hub update failed when I load the app

Can you close the app and re-open?


I just did, problem not showing anymore, did you do something? I spent 2 hrs in tech support and they were not able to fix ir.

@JOSEIBARRA There is an update flag that looks like was not getting set correctly on your base station.

I will work with the engineering team on troubleshooting why it didn’t get updated correctly.

You should be good to go.


1 Like

Thank you so much I am amazed with the support.

Thank you for your patience.

Hi- same issue on two of my smart hose timers. The firmware keeps failing on iOS. I’ve moved one of the timers right next to the hub, restarted the hub. Same issues

I am also having this problem.

App keeps telling me I need to update, but it never finishes, and when I later go back to the app, it says the update failed.

I will have the team look into this for you.

The hub is being updated currently. I will let you know when the team responds that the update is finished.

This exactly what happens to me. I have tried I plugging the hub and that doesn’t help. I have tried resetting the hub and that doesn’t help. I have tried deleting and the re-installing the hub and valve and that doesn’t help. I have confirmed that the hub is connected to my WiFi network. I am very frustrated. Do I even need the update?

1 Like

I have the same issue. One of my hubs updated one will not. I have tried resetting and moving the hub closer to the wifi router.

I am having the same issue, updates continue to fail. Restart hub and app not helping.

I see posts that the problem has been fixed but I don’t see any solutions posted?