Rachio Wifi Drop - Replacing Unit?

I have a Rachio 3 that is three years old. It has worked flawlessly up until a few months ago. I started getting notifications that the controller was offline and the lights would be flashing on the unit. When I followed the troubleshooting steps in the app it has never worked to fix it. However, if I unplug it and then plug it back in it seems to work for a few days to a week at a time before it does the same thing. I have the same internet service (AT&T) and wifi mesh network (Amplifi Alien) as when it was working so that hasn’t changed. The fact that it begins to work for a few days after it is unplugged leaves me to believe there is something wrong with the Rachio versus any wifi settings. Anything I am not thinking of? If I were to replace it with the same unit is there a way to get all the controller and zone settings to transfer over to the new one?

Starting to think that Rachio controllers don’t play well with any mesh WiFi networks.

I have two Rachio 3 units. One connects directly to the router (much more reliable); the other connects to a Wifi extender. I have had to give it its own SSID - but even then it disconnects daily.

So frustrating

I use Orbi and have had no problems with mine. I’ve seen several others posts on the community of other people who also have mesh networks where it works fine. I wish I could help you, but networking was never my IT forte. Perhaps someone else can help out.

@hcornea - I have had a Rachio 3 connected to a Netgear WiFi extender (different SSID) with no issues. I had a Rachio 2 connected to a Eero mesh system with no issues. I have a Rachio 3 connected to a Ubiquiti multi access point system with no problems.

I have had networking issues with other IoT things but traced them back to WiFi system settings - minimum speed setting. So I’d check settings in the WiFi system - minimum signal strength, speed, etc.

Thanks for the replies Linn and Dlane

I have certainly found that QoS settings in the router play havoc with IoT devices - so have those disabled, particularly the multimedia ones, which I don’t require.

The plot thickens in the case of my Rachio. Whilst it does lose its WiFi settings and need these reset (almost every 24hrs), it also “locks up” - which is clearly abnormal unit behaviour. Fixed by a power-cycle and reboot, but nonetheless a different problem.

I am in Australia with 240VAC power, and my other unit (which works fine) has a different PSU, so I’m now testing with the same brand PSU as on the other unit.

Certainly encouraged that others have been able to connect to a dedicated WiFi extender. There is hope!

@hcornea - I’m not sure if both of your Rachios are the same generation, but you could swap power supplies to see if the problem moves which would implicate the power supply. Yes, the “lock up” is interesting. Hopefully you’re on the right track. What else is on the power circuit that the problematic Rachio is on? Another test could be to run an extension cord from a different circuit branch.

It seems since this is not strictly speaking a Wifi problem, have created a new topic - with video.

Thanks for everyone’s response. I wanted to let everyone know how I fixed my problem. Giving the fact it wouldn’t reconnect back to the wifi until after I unplugged it and plugged it back in I was convinced the unit had gone bad. I ordered a new Rachio 3 and swapped them out. When I went to setup the new controller it wouldn’t connect to the wifi either. I did a lot of digging and researching online and someone recommended turning off band steering on my wifi router settings. As soon as I did this the old controller connected and has been online for days now. Needless to say I am returning the new one I bought. Hope my mistake might help someone else out down the line.


The power cycling issue interests me. Did your Rachio display go completely blank before the power cycling was required?

Just curious whether I’m seeing the same behaviour. The reboot LED sequence (other thread) suggests to me there is something else going on. Would be delighted if the unit isn;t a brick though …

I would get a message that my controller was offline. The app has you do troubleshooting steps based off what light is flashing. In my case, it was the second light. It would flash blue 5 times and then a red flash. Every time I did the troubleshooting steps it told me to do it said an error occurred and to try again. I never got it to work using their steps. If I would unplug it and plug it back in then it would reconnect. Sometimes it would be good for weeks and sometimes it was just for a few days. That same controller is solid now with the band steering turned off on my wifi. (I am using an AMPLIFI Alien mesh system)

Ok. Seems a little different to mine.
When it goes offline it has zero lights and no response, but goes to the 2nd light yellow after the reboot.

I think mine is indeed dead/glitchy. I guess we’ll see how the replacement fares.