Rachio Gen 3 frequently offline / DHCP failure

@BenB did you see this thread?

Seems root cause has been found.

1 Like

I’ve just changed AP’s and SSID. Ubiquiti AP’s connected to Pakedge router and managed switch. The controller has a DHCP reservation set. Things I’ve tried:

  • Reset Wi-Fi
  • Use fixed channel (1, 6), highest power, disable Auto
  • Reset Controller
  • Reconnect from the AP
  • Reboot Router
  • Remove and Reinstall Controller from APP
  • Disable Pi-hole during connection attempts

Not as network savvy as I should be, but all other clients are functioning normally. Controller connects with 169.254.59.144.

Is there any way to increase manual runtime until I can reestablish a working connection?

Confirm that you have disabled “Block LAN to WLAN …”; see
https://community.ui.com/questions/Block-LAN-to-WLAN-Multicast-and-Broadcast-Data-blocks-unicast-between-wireless-clients/3690e76c-4828-4307-8643-6e2722d6373c

No, but set up a second mobile phone as a hotspot. Configure Rachio to connect to that. Set up a fixed schedule with all smart features disabled. Run it manually to confirm that the system is working properly. You can now take the hotspot down and Rachio will run indefinitely without Wi-Fi, operating as a dumb timer.

Thank you. I’ve confirmed that Block LAN to WLAN is disabled. I’ll give the dumb timer a try. The controller did connect to the new AP temporarily overnight.

Hey. I took a look at that thread but I think the customer stumbled across a fix by effectively rebooting the WAP while changing various settings, and the Rachio connected. This definitely isn’t a root cause and I have confirmed that the setting doesn’t change anything.

The root cause is the DHCP broadcast packet that the Rachio is sending out; albeit somehow coupled with something on the TP-Link WAPs that don’t like doing that across VLANs.