Rachio 3e will not connect to Wifi!

I have now tried two different units. I am using a Samsung Galaxy Note 10 Plus, the regular 3 and the 3e and I cannot get anything to connect. I believe the first unit was defective as it never gave me a blinking yellow in the second quadrant after multiple attempt to reboot it, holding the wifi button etc.

I decided to try again and the new unit arrived today (went with the 3e this time) and this one blinks yellow but I just continue to get the “Oops! Could not connect” message every single time! I have Fios internet with the FIOS router. I have both the 2.4ghz and 5ghz networks on separate SSID’s using WPA2. Neither one of them will connect. I even tried, as suggested in other threads to create a Guest network. Same thing.

I then saw the instructions on support.rachio.com for connecting the Rachio to wifi with a PC. I downloaded the .bat file, I see the Rachio network on my PC wifi, it says “Connecting” but then says “Can’t connect to this network”.

I’ve wasted 4-5 hours on this between both units and this has been the most frustrating experience. It should not be this hard to connect a device to the internet! What else can I do here, before packaging this thing up, for a second time, and returning it again. :rage:

RouteThis # AUQNM74V Ran this while connected to the 2.4ghz SSID :man_shrugging:

@Frank512 Do you happen to have another device available? (Android, iPhone, iPad)

We are having reports of the Samsung S10 not able to connect to the controller after an Android OS update. The team has a firmware fix for the controller but it needs to get online first.

Thanks for your patience and sorry you are having this experience.

I do not have any other devices that would work. The two Samsung tablets that I have both have too old of an android version to install the app.

@Frank512 Apologize for the inconvenience. If you still have time to work on this tomorrow we can send you a new version of our Rachio app to your S10 that should allow you to connect the controller through a PC and after that you will be good to go. I can have our Android engineer work with you if that is acceptable… If not and you have run out of patience I understand that as well.

Have a great night.


1 Like

I haven’t packed it back up yet so I can give it one more try.

Ok thanks, we will reach out to you in the morning.

I am available whenever you guys are.

@Frank512. Sorry it has been such a pain to get your controller online. We are hoping our next release will help streamline the process and we are currently testing the new flow in our internal beta app. If you are willing, we would like to invite you to join the program.

All you will need to do is send me your email address tied to your Google Play account and once I have your email address added to our internal beta list, you can opt in via this link: https://play.google.com/apps/testing/com.rachio.iro. If you prefer not to share your email address here, you can DM me. Thanks!

Hi Steve,

Thanks, I will send you an email right now that you can reply to.

Great! I added you to the internal test program. You can opt in to this link now: https://play.google.com/apps/testing/com.rachio.iro.

After opting in, you should see an update in the play store. It might not be immediate and you can also try clearing the play store app data if it takes a while to show up. The app version to look for is 4.1.8 (13981) which is found at the bottom of account settings.

Once you have this update installed, you should be able to go through the add controller flow but now with steps to get you online via a computer. Let us know if you run into any issues along the way. Thanks!

1 Like

Thanks, I joined the beta and I had an update in Google Play for the app, but it is Version 4.1.8 (13980), not 13981. Should I be waiting for another update to show?

Version 4.1.8 (13980) should still work. I think there is only a very small change between the two versions.

Ok so the app just basically bypasses the setup process on the phone. All this is doing is directing me to the support page for using a PC which I’ve already seen and tried as I mentioned above. My Windows laptop will not connect to the Rachio access point so I can use the .bat file to send the information to the Rachio. It always just says “Connecting…” then “Can’t connect to this network” on the laptop wifi. It’s a laptop with a 2.4ghz WIFI only if that matters or not.

So at this point, the app should have added your controller to your account so the PC solution should be able to connect your controller to Wi-Fi.

Can you try going to “Manage known networks” in your PC’s Wi-Fi settings and “Forget” your Rachio controller and try connecting again.

@Frank512 If @steve.palmerin’s suggestion doesn’t work, I will send out a controller with updated firmware to you, apologize again for the inconvenience.


Hi Steve, I just tried that, the Rachio is nowhere to be found in my Known networks because it’s never been able to connect to it.

@Frank512 If you PM me your name/address I will get a controller (with the updated firmware) shipped out to you expedited.


Just so you can see what I am seeing on my end. I am not sure why it does not want to connect to it.

Ok, that sounds like the only way to get this up and running. If I had access to any other devices I would try those, but as I mentioned the other devices I have are too old of a version of android to run your app… Thanks Franz.