Rachio 3 Not Responding in Homekit (Again)

Another week on here where Rachio fails to give an update (They probably will now, seeing how we have to prompt them). I’m sure “Apple is still debugging the devices” like they have been for the last month.
Anyways, here’s to another season with broken HomeKit function (and a beta test that seems to have stalled/died). See ya next season in 2022, not holding my breathe though we will see this finally fixed. 2022 might be time for a new brand controller (about the time they announce v4 with working HomeKit,cough).

I think a useful interim solution would be to add an option to reboot the controller from the Rachio app. 99% of the time when I have HomeKit issues, the controller is still reachable from the Rachio app. Since restarting my controller is what fixes it every time, the ability to do this from the app would at least fix HomeKit until the next disconnect. Save me a trip to my shed, please.

I have a similar experience, so I added a Wemo plug to my Rachio.

This is true for me as well. It’s always “online”, this is purely a HomeKit issue.

This however has never worked for me. I’ve rebooted numerous times, done entire controller resets, and nothing.

Interesting. I’m pretty sure my issues are due to the mesh node that my Rachio connects to being kind of far from the other nodes, because my backyard camera occasionally disconnects too. The difference here is that my Logi Circle 2 camera actually reconnects to HomeKit after

Mesh is definitely not my problem. When I first got the Rachio in spring 2019, I was using a single Asus RT-68U (router/AP combo unit) and both WiFi and HomeKit worked great! Then the firmware that came out about 2 years ago borked HomeKit. I installed a Ubiquiti system (still not mesh) about 1.5 years ago and it made no difference; Rachio still connects to WiFi, but HomeKit is still broken.

You don’t think that the fact that the Almighty APPLE has had this thing in testing for 5 weeks without an answer says that this is something beyond a simple firmware issue?

1 Like

cmon man. we all know rachio isnt serious with getting this issue fixed. What other device do you know of, has taken almost 2 years to get basic homekit functionality working? Just more smoke and mirrors from this company. Wouldnt be surprised if Apple was never sent the units.

And ill ask again why is this company still advertising this product as homekit compatible? Still shows on amazon.


1 Like

That implies Ring actually started to add HomeKit.

It never actually made it into the product…and they have the excuse of being bought by Amazon ( who hadn’t made any effort to add HomeKit to any of their products ).

At least the Ring web API has allowed for some decent performant plugins to be written. The Homebridge plug-in runs rings ( pun intended) around the native Arlo interface.

Ring doesn’t advertise HomeKit compatibility on the box. I have to use a Homebridge plugin to get my Ring cameras in the Home app, which I hilariously also have to do for Rachio.

1 Like

@dane any updates?

Yeah, they’ve found a hole in the ground so they’re all looking into it.


Still waiting… even on the beta firmware, still doesn’t work and can’t get it to appear inside HomeKit. I’m going to look into Homebridge solution, anyone know if that will work?

Hello @eggyacid, I can confirm the homebridge workaround works.

I have no idea why but I’m glad.
Ever since I turned off IP6 in my router it has stayed online and even reconnected after power and internet outages.

My WiFi is five Apple Airports all connected by ethernet cable to my router.

I too am reporting back in to let everyone know that my Rachio without any work-arounds is still working perfectly :+1:t3:


I must admit, I have missed your regular updates!

Haha, I miss you.