Rachio 3 Not Responding in Homekit (Again)

Once this current step is completed, what are the remaining steps that at least need to happen between now and the update being pushed to all Rachios? This gives us a feeling for how close we are to a full resolution. Franz, your updates are extremely appreciated and I’d like to say thanks for you providing these. I keep checking back in.

As I’m totally frustrated right now after spending a long time reconnecting and then re-adding it back into homekit made even more Difficult as now you have to use a settings app and then switch back to the rachio app in order to add it back on. Took a bunch of tries.

So when can we finally get this very overdue update and how is it pushed to our controllers?

We are having v a lot of storms. Every damn time my power goes off for even a few minutes I have to reconnect the Rachio again.

So frustrated…

Where is the fix we were promised over a year ago?

1 Like

It’s finally dead!
Tried for over an hour to reconnect.
Tried restarting my network and iPhone. After over an hour of trying it will not join.

Time for a class action lawsuit

2 Likes

You serious?

1 Like

That’s what I thought.

They know there is a problem. They have worked out what the problem is. They are working on the problem.

Why is there any need for a lawsuit?

Exactly, at least they acknowledge the issue and appear to be working towards a resolution. If you want to talk lawsuit take a look at Ring - we have been waiting 4+ years for the promised HomeKit support.

It blows me away that mine works perfectly and in the few occasions where I’ve had to re-add it it was not a problem at all to do…

I have said this before In this thread, no need to respond… I find Rachio HomeKit integration nearly useless. You can turn it on and turn it off. You can do the same and much more in the Rachio app. I was watching some neighborhood kids on a security camera the other day playing in the front and gave them a good soaking. That’s about it

So why does mine work? It has got to be my router and how it handles IOT traffic. That’s all I can think of. It is as solid as a rock. It’s made by Synology check it out. I have both models they sell set up as a mesh network.

When Rachio gets this sorted out, if they ever do, you watch, mine will break and everybody else’s will work… I would consider that no loss at all and I started this thread…

Rachio is a excellent irrigation controller. I have told many people to buy one that ask about it. ***Unless they want HomeKit to work!

At the very least, Rachio should remove any mention of homekit from all packaging and ask Apple to take the Rachio 3 off of the HomeKit compatible devices on Apple’s website:

But a lawsuit? Really?

3 Likes

550 posts and no answers. Time for a class action.

Did the weekly updates stop? I’m surprised we don’t have a beta out there in the wild yet…

Unfortunately yes, they seem to be random now.

OK, Johnnie Cochran what kind of an answer are you looking for? If you read the 550 posts you will see Rachio has acknowledged the problem and is working on a fix. Just like everyone else I would like to see it out today but I assume its not ready.

Update!

Hey folks, here is an in depth update. Now that the ADK is compiling with our firmware the team hopes to make significant progress over the next two weeks. Thank you for your patience.

  • Compiling with Rachio firmware - COMPLETE
  • Homekit working in isolation, without all of the necessary services and characteristics (IN-PROGRESS)
    • First try to remove old homekit implementation
    • Bring-up new ADK based homekit without most features
    • Add back functionality for the necessary features and functions
  • Once features appear to work on the hardware regression test:
    • Homekit advertises all expected characteristics and services
    • Using homekit app allows zone control
    • Homekit provisioning

:cheers:

4 Likes

Thanks Franz.

That is great news, thank you!

Hey Franz, what’s with the 632 update that was pushed to everyone? You had manually pushed the 615 firmware back to my Rachio a while back and that fixed all of my HomeKit issues… I never received had a No Response error from HomeKit with 615.

Ever since the “upgrade” back to 632, it’s been completely broken, again.

I appreciate the updates, but would like to stay at 615 until you have a suitable replacement.

1 Like

I second this. I too was downgraded to 615 at my request back at the beginning of spring, and it worked great! But it looks like 632 was pushed from your side (I know I didn’t update it! I purposefully avoided that) and I’m experiencing the same issues as I was on 632 before.

1 Like