Rachio 3 Not Responding in Homekit (Again)

Worked for me as well.

Yep, mine worked for a few weeks but once again not responding in HomeKit. Very frustrating. I paid a lot more for this model due to HomeKit support and it keeps on going offline.

Guess I get to spend another 10 minutes or so resetting it once again.

Try holding down the stop button 10 seconds (or more), then adding Rachio back to HomeKit. I can confirm that it works!

Any word on this issue getting fixed?

It’s getting real old doing the stop button reset and adding it back into homekit. The major reason I spent extra for this model was for its homekit integration.

Hey @Tzterri!

Here’s the latest update I have. I promise we’re not forgetting about you or this, its just out of our hands until we get the update from other parties.

How often are you having to do the stop button reset method?

:cheers:

It doesn’t even stay connected for a week.

1 Like

Ugh, I’m so sorry about that. Thank you for letting me know. Will keep you posted once I get an update.

I just fixed it again but did it differently this time.

Instead of holding the stop button I held down the WiFi button for about ten seconds until the led went white. Then used the radhio app to add it back in.

Got the usual error that I ignored and after a bit more time went by got the message it was added in.

As I did not first delete it from homekit I didn’t have to add it back into homekit and it was connected again. So at least there was one less step to get it working again.

So to sum it up.
Hold down the WiFi button until the led changes color. Use the rachio app to add it back it. Ignore the error message and just wait until it finally says added it. No need to do anything more as homekit shows connected without have to remove and add it back into homekit.

1 Like

Thank you for the walk through @Tzterri! Will you keep me posted on how long it stays online with this tactic? Want to make sure I’m tracking all issues and options!

I used to provide support for Apple computers under the Apple Solution Expert program. Still do a small amount of Apple support to some of my older clients. I consider myself tech savvy and a bit of a geek.

A few months ago I started replacing all my old X10 automation with HomeKit. It’s grown way beyond my old X10 system.

The Rachio was the most recent addition to my automation. I really love it. The weather intelligence setting is awesome. My pump runs a lot less and the wet and soak is great.

Anyway, just wanted to let you know if there are any logs other troubleshooting that would be helpful just ask.

1 Like

Lasted only a few days. It was working until I restarted my WiFi network and everything reconnected except the Rachio. It seems like once the connection is interrupted the Rachio is unable to reconnect without a reset.

I have a bunch of homekit stuff including a hue hub for an outdoor motion sensor. A Lutron hub for all my dimmers. A bunch of LIFX LED lights. A bunch of wemo plugs. An Ecobee thermostat. A logi cicle2 camera. A couple of OMNA cameras. Plus couple of iHome plugs. Only the Rachio is having issues.

Hopefully this info is helpful. I’ll reset the Rachio tomorrow again by pressing the WiFi button as that worked well last time.

Are there any log files that can be accessed?

1 Like


This is my WiFi network. All basestations are connected by Ethernet. The rachio is less than ten feet from the two bedroom Airports just on the other side of a cbs wall in my garage so gets a very strong signal.

1 Like

Thank you so much for all the details and troubleshooting help @Tzterri!! Will make sure the internal team sees this so we can log the issues and come back if we need anything on our end once we get the go ahead from Apple!

Mine comes back if I power cycle it.

I am not really having any problems whatsoever now. Everything is working perfectly

Down again this morning.

Getting ready to add it back in again by holding the WiFi button and then using the Rachio app.

I’m having the same issue for about a year now. HomeKit unresponsive. I deleted from HomeKit and despite holding stop to reset, cant get it added back to HomeKit.

Just had to add it back in today once again. This is getting really old.

Thanks for the updates @Tzterri! I totally understand how frustrating this is. As soon as I have an update from Apple I’ll let everyone know!

Not sure if this is helpful but I’ve noticed this behavior.

Sometimes I’ll get a no response from some of my homekit devices for whatever reason. Like maybe my internet went down or I had a brief power failure so my WiFi basestations are rebooting or maybe just aliens messing with us humans.

But all my homekit devices will come back online within a short time except rachio. Rachio doesn’t seem able to recover from a brief outage.

1 Like