Rachio 3 Model Wi-FI initializing Error, I have a RouteThis Code

My RouteThis Code: ZEZDAE5N

I tried several times to get the Rachia 3 to be discovered on the app but after scanning the bar code, it comes back a few minutes later with an error that it could not be seen.

I am using a Samsung Galaxy S8 Edge using Android 9.

System is using AT&T’s Uverse with an Aris NVG599 with Authentication Type WPA

Aris has 2.4 and 5 Ghz radios in it, my Samsung Galaxy uses the home network in 5GHZ mode.

There are no wifi extenders, my phone and even the rachio 3 selected the my home network SSID to log into.

Got any ideas to try?

Have you been able to get the controller in the awaiting Wi-Fi state (quadrant 2 blinking yellow)?
If so, in that state, can you see a Rachio-xxxxxx network on your phone?
If so, can you connect to that network? (Of course it won’t have internet access).
If so, can it remain connected for two minutes (or does it switch to mobile data or another Wi-Fi network)?

If you have a Windows, Mac or Linux laptop or desktop with Wi-Fi, this post shows a way to get the controller connected to your network:

Wont work with iPhone 11 & iOS 13.4.0 Tech Support

If no luck, let us know what resources you have available:

  1. Android or iOS smartphones, whether or not they have an active SIM card, as long as they will power up and can connect to Wi-Fi. Post make/model/OS version.
  2. Android or iOS tablets.
  3. Windows, Mac or Linux laptop or desktop with Wi-Fi.

Which of these device(s) have you already tried in an attempt to connect?

Yes, Stewart, I get the yellow blinking LED.

I just connected to the Rashio directly from my Samsung Galaxy 8, and like you said the connection says no internet, but it does connect to the Rachio. I can also see the Rachio from Desktop Windows 10 PC as a network to connect to.

After a couple of minutes of not seeing a path to the internet through the Rachio 3, my Samsung Galaxy S8 Edge drops the connection to the Rachio 3 and automatically finds my home network and connects to that, in order to get internet service.

I do not have a Mac or IOS, only Windows W10 PC with latest patches.

A couple of minutes is plenty of time for the app to do its thing, so I doubt that’s the problem. Possibly, the provisioning is working but the controller can’t work with WPA. Did you select that because you have another device that can’t do WPA2?

Try using your PC as detailed in the link in my previous post. If that fails, we will at least know where it goes wrong. If it “succeeds” (200 OK from 2nd cURL) but the controller can’t connect, report whether (after reconnecting the PC to your Uverse) the NVG shows the controller as a connected device.

1 Like

I’ll check in the morning when I have more light to see if my router can switch to WPA2 instead, without breaking other devices on the system. So Rachio 3 can’t connect with WPA? That’s should be standard, why would it have an issue with it?

I’ll try this and the link you sent me in the morning and report back, I’ll need more light coming in to get at back of router and serial numbers and stuff to gain access to the back door security settings.


Thanks Stewart, here’s what solved the WI-FI Rachio 3 controller not found issue for me. I was able to get it registered, then success came rapidly after that, got my zones all entered, and now my sprinkler schedule is complete, and I used my phone to test all 4 zones of our sprinkler system with success.
I did this based on instructions you told me to use from Zachio OS Developer @ Rachio.

My only question is why did the Rachio 3 not want to connect to my network in the first place? I am using WPA2 protocol, which most WiFi networks use these days and some are even WPA3, so not sure does Rachio3 not work with WPA2? It should work with it. Here’s my steps taken:

1) Since my Rachio 3 controller could not connect to my home network, Let’s see if home network can find and connect to the Rachio 3 access point. I went onto my Windows 10 desktop PC and scanned for Wifi networks, finding the Rachio-C219DE, so I had my desktop PC disconnect from my home network, THEN connect to my Rachio 3 WiFi controller access point, and of course there’s no internet available but the PC is connected to the Rachio 3 at this point.

2) While my desktop PC is still connected to the Rachio, let’s check if we can talk to it, so I used the cURL commands from Zach in a DOS/command prompt window, by typing CMD in the windows search bar. cURL is a command line program which sends and receives data between a client and a server or 2 machines connected over the internet.

I then got the Serial # from the bar code sticker on my Rachio 3 controller after removing the magnetic lid, and obtaining the Serial # off the sticker, I entered the following command in my DOS command window, replacing my SERIAL NUMBER below:

curl -k -X GET -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" ""

Command entered successfully! I then see output response from Rachio 3 controller that says this in the command window:


3) Next we force feed the my network’s SSID and password to the Rachio 3 controller:

I replaced SSID, SERIALNUMBER, and PASSWORD with my specific numbers with this cURL command:

curl -k -X POST -H "x-api-key: SERIALNUMBER" -H "Content-Type: application/json" -d "{\"ssid\":\"SSID\",\"pass\":\"PASSWORD\"}" ""

After this, I checked the LED bar across the front of my Rachio 3, and BEHOLD! The quadrant that was blinking yellow before was now blue all the way across, meaning Rachio 3 is now connected to my home network.

4) I then disconnect the Desktop PC WiFi connection from the Rachio 3 access point, and reconnect it to my home WiFi network to get back on internet. I look at the status page of my home network’s ATT Uverse router and now it shows Rachio-C219DE as one of my connected devices where it did not before, so now I know we are good to go.

5) Go back out to the rachio 3 controller, and start the Add Location process all over, home address, then scan bar code, hold breath for 2 minutes, and it clears past the finding controller part, and the phone app said the controller was found successfully! Then the Rachio app on my phone immediately went into the menus to start setting up the zones. Very relieved!


@JeffOstroff Sorry you had to go through all that, above and beyond of what we expect anyone to go through, welcome to the community!

@Stewart thanks for the assist.

@JeffOstroff Please let us know if you have other feedback or questions.