Rachio 3 and Ubiquiti Unifi Connection Problems

Anyone able to get their Rachio 3 to join their Ubiquiti network? I see people were having issues in the past but I didn’t see a definitive solution.

SSID: IoT with a VLAN 250. I removed the VLAN so it’s on my main network, tried joining Rachio with no luck. Within Unifi, I see a 169 IP address so I assigned it a fixed IP, rebooted Rachio, and still no dice.

I also created dedicated 2G and 5G networks, tried joining Rachio to these and no go.

I have roughly 10 other IoT devices that have no problem connecting.

I’ve used the batch file and have been able to get Rachio to join my phone network if I create a tethered mobile network.

Any other suggestions out there?

What ended up working for me was to uncheck “Block LAN to WLAN Multicast and Broadcast Data” under Settings | Wireless Networks | Advanced Options and removing the VLAN. Once Rachio established a connection, I re-added VLAN and checked “Block LAN to WLAN Multicast and Broadcast Data”

I have 4 UniFi access points. My G2 Rachio was able to connect once I used a dedicated 2.4GHz network with a different SSID than our other 2.4/5 network sharing the same SSID.

Okay doing what I mentioned didn’t work after I power cycled the Rachio. @scorp508 are you segmenting out that network onto its own VLAN?

Interesting, and given that DHCP failed (thus the APIPA address) I suspect that the controller is setting the broadcast flag in its DHCP Discover and Request messages. See pp. 10 and 22 of https://www.ietf.org/rfc/rfc2131.txt . However, I don’t understand why the VLAN caused trouble, provided that your router has a DHCP server listening on tag 250 and is otherwise set up to route packets.

I see no reason to block broadcast traffic on the VLAN; there shouldn’t be any except for two packets per DHCP lease renewal, unless your router broadcasts gratuitous ARP requests (and even those shouldn’t occur very often).

on my main, home network, the rachio will join no problem. comparing my IoT network to my home, the only differences are untagged and allowing broadcast. it’s strange, i do’nt know why. looking at older posts, people had the same issue with vlan tagging causing an issue.

VLAN tagging, per se, should not be even visible to the controller. Packets sent over the radio are untagged, the AP tags them based on the SSID. The tagged packets arrive at an additional virtual interface at the router, where the DHCP server hands out addresses on a different subnet. The firewall rules usually isolate that from the home subnet, but access to the internet can be unrestricted. Of course, traffic on the WAN interface is untagged. Tags appear only on the Ethernet between the AP and router.

1 Like

Yes I 100% agree but who knows if Rachio is doing something

I don’t, because my Rachio is gen 2. But you can capture traffic at the router, look at Rachio’s DHCPDISCOVER packet and see whether it is expecting a broadcast response.

When a device first connects to the network, it does not have an IP, thus broadcast messages are used
Rachio makes a DHCP request from to (global broadcast) asking for an IP / routing info (gateway, mask, DNS, etc).
DHCP broker than replies to the address / broadcast with the data for rachio (identified by MAC address) which is blocked with your current config.

Seems that the answer is to add your router / gateway’s mac to exception list in order to allow the DHCP messages to get back to the devices on the network, or simply leave the filter disabled (VLAN has nothing to do with the issue).

Nope, one /24 in use here without any VLANs regardless of what SSID they connect to.

There was a DHCP bug fixed in AP firmware released very recently. Have you updated?

I think I’m one version behind but I’ll check. Also going to see if Uni has something equivlanet to Cisco’s ip helper

I have my Rachio Gen2s on a UniFi VLAN and they connect with no problem. However, the setup using a smartphone can be tricky. You need to join your smartphone to the same VLAN, so that it can make contact with the Rachio and transfer configuration and credentials to it.

Also, Gen2 requires the WiFi to be 2G (not sure about Gen3). The startup handshake may not work if the smartphone is joined with 5G. This is a common problem with IoT devices that are set up from smartphones.

DHCP works on VLANs without any additional configuration in the UniFi equipment.

1 Like

Gen3 has 5G capabilities now. Re: smartphone, Rachio actually released a script that executes a curl command that updates the SSID info on it. This can be executed from a computer on the Rachio WiFi network.

I do agree this is probably a DHCP problem, I’ll have to dig in further and maybe do some packet captures.

Did you check out info here?

What hardware / router are you using for NAT / DHCP?

1 Like

From what I’ve seen with my Unifi setup, what finally worked for me was unchecking the 2G and 5G Minimum Data Rate Control, which can be found in the setup for each wireless network. Once I did that, the Rachio could get a DHCP address (I use reserved addresses), and my wireless is also an IoT VLAN, so that should work no problem.

1 Like

Yes and this was part of the solution that I saw was to uncheck this. I even went as far as whitelisting the DHCP server and the Rachio.

My router is Ubiquiti UniFi Security Gateway 3P

1 Like

I’ve had no issues Rachio 2 / UniFi, but I’ve learned a lot with Wemo, Ring, HomeKit, etc.

Biggest fix for me was to swap out the HPE switch for a UniFi switch (48-500W), which fixed a bunch of issues, perhaps most importantly restored ATT Wi-Fi assist for my iPhone 7.

My learning is that the blunt multicast option doesn’t fix things, but there is something that the HPE switch wasn’t forwarding that the UniFi switch is.

By the way, I run a 2.5 only SSID for my IOT devices, to keep the clutter away from my compute devices that use mostly 5Ghz. My apps DO NOT have to be on the same Wi-Fi network as my devices, but do have do have be on the same logical network.


If you have a non UniFi switch, you could try putting a google Wi-Fi unit upstream of the whole UniFi setup just to test.

In the UniFi dashboard, can you see that the device has a real IP address, and can you ping that? I can ping my Rachio devices from the UniFi Ping tool with 8-15mS response.

Have you looked in the UniFi events log?

Look at session history, and see if the Rachio device has a history of dropped connections and new session starts.

Does the Rachio device always connect to the same AP?

My R3 has had no issues however I’ve had problems with other devices such as the pool controller. I end up creating a new SSID just for that device and was able to rejoin the pool controller.