PWS Davis Vantage Pro 2 CWOP - "No Recorded Precip Data"


#1

wanting to use my Davis Vantage Pro2, but when I go to select it, there is an orange note telling me “No Recorded Precept Data” - is this because there has been no rain since I hooked up the Rachio, or that Rachio doesn’t see any recorded rain in the data dating back however far back it looks? I should add I just added my station to CWOP a week ago.


Use Rachio with Davis Vantage Pro2 PWS and CWOP
Flex watering after heavy downpour :(
#2

@petercw2 I know it can take a few days for the data to sync up. I would continue to use the PWS and if there is a precip event and it is not recorded I can followup with our weather provider.

:cheers:


#3

yes, there has been plenty of rain events since I began posting to CWOP (about a week before installing my Rachio) and I still am told my PWS (via CWOP) is not reporting rain data.

My data is recording and supplying the rain data in the feed


#4

@petercw2 Ok thanks. Is this a display only issue or is the precipitation data not coming through in your weather intelligence/soil moisture graphs (flex daily)?

:cheers:


#5

Not sure I understand the question. I haven’t chosen my PWS as my Rachio reference station because of the error. I don’t use Flex Daily so not sure I understand the moisture graphs.

Additionally, because I live somewhere I’m restricted to watering only on Tuesday/Sunday I’m using “Fixed Day” schedules and I assume the rain data is important in that schedule adjust how much to rain, correct? And I don’t get “moisture graphs” using this schedule? :frowning:


#6

@petercw2 Is there a Weather Underground URL or something similar (pwsweather.com) so I can forward the missing precipitation data to our weather provider?

:cheers:


#7

You bet. Here is my WU account and my Davis WeatherLink Account that originates the data from my Vantage Pro2 and sends to both WU and CWOP.


#8

Ok, I guess ultimately what I need is the pwsweather.com account since Aeris pulls data from that site.

Do you have the URL for your weather station on pwsweather.com that shows recorded precipitation that we are not receiving?

:cheers:


#9

I do not because Davis do not send to pwsweather directly… Davis does send to CWOP, which I am sending to and the reason I bought a Rachio was because of the claim it will read data from CWOP. Is that not the case?


#10

@petercw2 I’ll followup with Aeris regarding your station and precip. If it is in the list of available stations from the Choose your weather staion screen than the data is being fed to Aeris.

:cheers:


#11

it does appear (albeit with the error warning) and I have now selected it. What I don’t know is how to determine if the data is passing through to my Rachio account? Is the local weather data appearing in my account confirmation of that? Also, with the rain earlier this week, will that be accounted for in my scheduled watering tomorrow? (Remember, I’m fixed to only Thurs/Sunday) in my city.

Also, why does Rachio not simply connect directly to WeatherUnderground?


#12

@petercw2 According to Aeris this seems to be a known defect with CWOP data.

Looking here:
http://mesowest.utah.edu/cgi-bin/droman/meso_base.cgi?stn=E9355

The station is sending the data as Precip since local midnight. Unfortunately, this is the value that NOAA is not redistributing for “APRSWXNET/CWOP” stations. We have requests in to add this, but as of the end of June, we were told there was no immediate option for them to redistribute these values.

My followup to Aeris was…

If I had the customer sending data to personalweather.com would that be a “workaround”?

Their response was…

Correct, if the person is sending their data to pwsweather.com, which is owned by our company, then we have full access to their data in near real time.

Specifically, the observations from the stations are imported in our Aeris API within seconds of being received at PWSweather.com. Though the observations/summaries are updated approx every 15 minutes with the latest received data.

AerisWeather Support

IMHO possible solutions at this point are:

  • Publish data from WU to pwsweather using a solution presented here (WeatherSnoop or https://github.com/johnny2678/wupws)
  • Use Meteobridge to publish data to pwsweather.com
  • If this is too much work or cost, I’ll buy the controller back if the CWOP claim was misleading. This is the first I have heard of a CWOP limitation due to “NOAA is not redistributing for “APRSWXNET/CWOP” stations”

We do plan on having other weather options for next year (hint, hint) but don’t know if the timing works for you.

:cheers:


#13

I very much appreciate the pro active support… thank you. Let me reply to your options and point out a big point of confusion.

As for the offered options:

  • Can’t use the 1st option because that would require me having a program/script running 24/7 on a computer in my home.

  • I already have my DVP2 connected to their WeatherlinkIP device, which is the same thing, and serves my data to WU and CWOP.

  • I’m stunned this hasn’t come up before and I am a bit confused. So no CWOP clients are report data to their Rachio? That can’t be correct. On my available list of nearby stations there is another that appears to be the same Davis I use and he’s also reporting to CWOP. But there is no precept error showing for him. See attached.


#14

@petercw2 I do see precip data for MID_E8974, I’ll followup with Aeris on why these are behaving differently.

:cheers:


#15

@petercw2 The plot thickens…

Franz,

Checking here for the E8974 station:
http://mesowest.utah.edu/cgi-bin/droman/meso_base.cgi?stn=E8974

This station is sending the Since local midnight value, which NOAA does not redistribute AND the 24 hour precip value which NOAA does redistribute and we are able to utilize for the daily precipitation.

There may be a setting within his stations software to send both values. Its also possible the two stations may be using different software to send the data, though checking here:

http://weather.gladstonefamily.net/site/E9355
http://weather.gladstonefamily.net/site/E8974

Both list the software type as “Unknown station type/software: L…DsIP”

Checking the Graphs you can see E9355 only sending one value for rain:
http://www.findu.com/cgi-bin/wxpage.cgi?call=EW9355!Dallas&last=120

but E8974 sending two rain values:
http://www.findu.com/cgi-bin/wxpage.cgi?call=EW8974!Dallas&last=120

If your user finds there is a setting or adjustment that allows his station to send both values please share, as this could be a potential solution for other users who have stations currently only sending local since midnight.

AerisWeather Support

If you are able to send both values please let me know and we can see if this fixes your issue. If this does fix the issue we can also report to Aeris as a long term workaround until NOAA can put in a permanent solution.

:cheers:


#16

that is a good helpful start… let me do some research on what I am sending where and if there’s a way to adjust what CWOP is getting. thanks.


#17

Good news. I was able to correct the matter and I am now reporting the proper rain values. How long will it take for Rachio to recognize the data and cease reporting the error to me in the “change weather station” page? thanks for your help in figuring this out, btw.


#18

@petercw2 Ok great. I’ve heard up to 48 hours. If it hasn’t changed by then let me know and we can followup with our weather provider.

Can you share how this was fixed so I can relay back to Aeris?

:cheers:


#19

Yes, of course (should have offered it already)… My console and WeatherLinkIP both simply needed a firmware update. So Davis Vantage Pro 2 needs to be running v3.15 and the WeatherLinkIp v1.11. Not clear if both made the difference in combination or it if was one of them individually.


Lots of rain yesterday but Rachio does not reflect it
#20

late Friday PM, rain event early data, and have been reporting the correct data.
still showing as “not reporting” in the selection list.