(Not) Returning Rachio gen 2 (disappointed...NOT)

My controller just wont connect to my wifi…i have both 2.4ghz and 5ghz and have no problems with any other devices. Even changed the SSID to see if it would work, but no. I wasted 5 hours trying to install the controller, talking to the support team for over an hour.

Pretty disappointed how finicky this controller is. Will be ordering a different controller that actually works and is easy to setup.

Support team probably covered this, but for others in a similar situation, Gen 2 does not support 5GHz WiFi. In case your 2.4 and 5 GHz networks run under the same SSID, this can cause an issue during the setup. It’s best to disable the 5 GHz network temporarily during the setup.

It is also a good idea to avoid adding your controller to a Guest network, in case your WiFi router has this as an option. A common feature of such a network is to block communication between guest devices, meaning your phone will not be able to connect directly to the controller during the setup. In case you wish to use the guest network, best option is to disable the actual guest network temporarily during the setup. Change your primary network’s SSID & key to match your guest network’s name & key and proceed with the setup. After the setup is complete, put things back how they were and controller should be able to connect to the servers by itself.

I figured changing the SSID for 5ghz would be similar to disabling it. Do you think disabling 5ghz is the solution to getting gen2 to work?

If you’ve already tried one, and it did not work, it would not hurt to try disabling 5GHz all together. Nominally having a different SSID for 5GHz network is sufficient, but your wifi router may be having differently, especially in case it is part of a mesh network.

I disabled the 5ghz completely and still no connection. The app gets stuck at trying to add rachio to my wifi.

What model of the wifi router are you using?

tplink ac1750

Try this:
Go to Advanced > Wireless > Wireless Settings.
2. Select the wireless network 2.4GHz (should be on the top right of the page).
3. Set Channel Width to 20Mhz (let me know if it was more than than)

Retry setup after applying the changes.

my settings are already set to those.

Can you please confirm which specific AC1750 models do you use from the list here (link)?

Also what other options do you see under the Wireless Mode?

its model C7 (4th from top on that link). I see the following options under wireless mode: AP, Client, Client (bridge), Adhoc, WDS Station, and WDS AP.

I greatly appreciate your help, but seems it will take a miracle for it to work:P

Ah, no wonder your interface looked somewhat familiar, been a long time since I’ve looked at dd-wrt (could have mentioned that) :slight_smile: Did you buy it already loaded with a custom firmware?

I’m looking at what options may interfere with the setup. Now that we know what we are dealing with :wink:

Try enabling Advanced Settings and look for AP Isolation, should be set to Disabled, but if not please do so.

1 Like

Yes it ddwrt, and i did it myself.

Yes AP isolation is disabled.

Their forums seem to mention that N-Only Network Mode that you use may cause issues on some hardware (link), try switching it to NG mixed and rerunning the Rachio setup.

1 Like

Well seems like I got it to work by pulling out my iphone 5 from storage bin. I don’t know if it was just the iOS that made it work or the fiddling on my router. I am gonna revert all settings on my router next and reboot. And then reboot the Rachio and see if it still works. Wish me luck and thanks for being so patient.


Glad to hear that :+1:


Hope it works on my Android devices now that its registered. The old iphone is like a landline now - dies instantly upon removing the charging cord, Ha!

After the setup is complete. Communication is done via a central server. Device type should not matter as long as app is up to date. Bet you are happy that you didn’t trow away that phone :wink:

1 Like