Network Connectivity - Rachio with Ubiquiti UniFi AP-AC


#1

During the summer of 2015 I opened a support ticket (for the Rachio guys browsing the forum it was 75499). This ticket was related to not being able to save settings or control my iro intermittently. The primary symptom was a timeout from the rachio online app or from the iOS app when trying to change a simple setting such as rain delay. After much troubleshooting with tech support, we concluded that the issue was related to a faulty wifi module in the iro and support did an exchange on the unit.

Several months have passed with the new unit and I am still having the issue. Now with some free time over the holidays, I have done some additional network troubleshooting and have some additional info – I am hoping someone on this forum has encountered something similar and can help.

Network setup:

  • My home has 3 Ubiquiti Networks Unifi AP-AC wireless access points set behind a Uiquiti Edge Router Lite.
  • I have 2 SSIDs – the iro uses a SSID that is set to 2.4 GHZ only and is forced to the closest access point (approximately 50 feet from the iro). At one point, I did have an extender deployed, but it did not change the observed behavior - it has since been removed.
  • In earlier troubleshooting efforts, I opened up port 31314 to my network. I also have no MAC filtering deployed on my network (Ubiquiti actually does not provide a means for MAC filtering)

Newly observed behavior:

  • I have SSHed into the access point to which the iro is connected and am tailing the logs with a grep set to the MAC of the iro.
  • I am observing multiple disconnects/reconnects of the iro from the access point. A copy of the log is below (I have put spaces between the disconnect/reconnect blocks so that it is easier to see the frequency that this is occurring). I feel confident that the disconnect/reconnect behavior I am seeing is the root cause of the issue.
    - Is anyone aware of any issues with the iro that would cause it to disassociate an reassociate frequently from wireless access points?
    - For what it is worth, I have my iPhone 6 connected to the same SSIE and sitting on top of my iro in the garage. I am NOT seeing the same behavior.

Snippit from my wireless access point Log – note the timestamps:

BZ.v3.2.12# tail -f messages | grep “67:0d”

Jan 2 10:11:02 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 10:11:02 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:11:11 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 10:11:11 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:11:11 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 5687F646-00000001
Jan 2 10:11:11 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 10:12:55 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 10:12:55 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:12:58 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 10:12:58 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:12:58 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 5687F646-00000002
Jan 2 10:12:58 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 10:14:43 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 10:14:43 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:14:45 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 10:14:45 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:14:45 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 5687F646-00000003
Jan 2 10:14:45 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 10:16:29 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 10:16:29 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:16:31 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 10:16:31 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:16:31 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 5687F646-00000004
Jan 2 10:16:31 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 10:19:23 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 10:19:23 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:19:26 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 10:19:26 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 10:19:26 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 5687F646-00000005
Jan 2 10:19:26 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)


#2

I checked your last rssi and it was -76, which is barely holding on.

Generally, anything in the -50 - -60 range rssi is what we like to see.

50 feet away I would expect the rssi to be at least in the -50 range…

I’m going to forward this information to our WiFi chip provider and see if they have any recommendations.

:cheers:


#3

Franz:

Thanks for the quick response. I have also been working with Jared on front line support.

After your comments and some things that Jared mentioned, I removed the iro from its mounting plate and placed it on the floor directly below the access point to which it is connected – distance is no more than 8 feet with nothing but air between the iro and the AP.

From the perspective of the access point, I am getting 99% signal to the iro (-40 dBm). I am still observing the same behavior. Most recent logs from the access point look as follows:

Jan 2 14:11:40 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 14:11:40 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:11:42 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 14:11:42 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:11:42 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 56882DD5-00000002
Jan 2 14:11:42 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 14:12:53 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 14:12:53 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:12:56 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 14:12:56 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:12:56 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 56882DD5-00000003
Jan 2 14:12:56 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 14:13:01 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 14:13:01 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:13:03 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 14:13:03 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:13:03 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 56882DD5-00000004
Jan 2 14:13:03 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 14:15:01 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 14:15:01 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:15:03 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 14:15:03 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:15:03 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 56882DD5-00000005
Jan 2 14:15:03 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Jan 2 14:16:06 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: disassociated
Jan 2 14:16:06 UpstairsAP daemon.notice hostapd: AP-STA-DISCONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:16:09 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d IEEE 802.11: associated
Jan 2 14:16:09 UpstairsAP daemon.notice hostapd: AP-STA-CONNECTED 0c:2a:69:0b:67:0d
Jan 2 14:16:09 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d RADIUS: starting accounting session 56882DD5-00000006
Jan 2 14:16:09 UpstairsAP daemon.info hostapd: wl0.1: STA 0c:2a:69:0b:67:0d WPA: pairwise key handshake completed (RSN)

Given the above, I am very comfortable that we are not dealing with a signal strength issue.

If it helps, I am more than willing to work directly with you and the WiFi chip provider to resolve. As you can imagine, this is getting more than frustrating. I love the iro, but may have to consider switching to another device if given the connectivity challenges.

Thanks!

-D


#4

Rssi looks better, working with our vendor on this, it’s so strange it just keeps disconnecting and reconnecting.

Will let you know if they see anything out of the ordinary. I noticed you have rain sensor enabled.

Just to remove variables, can you disable that setting and remove any rain sensor wires?

I have seen those, if misconfigured, sometimes do odd things :wink:

We will get you working, if this doesn’t work I have one other option to fallback on.

:cheers:


#5

Thanks again Franz!

The iro is completely disconnected from the base plate right now so that it can sit directly under my wireless AP :smile:

I have disabled the rain sensor setting in the app.

So far, the behavior persists.

D


#6

I’m running my rachio on the ubiquiti lr without issue (. I’ll bet $100 you’re using zero handoff? I have a suggestion for you, the ubiquitis are turds, I have to bounce my antennas every night else I get your behavior with a few devices and it is transient. Sometimes it is my iPad next time it is my PlayStation, sometimes it is every device.

If you like I can help by providing the steps but seriously, go bounce all of these by hand and I bet the problem goes away for a week.

If you look on their forum there has been a long running thread about it.


#7

Plainsane:

Thanks for the advice. So far, the only device where I am seeing the issue is with the iro. Everything else in the house is rock solid, and I have quite a few wireless devices…upwards of 20 online right now.

I’d like to hear more on zero handoff if you don’t mind. It is disabled in my configuration (the AP-ACs don’t support it). I actually set up a separate ssid just for the iro and have only enabled that ssid on the AP that is closest to the iro. I know for a fact that I don’t have a situation where the iro is trying to connect to different APs in my house.


#8

Hi,

I’m from Rachio’s wifi supplier Franz mentioned; we actually run UniFi AC’s in our office, so we’d generally notice if there were issues with them. Ours are UniFi AP-AC v2’s, running version 3.2.10.2886.

2G is configured HT20 & auto power (which ends up being 23dBm EIRP).

Here’s our network setup:

What RSSI does the AP report for the client?


#9

I’m telling ya, bounce the antenna and see if it gets better. on mine, it seems that /tmp fills up, then stability issues ensue.


#10

It allows a client to hop between antennas that doesn’t comply with 802.11 standards. I like it because it doesn’t cause interruption. So if you are walking around the house on a video call it doesn’t drop, ever


#11

Hi @davispeden,

Thanks for reaching out. I was reviewing ticket #75499 (+76836) and it appears the ticket closed with the following:

The issue I was having was that I had accidentally re-enabled 5Ghz on my network and it was trying to connect to that. Disabled and all good now.

I was curious, are the 2 SSIDs (and passwords) different from each other?

Any chance you could post a photo of your network settings similar to @hfiennes that we could review?

Best, Emil


#12

plainsane:

On your advice, did do a hard bounce of the AP that the iro is connected to. The iro is still located about 10 feet from the AP, and since reboot (about 10 minutes ago), I have seen 5 disassociates – one every 1 to 3 minutes or so.


#13

Here is a screenshot of my config. I am using HT20 and autopower as well. These AP-ACs were purchased in March 2014 (not sure which hardware version). Firmware version is 3.2.12.2920. I am getting approx -49 dBm for the client as reported by the Ubiquiti controller.


#14

Soft. I ssh in and run reboot.


#16

Nope. I’ve got Uniquiti Unifi AP-AC access points.


#17

https://www.ubnt.com/unifi/unifi-ap-ac/ dat?


#18

Yup, dat.


#19

Last question and I’m tapped out. I thought I read this but can’t find it…are your running 5g and 2g on the Sam ssid? I assume not.

I’m still trying to verify that huge skew in time doesn’t affect the encryption layer…it should not in this area But it is all that I have


#20

I am actually running both on the same ssid. I have 2 ssids, and force the one that the Rachio is on to use only 2.4ghz.


#21

I’m not familiar with that product so is it 100% safe to assume that the rachio is not trying to blink up on the 5ghz band? Has the device blinked up before?
I’m just not familiar enough with forcing 2.4 from the ap side…I don’t know what that means…

I’m also not familiar with how blink up is utilized from the phone app, but if the blink up process was using the bssid, I could create a straw man as dual banded ap causing this issue via the blink up process as you could not ensure your phone was on the 2.4 band. But I’m way out of my league now, I know just enough to sound stupid at this point.

I’m tapped out homie…that is all my tiny brain has