It’s here! Rachio V3.0 App Update Released


#21

Won’t let me into my web account because I have not updated my phone version. Phone version seems to think I have latest version, but it has not been updated for ages. So I will wait and hope it is all sorted out by the time it gets hot


#22

Hey @MidnightVoice-

Sounds like your app isn’t updated yet. Check out this article to get that updated!

McKynzee


#23

Hey @dr_jared88-

Great question! We have yet to enhance our integrations to catch up with our app update, but this would be a super cool add! I will make sure to log your feedback.

McKynzee


#24

I was a beta tester of the app. I could not update the original app until I uninstalled the beta. This was on Android. Kept getting “failed to install.” results.

BTW rally nice upgrade!


#25

Done (three times)

“Your account is outdated. Please log in to your account on a mobile device to automatically update your account. You will then be able to access your Rachio account normally on any platform.”


#26

Ok, could someone explain why under profile:

First name is "NV"
Last name is “.tv Mont nimble bloc David Ross”

???
thanks


#27

Hey Dave-

Definitely sounds strange. Do you mind contacting Rachio support via your mobile app so we can troubleshoot?

McKynzee


#28

The Android app will not update. I’ve deleted the app, rebooted, reinstalled a few times and still get a install error. Any suggestions?


#29

Hi @mckynzee,
I assume you meant open a ticket as that’s all I could find in the mobile app.
tnx
Dave


#30

Thanks for breaking my setup!!! The new app was pushed to my iPhone via automatic updates andthe new version erased my account settings on my phone and is now trying to get me to add a new controller except the new app will not go through the controller setup. why in the world would you push an update that erases the currently installed controller? So far, this smart controller has been nothing but a time consuming project. I thought it was suppossed to help me save time and money? I don’t know how many hours I wasted getting the controller to work in the first place and now I have to go through the whole process again because you pushed an update… NOT COOL!!!


#31

Wow, can’t even use the web interface now. It needs the mobile app to upgrade the device. I’m completely stuffed now…

Please help ASAP.


#32

Seems you might have a very isolated issue here. A number of us both Android and iOS have updated without incident. All of my previous information is intact down to the pictures of my zones.

When mine updated I had to log back into my account, you are sure you used the correct login credentials and didn’t just create another account?


#33

I can not seem to see any of my clients’ Controllers. I had over 80+ pre-Updated app. Now ONLY my home controller shows up. What am I doing wrong???


#34

I just want to express my appreciation for this update. I really like the updates to the Android app. I think it is a nice improvement in layout and usability!

I absolutely love “end by sunrise”. I’ve converted all of mine over to that.

I am really happy that I can use Flex Daily now for my front yard, now that I can accomodate my city’s constraints on watering days.

The improvements to the remote look excellent too. I’ve really liked being able to remotely activate the sprinklers while testing and repairing broken components out in the yard. The old interface certainly worked for that, but was a little clunky. The new one looks very quick and easy to use.

I like the new easier way to get to the consolidated history through a tab.

Overall, I am quite pleased.

I know how much effort can go into overhauling backend infrastructure. I’m sure you folks put a huge amount of work into that, and that part isn’t nearly as visible to us end users. But congratulations anyway! I look forward to the new improvements that will enable in the future.

Thanks again, everyone at Rachio!


#35

Just installed the new app and took a quick skim through it. Looks great - Looking forward to playing with the Weather Intelligence page and features - very helpful. It’s still quite cold and very wet in my part of New Jersey, so I’ve still got my Gen 2 / 16 Zone unit on standby until Spring finally gets here. The controller did really well for me last summer (first summer with it installed), and I’m looking forward to taking a deeper dive into the features this spring, as well as the new app.

Kudos to the software team. This appears to be a solid move up – looking forward to giving it a spin.


#36

I’m NOT complaining, but it just doesn’t seem like it should’ve taken a year for what seems to be a few minor improvements and a layout change. I can only assume the back end was a MUCH larger task. I’d love to see a “local” weather station option. Select your station type and Rachio listens to your local station directly. It seems like most stations report to WU, but Rachio can’t use WU due to API call restrictions. Props to Gene for all his efforts to alleviate this! But I hope Rachio steps up and fixes the issue in house. Maybe hire Gene :grin:


#37

The new app has completely broken my system. It erased my credentials and data for the Rachio. I have to go through and re-add the controller to the wifi network. When I try to add the controller, it fails repeatedly. Even after restarting the device. I tried to get into the iOS app, but now that just says “Bad Credentials”, even when using the same credentials that work on web and Android. And on the web, there is no longer an interface there - it just says “go use the iOS or Android App” and all it will let me do is change my password and set notification settings.

Now we’re getting flooded with rain, and I cannot turn off my irrigation. We are in a very dry climate in Los Angeles, so I’m stuck just unplugging the darn controller so I don’t drown my entire landscaping.

Terrible migration job, Rachio. Data should not disappear when there is a free automatic app update.


#38

Not isolated. Happened to me as well. I used the correct login credentials. However, I would note that I had a username before for logging in (as opposed to an email address), and the new version forces users to use an email address to log in. So I suspect that is the source of the bug on Rachio’s part.


#39

I keep gettingetting tne follow error tyring to update the app on android devices (samsung and a google pixel).

Have cleared the cache and also uninstalled the old app and still this message.

Im kind of screwed now.

First time i’ve been disappointed in this product.


#40

Hey are you getting this error as well