I was really excited to get my Rachio - not so much anymore

About 25% of the time - when I try to go into the rachio app on my phone - it shows the controller as offline. About 50-75% of the time when I try to turn on (or end early) a quick run - it is extremely unresponsive (even though online). For instance, I was recently replacing a lot of my sprinkler heads. I would test out my different zones here and there… 1/2 the time, the zone wouldn’t start - and at least 1/2 the time, when I wanted to end that run early (pressing the stop button) - it would take 20-30 seconds to respond (if it responded). So the latency in the unit responding to commands is extremely bad.

I already have an investment in this - so I am not going anywhere - but at this point, if I had to replace it - I certainly would try another brand.

Are you connected to wifi when you are doing this? In your yard, what is your wifi strength? Prior to upgrading my wifi at my house, when I would use the app to test my zones, if I had weak wifi signal it would be exactly how you describe. If I disconnected from wifi and went over cell network, it was much more responsive.

At the end of the day, it is a cloud system that the app runs from, so I’m not going to say that there isn’t a potential for some issues from time to time, but I’d say that if you have solid wifi or data signals, 99% of the time, the app is very responsive and quick.

Hi - Standing right next to the rachio controller I have 4 out of 5 bars on my phone (wifi). Earlier today I was trying to connect to it via the web app from my computer - was showing offline. The signal strength in my yard is fine as well. It is squarely a weakness in the rachio wifi radio - either it is buggy or doesn’t pick up signal well. But even when it is connected fine - it is very slow. I get that it is a cloud app - but I am a web app/cloud/mobile developer. If I built apps that were this buggy/sluggish/unresponsive - I would be out of a job.

I guess that is my point, I think your experience is abnormal, but I can’t say I’m sure why…I can tool around my app with less than a second between taps, as long as I have solid wifi or data signal on my phone.

Which generation Rachio do you have? What type of wifi do you have at your house (mesh, single AP, etc.)

I have a v3 - single access point - not far from the controller btw.

The delay’s aren’t with the app - it is getting the controller to actually respond to my commands. I could do a quick run - and it takes 20 seconds to actually respond and start. Or I go to stop a quick run - and it either doesn’t stop or takes 20-30 seconds to stop. That is all besides the times when the controller is “offline” - which is frequent.

I can tell you confidently that something is wrong, most likely, with your network. I use 7 Rachio 3’s on 7 different properties with 7 different Wifi networks, and they are all, for the most part, instant.

Do you have your controller on the 2.4Ghz radio of your AP? If not, do it. Also, is AP radio on channel 1, 6, or 11? If not, try 1, 6, and 11, one at a time with the Rachio for like an hour or day each to see which one is the most stable.

Do you have a microwave nearby? Any cordless phones, etc that can/will interfere?

2 Likes

From my personal and recent experience you might need a new wifi router, move your router or buy a router extender. I had the same problem you describe. It was also showing up as low bandwidth on my smart tv.

1 Like

Beyond any wifi issues, the latency could very well have to do with how far the valves are from the heads and how many heads are on a zone, and lastly the water pressure.

Lower pressure will result in slower response
More heads will result in slower response
Long piping between vales and heads will result in slower response.

I have a unit–no complaints.
My nextdoor neighbor has the latest version—no complaints
I installed the latest version for someone with a large yard several weeks ago—no complaints.

It will never be instant on an off as pressure has to build to overcome the springs to lift the heads and water has to bleed off (spray) to reduce pressure to lower the heads. This is true with any system. My sprinklers act the same under Rachio as they did when I had a rainbird system.

Since I don’t know much about your WiFi, I don’t know if you can do this or not. The easiest thing to do would be change the WiFi channel in use. If you are on a specific channel that several nearby neighbors are using, your Rachio will constantly be “seeing” stuff that needs to be read and ignored.

I hit return thinking I would get another paragraph so here goes my other idea. I do not recall if you can put the Rachio on a different network than your cell phone and have the system work, but if your WiFi has the capability of a guest network - move to that.

Finally if you have had this issue basically from when you got the system, contact Rachio - they have been very helpful when I was stumped.

So glad I use an Orbi RBK33 mesh system with a satellite in the garage. Never had a WiFi issue.

1 Like

@danielohirsch

If you run this app and provide the generated code I can have the engineering team review any incompatibilities.

:cheers:

Thanks - I will give it a try.

Franz, I sent you the code.

@danielohirsch

Are you using a range extender? If yes I’d remove that from the equation and try setting up a guest, single band dedicated network on your main router and we can go from there.

:cheers:

Hi Franz - nope - no range extenders and only one router. I have a single wireless access point running on 2.5 ghz only. I’ll also mention that I have no issues with any of my other smart devices.

With that said - I am sure the router in my house sits behind more routers down the road on my internet provider’s infrastructure (cox cable)- that is just how this thing works - and is normal. However, within my house - I have one modem/router/wifi access point that is plugged right into the coax coming from the internet provider.

I had the engineering team dig deeper and your RSSI (signal strength) is right on the edge of unacceptable (-78 to -80). This could very well explain the strange latency issues. A cheap range extender could fix the issue.

One other thing I had them look into is a HomeKit firmware issue that we have seen impact a small number of controllers, still don’t understand why (even if you are not using HomeKit).

I had the engineering team send your controller new firmware (iro3-firmware-hk-5-630) which it should have within the next 30 minutes. This could help with the offline issues. Another simple test is to move the controller closer to the router for a day and see if it truly just is signal strength.

If you don’t see better behavior over the weekend (firmware update/closer to router) we can work on more drastic measures!

:cheers:

1 Like

Great - I appreciate your help. Thanks for looking into this.

I had a similar problem when I set mine up in a new location after upgrading from version 2 to 3 so I could be closer to the flow monitor. That moved the Rachio from inside the house to outside on the side of the house away from my Wi-Fi router. I simply put a range extender inside the house in a window near the controller, and I have had no problems since then. I will say that I have put the Rachio and other similar things like my Nest on a network separate from my main network. This “services” network then does not compete or communicate with my other computers, etc., but it does have access to the Internet. In other words, it is a guest network. If you do that, it is important when setting up the Rachio that your cell phone with the app be on the same network. Once Rachio is set up, you can communicate changes from anywhere and from any computer with Internet access. Hope that helps.

1 Like