Hose Timer won't shut off

I have several hose timers, and one of them won’t shut off completely at the end of it’s scheduled run. I have the same problem when I manually activate and manually shutoff the flow. I’ve disconnected the timer from the hose bib and checked for any debris and don’t see any. I’ve also tried changing the batteries which didn’t help. I was hoping updating to the latest firmware would fix it, but it hasn’t. I’ve even tried resetting the valve by holding the Valve button down for 11 seconds until the Valve’s LED began flashing red. Nothing has worked.

Any suggestions, or does this thing need to be replaced?

Hmmm, that is strange behavior. I’ll PM you to followup.

:cheers:

1 Like

Franz, can you loop me in? I just had 3 of my 6 hose timers fail to shut off this morning. As an important side note, I do use ditch water for my lawns. Perhaps dirt/debris is getting into the actuator mechanism? How do we flush that out?

FYI, the firmware is updated to 6.0.15 on all of my hose timers.

Thank you for reporting this.

I will have the customer success team contact you and troubleshoot/resolve the issue.

:cheers:

Do you not have any kind of filtration? This would 100% cause an issue with the internals of the valve.