Does not work on iPad

These people broke the ap for the IPad a couple of months ago and don’t seem to be able to fix it.

Why can’t these people write decent code and TEST before deploying?

Works for me. Assuming your iOS is supported still, I suggest deleting the app, downloading it again and log back in. But bet you’ve done that already :slight_smile:

Just say “No” to mobile apps.
displays beautifully in Safari on the iPad. It’s a more compact layout than the mobile app, with less tapping and scrolling required.

And, it works the same (except for minor layout differences) on Windows, Mac, Linux, Android and iOS.


Because? I just tested it on a co-workers iPad (I’m an Android guy) and it worked just fine. @Kubisuro also confirmed it working. What iPad are you using and what iOS is on it?

My family has the app on 4 different iPads and all are working fine.

I have IOS 10.3.3. Your personal testing is not adequate. Version 4.1.1 worked. I upgraded and it fails. I’m certain Rachio has a list of boot issues that can cause an abort, they need to look at those.

I did not choose this product so that I could use it that way. If YOU want to use it that way, fine. I do not.

Their test is poor. They need to fix this.

If my version of IOS did not support it, then the AP store should not offer an update. This can be set by the AP developer. Therefore, since the AP updated, it should be compatible. It should have been tested. It should work.

How do you figure? It works for multiple people, presumably on multiple different iPad devices, possibly different iOS’s.

Could you provide what iPad device and version of iOS you’re using? Have you contacted support?

I have been in software development and test for more than 40 years. I know how to test edge conditions. I suspect I know what is failing here.

If you took asprin and it got rid of your headache would you consider it proof that taking asprin cures all headaches? Hopefully not.

Similarly, just because it works on a lot of iPads, does not mean that the failure on my iPad is insignificant.

Would you want a car where, for most people, the breaks work but sometimes, on some cars, they don’t?

1 Like

I don’t think anyone has said that your issue is insignificant, but you have literally provided ZERO information, even when asked a question.


You are correct, I have not given you all of the information - not all that I have provided to Rachio. My ticket with them has been open since March.

Very simple. AP Store said there was an upgrade. Loaded it. Hit Open. Splash screen comes up for several seconds then the AP aborts. Sometimes it asks to be able to send notifications.

1 Like

I’ll throw in my obligatory, “should have gotten an Android” comment, just to keep things light hearted. :rofl::joy:

But maybe @franz or @laura.bauman can nudge the programers a bit…

1 Like

Foolish response.

Hey @Klos! So sorry for the headache here. Definitely want to get this looked at, but I must first ask that respect be shown to users who are trying to help.

I’m going to shoot a note to our developers to get some eyes on this, but in the meantime, would you be up for sharing your support ticket number with me so I can take a look from that angle as well?


Settle down @Klos. If you were a regular here, you’d know that any iWatever related thing that comes up, I like to throw my little jab out there, hence my statement:

If you are unable to find some humor in a dancing Android gif, I’ll see my way out of this, and all your future tantrums. Best of luck!

1 Like

I would share the ticket number, but I don’t see where the AP shows it or how to share it.

Now the controller is telling me it can’t connect to your server.

Not a problem on my iPad it works flawlessly haven’t had any issues. @tmcgahey - IOS all day everyday