Display Bug


#1

I had what appears to be just a display bug today. For just one of my zones that watered today, the moisture level chart is showing double. The data is identical on both the web app using Chrome on an iPad and the IOS app.


#2

Looking some more, I also found this unexpected behavior. The above problem was for my zone 11 which actually ran. Then I looked at my zone 12. It is a shadow zone, not hooked up to anything, where I’m trying to figure out better ways to handle my zone 11. I did not make any changes at all to this zone in the last 2-3 days. Yet the irrigation time changed. Very strange.

f


#3

OK, so I’m a partial idiot, and I understand what is happening with this first screen that looks like a display bug. But it doesn’t mean I have to like it, right?

It finally dawned on me that “today”, while it says it’s a forecast (which I understand), is only partly a forecast. I’m pretty sure this screen happened because at the time the zone watered (8am), it put down .14 inches, and the moisture level graph probably looked just fine and only showed .14 inches. But later in the day it reran the forecast numbers, the Crop ET went up, the MAD went below zero, and so it thought it needed to run it’s schedule (which adds .14 inches). The problem in displaying this is that the schedule can’t run again because it’s past it’s start time, and besides it already ran anyway. But it knows it needs more water.

I really wish that “today” could be handled differently.Either keep the graph/details the same as the last run of the data that is about an hour before the last schedule started (don’t update the changing weather forecast throughout the day), or put code in place that checks to see if any schedules are left to be run that would handle this zone “today”, and if not, lock the Flexible Daily Schedule amount of water inches in and don’t let it change.

Sigh… in the meantime I’ll guess I’ll just force myself to remember that I can’t look at today at all and have it make total sense until it’s yesterday.


Showing watering occurred, didn't water...what gives?
Confused with Moisture Levels Graph Data
Watering Schedule calendar and Moisture graph show watering, but zone didn't run
Moisture adjustment seems broken
#4

Agree with the confusion about the status of “today”. I’ve been tripped up before. Especially with regards to setting a rain delay where it shows flex watered (forecasted) then the next day it shows not watered as expected. It would be nice for the graph to show the status of the system at the time it decided to run/not run. Even giving a delineation between past and forecasted days on the chart would be a help. Especially since the ‘More Details’ is minimized by default. Here are some modifications of the pictures given by @Linn with colors randomly chosen by me :grinning:



#5

@Raki I couldn’t agree more.

Nice emulation with the modified plots !