Controller offline, can’t reconnect to Wi-Fi

My Rachio 3 was set up in my garage and running well for several months. Yesterday all in a sudden showed “offline”. 2nd light (yellow) blocking. Used the app to reset Wi-Fi. No problem finding my device and Wi-Fi network but somehow couldn’t connect to the network. After a few min showed error msg “An unexpected error has happened. Try later”. Repeated numerous times and even tried different Wi-Fi network wondering about signals but none could connect. Same error msg. (I have other Wi-Fi device in same garage like MyQ… so Wi-Fi signal shouldn’t b an issue).
Any advice? Thanks in advance!

First, try rebooting everything in your network path: modem, separate router if any, separate access point(s) if any. If not connected, reboot the Rachio by removing power, waiting a few seconds and powering back up. If still not connected, report the indicator status


Attempt to reset Wi-Fi with the app, while watching the controller. Each time the light code changes, report the new status along with what you last did in the app and what the app displayed at that time.

Thanks for the reply! Yes I reboot router, and then unplugged Rachio, then restarted, … still “offline”. then attempt to “update Wi-Fi setting” on app. Same issue: The yellow light keeps blinking while my app showed “joining the Wi-Fi network”. (Didn’t have trouble identify my Wi-Fi network and my Rachio). … until same error message. The yellow light blinking continues…
I did run “Route This” diagnostic test, found in this forum, and have a key. Emailed to the Rachio support… not sure if/when that will help…

In your other thread, it appears that you have at least two devices in the path (Comcast modem and Google Wi-Fi). Confirm that all have been rebooted.

Wow, I’ve not heard of this before.

IMO, there are two likely possibilities:

  1. The app is failing to send the network parameters to the controller.
  2. The controller is failing to even attempt to access the network with the parameters received.

On your phone, in the list of Wi-Fi networks, do you see a network Rachio-xxxxxx (where xxxxxx is the last 6 hex digits of the controller’s MAC address)? If not, try from another device. For this purpose, an old phone without a SIM or a tablet without cellular is fine, as long at it can connect to Wi-Fi and install the app. Or, try a laptop (Windows, Mac or Linux are all ok).

If nothing shows the Rachio-xxxxxx network, try resetting Wi-Fi again and if no luck, try a factory reset. Once the Rachio-xxxxxx network, try the app again. If no luck, try from a different device. If still no luck, see

If you get past quadrant 2 blinking but it’s not completely connected, post details including current light codes.

Thanks for detailed reply, Stewart. Yes I rebooted ALL routers. No, never saw Rachio xxx network in any of my
devices, either iPhone or iPad or pc! As I mentioned, the yellow light keeps blinking the whole time while it tried (and failed) to join the Wi-Fi network… till the error message. … and still blinking… I dare not to “factory reset” my Rachio because I’m not that techi-Savy and really afraid of losing whatever account setting it already has. Lol.
Last but not least, I sure use iPhone 11 and of course updated iOS …now already 14.0.1, same as my iPad. Could it still b because of iOS issue for Rachio? And no, sorry I don’t have old iPhone/iPad around. …

Btw, without Wi-Fi connection, can I set up watering schedule manually on Rachio 3? I CAN water various zones manually but didn’t see anywhere to set/change schedule directly on Rachio 3… In other words, if it’s offline, it will only run what the app last set it up. … ( In my case I happened to have just paused the schedule a few days ago :frowning: … since Rachio didn’t skip the watering when it rained. )

Just getting more and more depressing! :relieved::disappointed:

Though I can’t guarantee it, a factory reset initiated by the buttons on the controller should not destroy any zone or schedule data. Just in case, save screenshots of the present settings to use as a guide in case they get lost. See

Use Option 2, but don’t do step 3. If the lights don’t behave as described, post details. Otherwise, after step 2, you should be able to see the Rachio-xxxxxx SSID. If not, I suspect a hardware failure and recommend that you open a ticket with Rachio (in the app) or call them on 1 844 472 2446.

I did factory reset!! :slight_smile: with your encouragement I dared to try! :smiley: and my iphone 11 showed Rachio xxx network!! but not on my desktop… maybe too far away from garage where my Rachio is… Then I tried to click on on my phone to “set up new device” but it didn’t work… maybe because of iphone 11. I still need to somehow find an older device, whether an ipad or laptop…?

GUESS WHAT!!! I just realized that my hubby’s iphone is X, not 11!!! :D:D He isn’t that crazy about new iphones as I do,… and it actually paid off! I fuzzed so much … turned out the solution is RIGHT beside me! After I used his phone, within 2 min my Rachio is ON!!

I found out something else… Before all this started, my app informed me that Rachio is offline but it’s still solid blue light on Rachio… So actually I should not bother wifi, just restart Rachio by unplugging it and plugging it back on… that should solve the problem right?

Again, thanks so much for your patience and not giving up on me! You sure brightened my day (and my lawn!! :wink: :))