Connecting to Nest Issues


#1

Just installed Iro today. Awesome. This unit is better than I had hoped for. Eagerly awaiting v2.0 software update.

Issue: When I attempt to connect Rachio to Nest, the software attempts to make the connection, then gives me a connection error message (red banner at bottom of screen). I’ve ensured that the password is correct, and that both Nest and Iro are on the same WiFi network. No worries right now…I will wait for the software version update and try again. Just alerting to an issue that I am unable to get around right now.


#2

@mahatma101

Thanks for reaching out to us. Happy to hear that you are pleased with your Iro. We’re excited for 2.0 as well!!

In regards to your Nest integration. Sorry that you are having issues with this. Would you be willing to email us at support@rachio.com with some additional information? Any sort of screenshot that you could provide would be much appreciated. We will review more in depth on our side.

Thanks again for your time and support.

Best,
Kevin


#3

I just tried to connect my Rachio to Nest and received the same error of unable to connect to Nest. In attempt to grab a screen cap of the error (flash by quickly) I tried connecting several times and on the 4th or 5th attempt it successfully setup my connection.


#4

@mahatma101 I was able to reproduce this error. Working on a fix, will advise when this is published. Thanks for your patience and have a great day!


#5

@boettcht I experienced the same thing, it is intermittent, but I believe we know the underlying issue. Hopefully can get this out in the next day or so. Looks like you are connected, so this fix will not affect you.

:beers:


#6

Just another note/finding on this. When I checked my allowed connections on the Nest side there were 5 Rachio Iro connections made. I removed 4 of them leaving only 1, not sure if that will break the connection or not. Last used time is currently a dash (-).


#7

@boettcht I believe if you go to our connections page, and you still see as ‘Connected’, should be good to go.


#8

Do you guys ever go home and rest? It’s 2207 hours MDT and you’re still at it! Awesome support.


#9

@mahatma101 lol, I am home :wink: .

It’s great to work with a team of passionate people.

:beers:


#10

When I attempted to connect I got an error also, but then I logged into nest and looked at connections, and it said it was connected to Rachio. I’m wondering if the error is a false negative in some circumstances.


#11

@cfagyal Thanks for the information. I believe we know the root cause, will be fixing, testing, releasing in the next day or so. Need to run our full regression test suite which can take some time.


#12

I have the same issue with connecting to Nest and IFTTT channel. Thanks


#13

@mp96b @cfagyal @mahatma101 @boettcht We have found and corrected the pairing problem with Nest. This fix will be released late tomorrow night. Monday the pairing process with Nest will be working correctly. I’ll post back here when the fix has been promoted.

Thanks for your patience!

@mp96b We have not had any reported issues with pairing to IFTTT. If you are experiencing connecting to IFTTT please contact support@rachio.com and they can help you troubleshoot.

Thanks!


#14

The issue has been corrected and promoted to our cloud.

Please let us know if you have any other issues, feedback, or questions. Thanks!

:beers:


#15

Thanks for the quick fix.


#16

Now I see a problem disconnecting from Nest. I logged into my Nest account and removed the 15 or so connection entries, then returned to Rachio. In hindsight, I should have disconnected from whatever one of those connections was active before removing them from Nest. Now, when I try to disconnect, I get the same maroon\red error bar popping up from the bottom and telling me there’s a problem disconnecting.

Again, no worries. I’ll wait for v2 to come out. Maybe a software and firmware refresh will solve all of this.


#17

@mahatma101 I was able to cleanup some of the extra Nest data on your account. You should be able to connect/disconnect now.

Will work with the development team on the state you were able to get the device into. My guess is that if you remove on the Nest side there becomes a disconnect on our side.

Thanks!


#18

Thanks, Franz. Works great now.


#19

I have some issues with connecting to nest. When I made the connection with nest, all the steps were normal, and it logged into my nest account. When I got back to the web portal, the Nest is not listed under Integrations. I repeated it five times. No joy. When I logged into my nest account, all six connections were listed. I deleted all but one of them. I am connected, but should it show the integration on the Rachio web portal?


#20

@shhanson-
That is very strange, I checked your account and saw the same thing where the integration isn’t showing. Did you go through every step that is detailed in this help article? I’m wondering if something went wrong in the “add home” step? Let me know.
McKynzee :rachio: