Connecting controller to wifi network initially

I’m installing a gen 3 controller for the first time and not able to add the controller to my wifi network. I tried with multiple phone devices, restarting my router, etc. I have an xfinity gateway router and attempting to add the controller from an android device. Any help is greatly appreciated.


Same problem here.

Using an iOS device

Were you able to get the third or fourth quadrant blinking? See

If so, that indicates that the SSID and password were correctly received, but the controller is having trouble connecting to the back end. Please provide details, including AP make/model, router/firewall make/model, any non-default settings that you believe may be relevant.

If you could not get past the second quadrant blinking, please describe in detail what you did and observed, both with the iPhone and with the Mac.

I am never able to go beyond the yellow light blinking.

The caveat is that I am trying it using iphone 12 pro. I can also see it with my macbook M1.

This may have to do with this issue:

The build date on my device is Nov 2019. It is very likely it has the old firmware.

The settings in the app is not showing the firmware number.

So I need the instructions on how to update firmware.

I could also try with an older iPad (3rd gen) running 14.2.

And there needs to be a physically connectable control port (ethernet/usb). From a systems design point of view, wifi cant the only way to connect a device especially something which is so dependent on a connection.

Which is “the” yellow light? The first quadrant blinks while booting, the second while awaiting Wi-Fi, etc.

On your Macbook, confirm that you can see the Rachio-xxxxxx network.
Assuming that you can, what happens when you try to connect to it? Likewise, on the iPad? Please be precise about prompts, error messages, etc.

  1. Second light is the yellow light.

2, Both the iPhone and MBA can see the Rachio-xxx wifi network.

  1. Ob iOS even if it says connected to Rachio-xxxxx, there is no IP address info

  2. When I try the macOS cmd line I get an error 3095.
    networksetup -setairportnetwork en0 Rachio-XXXXX
    Error: -3905 The operation couldn’t be completed. ( error -3905.)

  3. Tried with 2.5GHz and 5 GHz networks with different SSIDs.

  4. Based on the inability to connect to wifi, this looks like the wifi format issue discussed in the firmware upgrade thread.

I’m not familiar with MacOS, but found a post where upgrading the OS helped:

and one where one could connect with the GUI, even though the command line failed.
If you can get connected, but don’t get the popup, try running the script intended for Linux.

If no luck, what non-Apple devices do you have (Android, Windows, Linux)? If none, do you have a Mac that can boot to another OS or run another OS in a VM?

Another thought: When you connect in iOS but see no IP address, try opening in Safari and see whether you get the expected 404 error.

Do you have an older iOS device (such as an old phone with no SIM) that can run the app?

1 Like


Had to use a Mac from 2011 with High Sierra.

Tried using an iPhone X with iOS 14.2+ but it did not work.

Good thing was that I got the pop-up warning me to go the Settings and add a device even though that did not work.

With my iPhone 12 Pro, I did not even get that pop-up.

But the lesson is: Wifi is a dynamic platform and can not be the only way to set things up.

If I were a professional, after wasting a total of 5 hours for what should have been a 1 minute step, I would not stand by the product.