632 Firmware Release Notes for Gen 3 - Impact for onboarding controller using iPhone 11/iOS 13.4.0 & Samsung Galaxy S10/S20

Good afternoon everyone! As requested, I will be posting release notes for our firmware upgrades.

Gen 3 Firmware version 632 is in response an issue we have been seeing with G20 Samsung devices and iPhone 11 devices running iOS 13.4.x.

The issue is that for our R3 WiFi chip, the WiFi firmware assumed one part of the WiFi standard meant that within the connection string, one of the parameters would never have additional information. They put in a filter and refused connections that had any additional parameters.

Newer chips in the iPhone 11 and Samsung G20’s are starting to add a device parameter within this connection string and the device is understanding it to be invalid and is refusing to connect.

The 632 firmware upgrade is including a newer version of our WiFi chips SDK that resolves this issue.

We are pushing this firmware upgrade from our end proactively and you should see no interruption in service. If you do, please let me know and we will address it. The upgrade should be completed by tomorrow afternoon.

I met with our WiFi chip partner to make sure they are implementing better processes that allow for changes on the phone and computer side. We are also working to be more proactive with our new device testing so that we are proactively finding this issues.

Thanks everyone, have a fantastic weekend, and thanking you for being Rachio customers.

Michael

8 Likes

Thanks for the updates @Michael_I!

I assume the issues with the G20 were in the setup process? That is the only time I see a phones Wifi ship causing issues with Rachio. Plus, I’ve not had an issue with my G20…

Hi @Michael_I is this for all versions (1, 2, 3, etc) of Rachio? Also how does this correlate to the version that shows up in the technical info. For example mine is iro2-firmware-5-119

Hi, I returned my Racchio due to this issue. Wondering if new Racchio equipment will have the firmware applied, or better, the correction to the chip itself. The tech support side could not help me–as I guess this was discovered later in the process. I must have bought the controller in the perfect bad time to do so. They gave me a lot of reasons: problem with a port on the router, etc. So I sent it back. Would really like to have the weather functionality.

This firmware is only for R3 (Gen 3) controllers.

2 Likes

My unit updated to this version (thanks, it seems to have been stuck on 615 for awhile), but it doesn’t seem to fix the HomeKit issue, the controller isn’t visible when I try to add it to my Home in my eero app.
It’s not yet too hot here in the Central Valley of CA, and I have lots of free time these days, I’d really like to be troubleshooting my sprinkler system hands-free from my Apple Watch using Siri to start and stop zones, but alas here we are.

1 Like

This firmware does not include any HomeKit fixes, just WiFi connectivity.

:cheers:

It should take only a few minutes to set up Google Assistant and link it to Rachio. Turn on Voice Match and you can use it hands free. I don’t have an Apple Watch so can’t say for sure that it will work, but this


implies that it will.

If Voice Match doesn’t work on your watch, consider putting your phone in a baggie (bottom up) to keep water and dirt out and tie it with a string from your neck like a pendant. Though the baggie attenuates your voice, if you face downward and speak reasonably loudly you should be heard fine.

Your 632 FW broke HomeKit on my system. It has been working fine with HomeKit until this past weekend. Now I know why it suddenly started giving NO RESPONSE messages this weekend in the Home app. I tried deleting and re-adding the controller, but it no longer shows up as a device in the Home app. System still works through the Rachio app, but HomeKit is now broken with the 632 FW you pushed out. Any chance I could roll-back? And BTW, I use iphone 11 running current version of iOS, and Gen4 Apple Watch to control the system via HomeKit.

632 broke connectivity with the flow meter, as did 631.

This is very problematic. See here:

Same issue here, will reconnect using the fix provided, but in a day or 2 connection is lost. Also setting up wifi does not work on Android 10 (Pixel 3XL) I have to use IOS device to reconnect

We are looking into this issue, thanks for sharing it with us.

OK, so the issue was a Rachio WiFi problem…
I reported this issue trying to use an iPhone 11 Pro, back in February…
(I just could not get the Rachio Controller to connect to WiFi)
My post on the 14th summarised the situation, my diagnostic tests, and my work around: “Used my wife’s iPhone 6”
1 yr trouble free, now controller offline is the norm and
1 yr trouble free, now controller offline is the norm
Shame you did not provide some acknowledgement to me for the effort that I put into trying to sort this out at my end, and reporting to you in detail?..
Robert.

1 Like

So, I was in the window of having an iPhone 11 with the version that wouldn’t connect. I finally sent the Rachio 3 back, based on not being able to find help from Rachio. So now, it is fixed? Also, how do I assure that I have the controller with the newer chip… Are you pulling the others off shelves?

We have a new firmware release after the controller is provisioned. If you only have access to an iPhone 11 we will have an option soon to connect the controller to the internet using a laptop as an initial workaround. PM me if you would like me to let you know when it is out.

This option is not viable, but any new units manufactured have updated firmware.

Thanks for your patience.

Hi,
I just bought my gel 3 from Amazon and having trouble to add the controller to the Rachio app.
it failed at the Adding controller to WIFI network… step
it said that it can’t find the controller.
Does this updated firmware fix this issue?
How do I update the controller without using the app?
Would anyone help me with this? having a new grass put on and now can’t have the sprinkler system work…

Thanks!!!

What type of Android phone do you currently have?

iPhone 11pro
I also have iPhone 5s with version 12.3 and still not working

The iPhone 5s should work with the controller (it is only the 11pro). You will not need new firmware.

If that doesn’t work I would try creating a guest network (preferably 2.4g) with no range extenders.

If it still is not connecting please reach out to https://support.rachio.com/ and they should be able to get you online.

Thanks for your patience and have a great weekend.

:cheers: