Calibration fails to Complete - Connection Error

Using IOS App 4.4.5, 4.4.6, and 4.4.7 (brand new) all result in failure to finish the Calibration and failure to update/load/show the new cal data on the App. I get the error “Oops we couldn’t connect to your flow meter”. This is not true as the Cal data is populating in the graph throughout the calibration - it just has a problem at the end (for me at least). I have tried multiple ways to initiate the Cal, and have a excellent connection strength (RSSI) to both my Flow Meter and my Controller. I have been working with your team (very helpful) for weeks and originally identified/helped the team troubleshoot the graphing error I found in version 4.4.5. The team then fixed the 4.4.5 graphing error in the n4.4.6 release (thanks) as it populates data correctly now, however, the Cal still fails at completion for 4.4.7. The only workaround for me has been to “Use Current Value”, which I’m told bypasses the Controller Cal data upload and instead uses the current graph data shown on the phone app to re-upload the Server.

I would really appreciate if the community would be willing to run some Cals using their own iPhone (4.4.7) or Mac (web) apps and see if the Cal completes successfully for you (without error screen) and updates the zone data with the new Cal GPM data. The team tells me I am unique and I must have a configuration problem with my network. This is odd for me because the cal used to complete (last year) and my network config has not change. Thanks all.

@laura.bauman I’m running v. 4.4.7 on my iPad and I’ll recalibrate one of my zones in the backyard within the next 20 minutes or so (20:00 MDT).

Edit: just finished calibration one of my larger rotor zones in the backyard. Though I had to wait 10-20 seconds before “Finished” appeared, it DID complete the calibration successfully and showed me the computed GPM value (12.4m third screenshot below), but during the 5-minute calibration, as with version 4.4.5, the numeric readout never changed (remained at 0.0 throughout) and the vertical blue lines on the white wave animation never appeared. I reported this as a problem two versions ago (4.4.5) and it was fixed within a day or two in a subsequent release (4.4.6). Here is that discussion thread. Now apparently the latest release (4.4.7) has reintroduced the problem. Below are 3 screenshots in sequence:

Hey guys! Happy to work some of this out with you guys as I may be able to provide some deeper insight. In v4.4.5 (maybe earlier) the app had an issue distinguishing new events we received from the server (the calibration readings). So we may have shown the first calibration reading but then none after that (or may not have shown the first reading).

That was fixed and I checked on v4.4.7 and the fix is still there. I think what you may have seen milehiguy was a case where the app’s event connection broke and didn’t reconnect to give you updated events. I reinstalled the current app from the App Store and recalibrated one of my zones and was able to see those new readings every 15 seconds or so.

The case that you’re seeing TurfMan is interesting though. Your events come in and are reported, so the connection is fine during the calibration. I believe you’re correct in that something towards the end of the calibration is going awry. I don’t know right now what that issue is, but the fact that the in-progress calibration readings are coming through is good!

It may be a workaround to use the “Use Current Value” but one of the reasons we added that was to save water. It’s more of a preferred way if you see your readings are staying pretty consistent as it allows the flow rate to be set earlier and not continue to use water if it’s not needed. That button does have the app send the value to the server and is then saved for use with high/low flow alerts. While the server may do some simple average correcting in some cases, the readings you’re seeing are actually the averaged values. So you are not losing any precision using the “Use Current Value”.

But, to look deeper into the issue you’re seeing and potential fixes. While you’ve been troubleshooting this, have you factory reset your controller yet? There are some instructions online for doing this, but some of the instructions also mention deleting the controller from your account. Do NOT do that, as data is lost when you delete a controller from an account.

1 Like

Thanks @zachio I appreciate it! I’ll read your post again tomorrow when have fresh brain cells, but in the meantime …with version 4.4.8, that I just installed from the App Store, the GPM numerical value countdown and blue lines have returned, as you can see in the following two screenshots. Calibration completed just fine. :+1:

1 Like

Hey Milehiguy, thanks for the Cal check (appreciated). It was very interesting that on your very 1st try you got a problem with the graphing on the Cal (with iPad 4.4.7). To clarify, you ran both tests on an iPad with the 1st test using iPad 4.4.7 and the 2nd test using iPad 4.4.8 right? Both tests competed Cal but he difference being that with iPad 4.4.7 you did not get a populated graph and in iPad 4.4.8 (which not available for iPhone) you got a successful Cal. Right? Have you tried on the iPhone or Web?

For me, I have used iPhone 4.4.7, Web App, and new iPad 4.4.8 and in ALL cases I always get the response “Oops cannot connect to the Flow Meter” even though my graph is populating. I worked with Tech Support (great help - Caio) under 4.4.5 and I/we forced the issue for days and finally the Rach Team concluded the 4.4.5 had the issue with the graph (and it looks like you did the same in the Forum) and there were two quick/successive updates 4.4.6 and 4.4.7 (which is awesome support). But these updates have not fixed the issue for me, what happened was my graph started to work again with 4.4.6 (again - as it always did in year 2019) BUT, the app still does not complete the calibration and update the zone GPM. As noted, I can use Current Value and override the normal progress - but that’s not the point here - its to get my system HW and SW working as designed. Team believes I have an issue on my end (either network or hardware). Never did tech support suggest suggest a Factory Reset - but they did suggest a new controller and/or flow meter (I have each as backup). I did replace the flow meter (pain) with my backup and got same result. The backup controller is still on the box - guess I could mess with that but again - a pain to integrate. I worked with several networking people over the last week (they all say my IPv4 and IPv6) connections are functioning properly and I even moved an access point to within 2 inches of the controller (because support said my RSSI was weak) and now I get -5 RSSI (insane good connection) - BUT with same failed result. I tried to get the team to look at the code and see if/where the “Oops error” data sources from - as this would likely tell them what part of the firmware, app, or server is generating it and why - but I got no response to that one. Due to all my error splash screens - all related to that somehow I am Manually cancelling my Cal (not true), I really believe there is either a HW controller/firmware problem on my end or a server communication TIMING problem on the Rachio end. Of note, if when I “retry” a cal on the App (due to the error) it even gets worse as the cal cannot restart properly, does not populate etc - a bad loop. So…If I were Rachio, I’d focus on the Timing of expected communication because something does not seem right.

ON to the reset. Zachio - thanks so much for chiming in. You want me to do a Factory Reset (NOT remove controller). As you noted - there is much confusion on what/how a Factor Reset is performed or what it is. I can, 1) Power Cycle - Unplug/Replug (which Ive done), 2) Reset WiFi with button (which Ive done), 3) Power Cycle - wait for boot - then hold down Stop Button - wait for light Bar to flash (I have NOT done that), 4) “Remove Controller” in the App - which is also called Factory Reset - (I will NOT do that) and 5) Transfer ownership (Nope). So…how do a perform the suggested Factory Reset, will it retain all my customs setting (lots of work). Also note that my Controller/account never gets the auto Firmware updates and I have to have it done manually on your end. Happened twice over the years and nobody gives a good explanation - only that its my end - not sure its related but just an FYI. So what is the Factory Reset going to do? Are you thinking the firmware just needs a jolt? How is the Power Cycle different than a Factory Reset in terms of Firmware? Sorry for the frustration/questions - been working this for weeks - troubleshooting with tech support.

Thanks guys.

Hey Rick (milehiguy), just curious. I read another post of yours and it said you were running Firmware 615 (back in 2020) with flawless Flow Meter results (and the thread sort of implied that Flow Meter folks should be on 615 - Is that old news?). I am currently at 632 FW (hopefully with the appropriate “feature” flags set to me having a Flow Meter on my Controller - if that’s still a thing?). Anyway, just wondering if its possible that 615 FW performs the Cal correctly (w/ 4.4.7 App) and 632 FW does not? Just a thought.

1 Like

FYI. My iPhone auto updated with 4.4.8 on 6/23 (App revision notes on App Store say - “bug fixes” - not sure what was fixed nor if there is a detailed version history/log somewhere online - their used to be at one time). So, anyway, I ran a Cal with 4.4.8 App and 632 FW and unfortunately my App still fails with “Oops cannot connect to Flow Meter”. I’ll keep on it. Must be my hardware if the Rach team thinks all is good on their end.

Hey @TurfMan … I just double checked and I’m currently running f/w 632 (iro3-firmware-hk-5-632). I don’t recall when it updated from 615, but may have happened automatically at some point. In any case, yes that must have been old news. Clearly, some people are still having issues with 632, esp. with regard to HomeKit connectivity, but luckily I am not. Not only is HomeKit working, but my WFM seems to be working perfectly. The “graphing” anomalies that appeared (for me) during calibration with a couple of the previous versions (4.4.5 and 4.4.7) have disappeared in the latest version 4.4.8.

Now I’ll address a few of your questions for me in your previous post … you are correct in that all my recent tests were conducted on an (old) iPad Pro 9.7" (vintage 2016) and none on an iPhone or web. The populated graph issue was the only anomaly and as I recall happened with iPadOS version 4.4.5 and 4.4.6. The problem was corrected in 4.4.6 and 4.4.8 in very quick turnarounds by Rachio (@zachio). To the best of my recollection, calibration itself completed successfully in all 4 versions. Note that I’ve never gotten the “Oops cannot connect to the Flow Meter” error that you’re getting. Fwiw my router is an ASUS RT-AX68U with very strong signal to all of my IoT devices incl. the Rachio 3 controller (2.4GHz). Hope this helps in some small way! Good luck with the connectivity issue. :wink:

Thanks a ton for the info Milehiguy. My network is an Arris (Comcast) gateway (wifi off) with a roaming network of Apple Airport (Extreme) WiFi Access Points (for good coverage everywhere in the home). This same network was used back in 2019 when I did ALL my Cals successfully. Its only recent when I did some nozzle work that I did a Cal and it failed to complete using 4.4.5. Thats when I worked with tech support and they initially thought “I” had a HW problem. I stayed on it and it turned out that 4.4.5 App SW broke the function (no graphing data, no completion) - due to problems with the App SW distinguishing new server events (as Zach describes above).

Its interesting to note that when you failed a 4.4.7 run (no graph) just a few days or so ago, that Zach said your “app event connection broke and didn’t reconnect”. As a result, there was a 4.4.8 immediately available and it worked for you. Not sure 4.4.8 had anything to do with it. But I think my issue is related to the “event connection from server” - I must be losing that as I’m not getting server download to the App (it seems) at completion.

Also I haven’t done a Factory Reset (FR) and haven’t heard from Zachio on just what steps I should use. Have you ever tried an FR? Do you use the Stop button? Thanks again for the Firmware info - I was hoping that was my issue.

You’re welcome. I’ve never needed to perform a factory reset before. I’ve power-cycled, but never a FR. I’ve stopped an ongoing watering session (both scheduled, Quick Run, etc.) via the stop function in the app, but never at the controller. :wink:

The 4.4.8 was unrelated, there was a config path that would incorrectly hide a button that was fixed in that version.

I don’t believe you ran into any eventing issues. You received the events mid-calibration and looking at the zone calibration results it seems the calibration did end in with an error. When a calibration results in success the result is “CALIBRATION_SUCCESS” but it seems you had “COMMNICATION_ERROR”. So it may be that a factory reset can clear any cached data or settings and would start your controller off fresh.

Factory Reset Info

To try a factory reset here’s the steps you can take. Do note that this clears all data (including any schedules) from your Rachio controller. Those will be re-downloaded once your controller is connected to WiFi again, but you will need to update WiFi before things will start running again. You won’t need to re-pair your flow meter.

Unplug the controller from power and wait about 5 seconds. Plug the controller back in and then immediately hold the up direction on the button (the stop button). You’ll see the light bar start to light up yellow. Keep holding until the light bar fills all the way and does a blue flash, then release.

The controller will start clearing its data. Keep the controller plugged in and wait for it to reboot (the lights on your controller may turn off, or may stay on during this time). I just did this with one of my controllers and it took about 3 minutes to fully reboot. You’ll know it’s finished the process when the second light quadrant is blinking yellow. If after 10 minutes it has not rebooted and is not blinking yellow, go ahead and unplug, then replug the controller in. It should then blink the second light yellow which means it’s ready to connect to WiFi.

Now in the app you’ll need to reconnect to WiFi. Open the app and go to the More tab, then Controller Settings, then Update Wi-Fi Network at the bottom. Your controller will already be ready to connect to WiFi with the second light blinking, so you won’t need to hold the WiFi reset button. Click the button to connect and you’ll get connected.

It may take some time for your flow meter to communicate with your Rachio again. After the flow meter first pairs (which you’ve already done), it goes in to a battery saving state and doesn’t communicate with the controller at all times. You can force it to re-establish the connection quicker by taking the batteries out and putting them back in. After that everything should be fully cleared and reset. You can try calibrating again and see if that helped fix the issue.

1 Like

zachio, thanks sooo much for the clarification on the Factory Reset (FR) procedures and the Flow Meter “battery saving” operation. I must have missed it, but I don’t recall any literature saying that it is expected that the FM will not connect immediately after a FR and/or Power Cycle. I did have to wait around 15min, but as you said, the FM did reconnect on its own without pulling batteries.

Todays test: So, I performed a FR (twice) around 1:30Pm local (Pacific). Waited (5 min), ran one cal with the FM not connected - thinking maybe the FM would connect during Cal - NOT. So stopped Cal manually because I was not getting any graph data. Then waited another 10 minutes and saw that the FM auto connected (good). So around 1:55 local, I ran the zone1 Cal, got good graph data, and unfortunately STILL have the same failure “Oops cannot connect to FM” at the end of Cal/no zone GPM update.

So if possible, could you check the data (again) and see if the “Communication Error” is occurred on this latest Cal after FR? Also, is “Oops page” the right App code response if there is a communication error between server and App??? (I didn’t see that answered).

I’m now left to trying a new controller (unless you have other ideas). FYI, I did bypass my local Access Point WiFi (yesterday) and went straight the Gateway WiFi to see if that made a difference - got same error result. Bummer.

The “Oops” message may be kind of misleading as the application will show that when the calibration result comes back as “CalibrationCommunicationError”. So it’s not actually a communication error between server and app, but showing the result the server processed from the controller. I think if the FR didn’t fix it, we’d need to take a look at what the logs send back to identify where exactly the error is being encountered. For example, it could be a problem the controller has sending those results, or maybe there’s an error in processing the data on the server. Unfortunately I don’t have an answer to that now.

That said though, what I’m seeing with those in-progress calibrations being reported, if you use the “Use Current Value” button once your values settle out, I think your setup will work and be all set to give you accurate water readings and leak alerts.

zachio & milehiguy - GOOD NEWS: Today I physically removed all the existing (old) Rachio HW (both Controller and FM) and unboxed and replaced them with brand new new controller and new FM. Cal completed! Now I had to figure out which HW item is failed? So I put in the old FM (only) back in the system but still using the new controller. Cal completed! (Points to the old controller right). So…put the old controller back in with the old FM (like I always had) - and Cal Completed! (WHAT??). I have ALL the same stuff that I started with - and now it works.

Here’s the only solutions I can offer:

  1. In the troubleshooting, I was forced to REMOVE the FM (in the APP) from old controller (so as to be able to add it/associate to the new controller). Then at the end of troubleshooting, the FM was ADDED (in the APP) back to old controller. Could this App removal of the FM from account have cleared the issue? I would have thought the controller Factor Reset (FR) would have done the same thing; however, zachio said (previously) that “you will NOT need re-pair your FM” after the FR. Soo…that tells me that even though there was an FR, the FM will pair (remember) that controller connection irregardless. So “Remove FM” obviously does something (in software) with the APP and/or account such that its no longer associated/remembers the connection with that controller. Clearing that “remember” function via remove appears to have fixed it. If folks out there are having a similar FM communication problem (Cal failure) or maybe even just a FM disconnect problem - I would suggest users try to REMOVE THE FM (in the App) and then ADD IT BACK (in the App). Maybe a tip for Tech Support - as that was never suggested as possible solution. Of course this could be not correct (pending zachio).

  2. The existing FM was physically moved around - but I kept my same lithium batteries in there the whole time. Maybe it needed this “kick of the tires”. Doubt it.

So…5 Cals in and all working and populating the zones with new data! All HW exactly as it was 5 weeks ago…but I started with 4.4.5 (not good) and now its 4.4.8 (good). Something got out of sync with the HW and SW over the last year or so.


1 Like

Great to hear it’s working!

It seems like maybe there was an edge case you ran in to that caused the server to not accept the calibration result. I’m speculating here since I’m not familiar with that codebase. But the info you provided is super helpful! The info in #1 you mention above is more accurate. Removing the flow meter in app removes the connection on the server and with it data that’s stored thus clearing any misconfiguration that may have happened. Will definitely keep that in mind if we run in to this again.

Thanks for your persistence in trying to get to the bottom of this. I’m sorry you ran into this issue, but glad it’s working now!

1 Like