Zones wont start when auto schedule kicks in


#1

When I manually water any zone or all zones, everything is fine. However when my daily schedules want to water, the valves wont come on.

I have two schedules:

  • Flexible daily
  • Fixed days (every 3 days)

Both are set to start after 6:30pm and I have two master valves in my system that both turn on when any valve is on.

Everything works if I manually start a zone. I think its a race condition/timing issue.

The problem started happening after I added the second schedule.


#2

@Derstig - The issue is having multiple schedules with the same starting time. The Flex schedule is blocking the Fixed schedule. To fix it, move the Fixed schedule 10 minutes before or after the Flex schedule.

See this comment from @Franz on another post, similar problem:


#3

In that case, how will 10 min help? Shouldnt I schedule one of them so that it only starts well after the other one completes? Because surely they wont be able to both run simultaneously?


#4

@Derstig - I believe the way it works is that when Flex Daily decides it doesn’t need to water for a day, the controller goes into a global (all schedules)“rain delay mode” for five minutes. Therefore if the Flex Daily is set to start at 6:30 and the Fixed is set to start at 6:40 for its three days they won’t conflict. And yes, if Flex Daily is actually running on one of the three days that the Fixed schedule is set to run the Fixed schedule will wait until the Flex Daily schedule has finished running before it starts.


#5

This is still not working even after setting the two schedules 20 min apart.


#6

Can you manually run the schedules from the app, or is the manual remote run function the ONLY way to get the system to water your zones?

Also, can you tell me if the system notifies you that the schedule has started and thinks its actually running? Or is the schedule just not running at all?


#7

I can run the schedules manually. Also when it runs the entire thing automatically, the app thinks its running but visually I see that no sprinklers are running.


#8

Interesting. Would it be possible to disable this schedule for now (not delete it) and create a new schedule to see if the issue persists? What type of schedule is it by the way?


#9

I have done that already twice, and the issue still happens.

One schedule is flexible (everyday) and one is fixed (once every 3 days).

Is there a way for me to pull the logs to analyze? How do you guys debug these issues?


#10

I would suggest reaching out to support@rachio.com so that we can take a closer look at your account. That or DM me your username and I’ll be happy to take a look for you. Creating a ticket with our support team might resolve the issue faster however.


#11

Hey @Derstig-

Were you able to get in contact with support and resolve this issue?


#12

Nope, I forgot. You can look at my settings though my username is also Derstig, maybe you guys can take a look?


#13

What happens when you don’t have either of them activating on the same day?


#14

Then it works. Actually, even the same day works, right now I got one at 7:30am other 7:30pm and they worked fine two times in a row.


#15

Hey @Derstig-

My best guess is your fixed WI is causing your controller to globally skip your flex. If you move your start times to just an hour apart, it should resolve the issue (similar to how the moving them to morning/evening resolved it). Let me know if that solves the problem!

McKynzee :rachio: