Zones not appearing in iOs app

I have 2 Rachio 3 controllers on my network. One is working fine from my iPhone, one not. When I go to the 2nd controller on the iPhone, no zones appear in the app. I’ve reconnected the wifi, no effect. I log in on the computer via the web and I see zones just fine. Unfortunately I want to control the zones while outside … What do I do to get the zones back on the 2nd controller.

Strange, just had the engineering team login and can see both sets of zones. Can you try uninstalling and re-installing the app?


And when you log in on your phone via the web (Safari), can you see and control the zones?

Yes, using iPad and Safari I see the zones fine. So then I tried the app on the iPad - and it worked. Went back to the iPhone and tried again (like the 20th time) and now it works.

Thoughts for the cause so I can get around it quickly next time?

@zachio Any ideas on missing zones? Caching?


Nothing pops out to me. It’s good you’re seeing all your zones now, but if you do happen to have it happen again, let me know and I’ll be able to dig in deeper to see if there’s anything that pops out as to why zones wouldn’t show up.

Force quitting the app will reset most things, enough to cause a full refresh when opening the app back up as we cache very little (due to constantly changing state of the controller).

1 Like

Thanks guys. I’ll let you know if it happens again and the circumstances.