Yet another Homekit

Just to add my voice to the pile.
Latest iOS, iPhone 11, Apple TV setup as a hub. I have tried 5 different brands of WiFi AP, The Rachio App works fine on all the WiFi APs. But ever since the 631 firmware upgrade, it is almost as if the HomeKit API has been turned off…
I have tried resetting it.
I have a ticket on-hold since about a week after I bought the darn thing.
No updates, no eta, no communication.

I have offered to be a Beta tester, I am an intelligent tinker and would like to help. I can easily packet capture and help with all that fun stuff if needed.

But as per usual. Rachio support has tried the basic. “did you turn it off and on again” troubleshooting with me and left me with an “it’s Apples fault, they changed the API in the last update”, with no proof or timeline on how long their developer will take to harmonize the code to the latest build of HomeKit API… or whatever their issue is…

As usual I’m left feeling like I bought a bag of lemons and can’t even make lemonade. With no way to roll back the firmware, no way to get help from an attentive support team and to be the lowest on the totem pole because “it works fine with our app, so just use our app” as the canned response…

I’m pretty steamed at this point…

Hopefully the new head of Engineering will change this and rebuild my faith in Rachio, a company with so much promise, from my home state of Colorado… Yes I live very close to their headquarters and still get treated this badly.


I running firmware 615 with no issues. The new firmware must not have downloaded on my system yet.

However, I had the same issue setting up HomeKit. Do you have a mesh Wi-Fi network setup? If so you have to have the rachio and your iPhone connected to the same receiver in your mesh setup to get HomeKit configured. Then once configured it works perfectly.

Are you running a beta version of iOS on your phone and/or the AppleTV?

Hi Jason11,

I have tried it with both, a mesh and a single AP. No love either way. With 615 it was all working great.
I think 631 has an issue. From what I have read from others oaths forum it sounds like 631 has been stopped from breaking anyone else Rachio, but they haven’t issues a 615 in 632 clothing to fix all the broken Rachios.

Nope. I’m strictly a GA person (especially when troubleshooting). Unless you are suggesting the beta code on the AppleTV can fix this issue for this one device?

I may try and see if there is a home bridge plugin that will do the job of the Rachio controller, I have read that someone got something working… Who knows I may find some time to write my own.

Ok…if I get 631, I will be able to confirm that it is the firmware but right now it is working as expected. I am running both beta versions of iOS on my iPhone and AppleTV. If you are a GA guy, I wouldn’t change your approach…I am a dev guy so have the betas to make sure nothing breaks. It may help to see if 631 works with the beta version of iOS.