Wifi issue Gen 3 16 Zones

Got the new device from Amazon, hooked up all the wires last week 5/8.
But, unable to get the wifi work until now.
My home has a Tenda MW6 nova mesh network.
There is no option to separate the 2.5/5 G networks.

First tried activation with my Samsung S10+, fail.
Later got it activated with an iPad, but unable to finish all the way through.
I can see the device name in my app, but always showing offline.
Tried reset the wifi for more than 10 times with multiple devices (Samsung S10+, iPhone 6s, iPhone 8, iPad…). All fail.
Most of the time, the connection process will go ‘yellow amber - white/blue - red - amber’. Basically, something is happening to make the connection, while stopped after showing a red light.

Today, just tried reset the network with my MacPro, being able to directly connect to Rachio 3, but always end up with ‘An unexpected error happened.’

This is really annoying to deal with this wifi headache.
At least 3 hours have been wasted.
I know Rachio3 may not like such mesh network, but, why it is not a problem for the other 30’s smart devices connected to the same wifi?

@Martingale Sorry to hear about your WiFi connection issues. Our support team should be able to help assist with WiFi troubleshooting. I remember a long time ago hearing about Tenda Nova mesh issues, but can’t remember now. https://support.rachio.com.

If you want to try this https://support.rachio.com/hc/en-us/articles/115010540888-Is-my-Wi-Fi-network-compatible- and provide the generated code I can have the engineering team do a quick review.


Thank you for the quick response.
Here is the generated code: EFXFYKUA

The team was able to review, and it looks like there are multiple SSID networks with the same name but different frequencies, but that could just be how the router operates. Did not see anything else as a red flag. If there is a way to create a separate network with one band that would be a good test. If not, Rachio support will be your best bet. They have navigated through lots of home network configurations.

Thanks and have a great day.


Turned off two mesh nodes, created one separate guest network. Neither worked!
What’s the easiest way to contact your support team? I couldn’t find a phone # on the support page. Don’t want to waste time with the bot there.

1 844 4RACHIO (1 844 472 2446). In my experience, they are very responsive.

However, I suggest that you first do a quick test to see if the trouble is related to your network.

Temporarily set up one of your phones as a mobile hotspot (it’s connected to the internet via mobile data and shares it via Wi-Fi). This is also known as tethering.

Take another mobile device that has the Rachio app and confirm that you can connect to the hotspot and access the internet. Then, run the app to connect your Gen 3 to the hotspot Wi-Fi. If that succeeds, you should see the controller as being online. If you’re in a hurry to water, set up a fixed schedule and confirm it works. You can now take down the hotspot.

Thank you for the advice.
It’s not that hot here, and I still have my old controller on hand.

Tried hotspots from two different phones, still no good news.
Since I’m new in the community, wondering how is the probability for getting a bad unit?

It looks like the controller is on your account but in provisioning state which we rarely see.

Can you please try these steps.

Remove the controller from your account in the app.
Factory reset the controller (just google “Rachio factory reset”)
Onboard the controller using the iPhone 6s to a hot spot (for testing).



Still same issue by following these step removing devices then trying to adding back.

This might be similar to the issue I had with my Google Mesh Wifi (and a few other devices). Since the SSID is the same for 2.4 and 5ghz, Rachio seems to try to connect to the 5ghz band and it fails. Since 2.4 broadcasts farther than 5ghz, the way I got around it was to move my Rachio far enough away from the hub so that Rachio no longer saw the 5ghz band, but still saw the 2.4. It then connected to the 2.4ghz, and I was then able to place the Rachio in my original location. Not elegant, but it worked.

1 Like

Thank you! That may be the only viable way. Previously, I have tried turning off two mesh points, leaving only one node on. Maybe, the distance is not long enough to disconnect the 5G signal.
Anyway, I have returned the one purchased from Amazon. Will try another new unit for luck.

Got the brand new Rachio 3. Unfortunately, couldn’t connect to my mesh after trying all the suggestions mentioned here. I turned off two mesh nodes, placed the Rachio 3 very far away from the main router, still unable to get it on the network though my wifi analyzer only saw 2.4G wifi signal.

Final solution was to set up an old school wifi router separately for this special device. Maybe this is the easiest solution at this moment.