Web app (app.rach.io) just says "Updating device data" with spinning wheel

About 5 days ago I stopped receiving weather data.

In the Android app the forecast just has a sun logo and highs and lows of “0”. I have tried setting different weather stations (both PWS and non PWS). And my Netatmo PWS is no longer on the list even though it’s been working for over a year and the data can be seen on the PWS website (SBCNETATMO).

I tried using the web app (app.rach.io) and the Home screen just has the words “Updating device data” with a spinning wheel. I can still turn zones on and off without problem.

Rebooted the Rachio to no avail. Still no forecast data and the spinning wheel.

Any help appreciated.

Here’s what the forecast looks like. You can see it’s updating the past weather but not the forecast.

I’m getting the exact same thing, I have rebooted my unit and also changed the weather intelligence settings but it still only shows 0/0 degrees for temperature. Any idea what is happening? Was this 100% caused by the outage?

I’m glad I’m not the only one. I have tried several different weather sources (PWS etc). Rebooted my Gen2 several times. Wait for a few days etc. Nothing seems to solve the problem. Searched the community forums for similar issues but could see anything.

It kind of makes the Rachio just like any other controller if you can’t get weather intelligence. Just another reason to think twice about connected/cloud based technology. Local control is far more reliable.

Anyway I have just emailed tech support. Will let you know if they respond.

1 Like

I just found out that the temperature shows up after the day has passed and still waters accordingly. For example, for the other day it was showing 0/0 for yesterday. Now the day has passed, it shows the correct temperature information and it also watered.

So this might be simply a visual glitch in the app but doesn’t affect the Rachio unit and it’s ability to water and forecast in the background?

Still not able to access the web version though

So this is the response from Rachio support:

I’m sorry you are experiencing this issue! Researching what could have caused this, we found more customers from Australia and several countries outside the US and Canada are experiencing the same problem.

The forecast information displayed in the Rachio app is gathered from National Weather Providers. In October our Weather Provider is going to release some updates that may fix this issue. However one of our limitations is that we are not able to open any support request with our Weather Provider if this issue is not solved, as we can’t control how information handled outside the US and Canada. Please be mindful that the usage of our controllers outside of these areas will also void the warranty.

Basically they haven’t really explained what happened and are absolving themselves of any responsibility by saying it is being used outside of the USA. Rather frustrating.

What I don’t understand is exactly where they get the weather data. My data from netatmo is sent to pwsweather.com via meteoware (as per the instructions from Rachio: https://support.rachio.com/hc/en-us/articles/115010379287-How-do-I-use-my-Netatmo-with-my-Rachio-).

I will kepp trying to solve this but it’s looking like my Rachio is headed for the bin and I need to find another irrigation system…grrrrr!!!

I have the same issue.

Interestingly I can still see weather forecasts if I go click on a future day in the calendar view. This tells me data is still there, a quick glance the forecast seems correct.

It’s just not appearing on the Home Screen.

Can anyone confirm they are seeing forecast on days in the calendar view?

1 Like

I’m having the exact same issue, I can see the weather forecast data when I choose a date on the calendar, just not on the home screen. The data is there, so I can’t see how this issue is a weather provider issue.

yep, agree.

I have responded to my open ticket with them.

I’m not seeing any data on the calendar view. When I click on a date in the future (e.g. tomorrow) it has no weather data and just reads “Nothing Scheduled”. Even clicking on today has no data, as per the screenshot above. Clicking on a date in the past (e.g. yesterday) I see the weather data (icon, high/low, precipitation etc). So it is being populated retrospectively for me, just nothing prospectively. All very frustrating.

Ohhh…wait. Using the Android app is see nothing in the forecast as per my previous post. But the web app (app.rach.io) does have forecast data on the “Schedule” page when clicking a date.

This makes me think it’s not a problem gathering the data. It seems like a problem with how Rachio handles the data. All very weird.

1 Like

Exactly, I think it’s just a visual thing. Nothing wrong with data or anything. It’s a bug on Rachios side displaying the data all of a sudden. Seems strange how it happened all of a sudden around the same time as the outage the other week.

The device is working, only doesn’t visually show what it’s GOING to do, but the next day shows what it has DONE. Very strange and not something that I see as difficult to fix.

The device is working, only doesn’t visually show what it’s GOING to do, but the next day shows what it has DONE.

But does that mean it is still able to use weather intelligence? I.e. adjust watering based on forecast?

I would think so? Just from the fact that I saw a day with 0/0 and it actually watered it. I saw the same day that just passed and had temp info and said it watered (I checked the drippers and it did). I believe this is mainly a visual bug.

It will be interesting to see if when rain is forecast Rachio delays watering like it is supposed to.

Yes exactly, I’ll keep an eye on it but its raining the next couple of days so hopefully it skips for me and I can update you. I don’t understand the response from Support either. If I set my weather info to the tower 500m down the road from me, why wouldn’t it show up in the forecast? If it was the weather intelligence having an issue then yeah I can understand that.

I did some digging into the Rachio code and took a look at the REST requests the front end is firing off to the server.

Both the failed and successful requests are hitting the same REST endpoint which means there is no issue with the Weather Service.

What I did find though, was that some requests were failing when the END_DATE for the request was too far into the future. E.g. 25/09/2020 - 25/09/2020 WORKED, 24/09/2020 - 01/10/2020 WORKED, but 24/09/2020 - 07/10/2020 FAILED.

To me this looks like either Rachio is requesting data further into the future than the API can provide, or the Weather Service has made a change on their end to limit the future forecasts to X number of days which Rachio is exceeding.

WORKS ----
curl “https://cloud-rest.rach.io/location/getWeatherByLocation
“Content-Type: application/json” -H “Origin: https://app.rach.io” “{”“location_id”":"“XXXXXXXXXXXXXXXXX”,

FAILS ----
curl “https://cloud-rest.rach.io/location/getWeatherByLocation
“Content-Type: application/json” -H “Origin: https://app.rach.io” “{”“location_id”":"“XXXXXXXXXXXXXXXXX”,


Seems to be fixed now for me. Yay!
I didn’t anyone hear anything from Rachio about if/when they fixed this?

Now I have to try and get my own PWS to appear in the list of weather stations again.

Yep, working for me too. Had to swap between local and intelligent weather to populate the calendar as it was still showing no upcoming watering. It’s now back to normal! Website works as well.

Thanks everyone!