Unexpected error to connect Wifi all of sudden

I had Rachio 3 running for like 6 months already, everything works pretty well, all of sudden the device was offline few days ago, and I tried to reset, always give unexpected error when trying to connect WiFi. I have tried reboot, factory default, nothing works. So frustrated. I have 2 ruckus enterprise APs installed on home ceiling both hard wired to switch, I have no WiFi issue other than Rachio.

Can you get the controller into the ‘waiting for Wi-Fi’ state where the first quadrant is lit and the second is blinking?

If not, do a factory reset and try again. If you still can’t make the second quadrant blink, you probably suffered a hardware failure and should obtain an RMA.

On your phone, near the controller with the second quadrant blinking and not running the app, go to Wi-Fi settings and look for an open network whose name begins with Rachio. Connect to that network. If you see a message about no internet, choose ‘stay connected’, after checking the option to not be asked again for this network.

Wait two minutes and confirm that your Wi-Fi is still connected to the Rachio network. If not, turn off mobile data, reconnect to the Rachio network and see whether you can now stay connected for two minutes. If not, post details.

Open your phone’s browser to
and confirm that you see this message:
File / not_found
Then, reconnect to your home Wi-Fi, open the app (you should see the controller offline) and go through the ‘Update Wi-Fi Network’ steps, without touching the controller, until you are asked for network name and password. Enter those and proceed; with luck the controller will connect to your Wi-Fi and the cloud server.

If you still have trouble, try running the app on a different device, e.g. an iPhone or iPad if you were using an Android device, or vice-versa. If still no luck, post the makes and models of devices you have tried.

Same problem here. Funny thing ist that my access point sees the Rachio 3 connected, but it doesn’t connect to the cloud.

Possibly, your firewall is blocking it. From a device on the same SSID, can you access https://mqtt.rach.io:8883 and see the expected certificate error?

Does the Rachio get an IP address? Can you ping it? Access it’s web page and see a not found error?

I don’t think so since I didn’t change anything in my network setup.

Yes, I can.

Yes, then it disconnects after a short time and gets another IP.



Very strange that the Rachio keeps getting another IP every few minutes…

Indeed. Is it presenting different MAC addresses? Or somehow tricking DHCP to assign a very short lease time? If the latter, setting it static in your router may help. Do you have a way to capture its traffic?

No, always the same MAC address.

The lease tim is set to 10 days which is default in AVM FRITZ!Box 7590.
The minimum I can set is 1 day.

I set up the FRITZ!Box 7590 to always assign the same IP address to the Rachio 3. In FRITZ!Box 7590 it is set to x.x.x.61 but the installed access point tells me that it currently is on x.x.x.75. Really very strange behaviour!

I didn’t do that before on macOS. Can you give me advice?

Perhaps the AP is acting as a pseudo bridge. Do you see multiple devices with the same MAC but different IP addresses in the router? If you connect your phone to the AP, does it get different addresses in AP and router?

Waiting for takeoff now so won’t be able to answer until tomorrow.

All I had to do was restart my FRITZ!Box 7590 and the Ubiquiti UniFi managed switch.
So happy it works again without the need to completely reset the Rachio 3. :wink:

1 Like