Unable to download latest Android app

I have been using my 2nd Gen Rachio controller for several years without problems. About 3 days ago my Rachio app had a message that my app was out of date and needed update. I was unable to get past message to use the app. Tried multiple times to install the update but Google play just circles with the message “pending”. I have a VPN and paused it thinking that might be the problem. Still wouldn’t load. Finally I totally deleated the app with all my lawn information on it. I still am unable to get the app to download on my android phone. It still shows “pending” No problems with past updates. Please help. Kirk

  1. this is not a Rachio issue, but your phone/Google issue. 2) you didn’t lose your Rachio setup as it’s all saved on the server; 3) have you tried restarting the phone? 4) if still doesn’t work check if you have enough space left on the phone; 5) it could be a temporary issue with Google Play, so give it some time to resolve itself.

Thanks for the reply. I have tried this over about 3 days without success. Tried restarting phone again and still get the “pending”. I have over 75 gig of storage still available. I am able to access my controller on my PC so I have a way to control it. Just wanting the easy of using a phone app like I have for years and 2 different houses with same controller.

Can you download/update other apps from the play store?

I just tried to update another app and tried to download a new app. I do get “pending” on both. My VPN is paused.

I decided to look up on Google about the “pending” showing when trying to download apps. Some of the ideas I had already tried like turning off VPN. What finally worked was going to Settings App on phone, then 1. Tap Apps. 2. Scroll down and tap Google Play Store 3. Tap Storage then Clear Cache.
4. Next, tap Clear data.
I was finally able to download the Rachio app. Now I just have to input all my previous settings!! I hope this helps someone else if they have the same problem. Thank you beranes for the input, it helped look at other causes.

Uninstalling and reinstalling the app should not have affected your settings such as zones, schedules, etc.

Are your settings showing correctly there? If so, can you view app.rach.io from Chrome (or other web browser) on your phone? If so, can you view the settings?