Unable to connect when using Unifi AP


#1

I upgraded my network to use Unifi equipment and access points and am now completely unable to get my Rachio gen 2 to complete wifi setup. I’ve opened a support ticket but they are very slow to respond and the info so far has not helped.

What I’ve done so far:

  1. Created a dedicated 2.4GHz wifi network called “RACHIO” with no outbound firewall rules and no MAC address filtering.
  2. Confirmed the controller connects to the network. It shows up in the list of attached clients, and the MAC address listed matches what’s printed on the controller.
  3. Looked at the “deep packet inspection” page for the controller to see that outbound and inbound traffic to AWS is happening

Even with all this the controller never finishes setup. It just keeps cycling from the 3rd blinking light for a while back to the 2nd blinking light.

The signal strength reported by the AP is 97% (-51 dBm) and the network channel is 11.

I’ve done all the configuration with my phone in airplane mode and only connected to the Unifi network I created specifically for the Rachio (the phone connects fine and can access the web fine). I’ve tried uninstalling and reinstalling the Rachio app on the phone too, since 1st level support said to try that.

I’ve read through all the other Unifi AP threads here and they never really explicitly had any solution other than trying 2.4GHz networks, which I’ve done and confirmed allows the controller to get on the network. It’s just never completing the setup.

Anyone have any suggestions? It’s getting to watering time and I really need the controller up and running.


#2

Just curious if you have done this? I believe I had to do it when I had a unifi network, but its been a while since I did. Not sure what order I did this in. First two things are the same I just wasn’t sure where the setting is located anymore

“Enable legacy device support (i.e. 11b)” on your access point (on the Controller in Settings -> Wireless Networks -> Options)
In Controller - Edit your WLAN Group, re-enable Legacy.
IEdit->802.11 Rate and Beacon Controls, select Legacy under 2G Data Rate Control


#3

I have a all Ubiquiti network including APs and I have zero issues. What router are you using? What AP / FW version? Just curious why you created a separate SSID for the rachio controller?


#4

No issues with my UniFi gear here, we have 4 access points. Our Rachio connects to the AC AP Lite closest to it. Same SSID on 5 & 2.4GHz radios and it connects to the 2.4. My controller and APs are on the latest SW/FW versions.


#5

@neile - I have no idea if this is an issue or not, did you upgrade from V2 to V3 of the software before you changed out the AP?

One other suggestion would be to get the RouteThis app and run it so that information can be provided to Rachio. They have some good networking folks on the help desk. I might schedule a call with them when you’ll be home to troubleshoot it further.


#6

I have a UniFi AP-AC-Pro (version 3.9.19.8123) and Unifi security gateway running on a Synology box via Docker.

I set up a separate 2.4GHz-only SSID because support told me to.


#7

Thanks for the suggestion. I tried enabling legacy support and it didn’t help.

The behaviour is the same as without legacy support enabled: I can see the controller show up in the Unifi control panel as a connected device on the wifi network but it fails to finish the third light.


#8

I don’t know, when did v3 come out? I’ve completely ignored Rachio since October when I turned off my irrigation system for the winter. The new Unifi deployment happened about two months ago and I completely forgot the Rachio needed to get reconnected until this weekend as I started to bring up the irrigation again.

I’ve used the RouteThis app twice and sent the results to Rachio twice. The first time they really didn’t seem to bother to look at it and just said to try setting up a 2.4GHz network and try again. When that didn’t work they bumped it to some other support person who just told me to ensure the outbound ports weren’t blocked (they aren’t). I sent a new RouteThis trace this morning but haven’t heard anything back yet.

Anyone know how to see the results of what RouteThis sends to Rachio?


#9

Cool. Can I grab your network and controller and install it at my place? :grinning:


#10

Sure! Where shall I send it? :smiley:

Sorry I didn’t mean it to sound all “works here, so should yours!”

Did you already override the AP config so the new SSID would not be broadcast on the 5G radio?


#11

@neile - V3 was released March 1, 2018 6AM MST (edit changed to 2018).

I’m guessing that may be the problem. There is a new backend to the system. Therefore the new app is trying to find the device in the V3 environment, but it doesn’t exist.

I think Rachio can convert your controller over to the V3 platform for you. That may solve the problem.

I’d mention that on the next conversation or ticket.


#12

Yep, the new SSID is only broadcasting on 2.4GHz. I don’t think it’s a “connect to wifi” problem since I can see it in the Unifi UI and I can see in the deep packet inspector that data is getting sent/received from AWS.


#13

I bought my Rachio from Amazon on August 29, 2017. I assume that when I did the initial setup it would have had a forced upgrade or offered the upgrade to v3.

Unless you meant 2018, not 2017?


#14

@neile

It looks like your controller data was migrated over to our new V3 application but it can not receive the new firmware.

Have you tried a WiFi reset in the app?

:cheers:


#15

Thanks for the reply Franz. I’ve tried those wifi reset steps more times than I can count, most recently today when trying on both my 2.4GHz network and then my combined 2.4GHz/5GHz network.


#16

Do you have a hotspot (most phones have this capability) by any chance that we could at least get the controller’s firmware updated and connected to the cloud?

:cheers:


#17

I can enable hotspot on my phone, yes. Then tell the Rachio controller to connect to that hotspot and hope it finishes updating?


#18

That’s what I’m thinking, at least to see if we can get the controller connected to another WiFi network. Once connected it will get new firmware that probably won’t help your Unifi issue but at least might tell us if the controller can connect to other WiFi networks.

:cheers:


#19

I’ll give it a try later tonight, but to be clear, as far as I can tell it is connecting to my wifi network.


#20

I have one other idea. If you are using iOS you can connect to the internet through a WAC process. If the controller is in AP mode and broadcasting you can go to the WiFi settings in iOS and find the controller and connect to it. From there it might be able to connect to the internet and get firmware. Just a thought.

:cheers: