Standby Mode cannot be activated (iOS)


#1

Rachio Device Status: Online
iOS Rachio app version: 2.2.0
iOS firmware version: 9.0.2

Every time I try to activate “Standby Mode” I get the following message:

"The request could not be completed. Please try again later".

I also get the same error when trying to change any setting on the “Change Weather Station” section of the iOS app.

Everything else appears to function normaly.
Any ideas?


#2

Can you PM me your username? Thanks!

:cheers:


#3

Thanks for your quick reply Franz!
I already sent you my account username!


#4

Ok, figured it out. It was a defect we fixed in the last few days. Your city and state name had some international characters in it that was making our message signing (security) fail authentication. Any new users will not experience this, so I just had to take the special characters out.

Everything is all fixed, and your device is in standby mode. If you logout/login to the app everything will work great for you.

Awesome to have users in Greece! Have a great winter?

:cheers:


#5

Well, I did sign out and sign in again as you suggested, but I still get the same error!
There is now no indication my device is actually in standby mode.


#6

Hmmm…it looks like it might be the language chosen on your phone, this is what is coming over for the state name Νομαρχια Ανατολικης Αττικης :wink:

Can you try changing to English and see if that fixes it?

:cheers:


#7

My phone’s primary language is set to English (it has always been set to English).
I also have Greek but it is second in the list.
According to Apple, all apps should use the primary/first language - English in my case.
The region is set to Greece, but I did change it to US for testing - still the issues remains (after logout/login ofcourse).
Even my iTunes account is US !

I think the state/ region name is taken from the local Weather Station which I can confirm IS in Greek characters - in fact, even Rachio app displays the state name in Greek on its main window. But there is nothing we can do about it Any way around it?


#8

Strange, I’m having our iOS developer check this out. The city/state are still coming over as Νομαρχια Ανατολικης Αττικης.

On Android it works, and on iOS it doesn’t seem to work, which is what you are seeing and I was able to reproduce.

We’ll get to the bottom of this…for now I converted those to English. If you logout/login should work this time :wink:

:cheers:


#9

Well done!
It is working now !

Like you said, the issue must have been my location’s name - now displayed in English characters.(Kalivia Thorikou, East Attica)

Thanks!

PS. Let me now when the issue is fixed permanently - so I will not run into the same error if I chose another Weather Station in the future.


#10

Ok, will do. It’s actually not the weather station. As long as you don’t update the device location (which updates city/state name) you should be fine.

:cheers:


#11

I am having this problem. Android devices, location has a special character but I do not see any way to manually remove that. In the app, I would put it into standby but it would not actually do it: (1) no device update reflecting this and (2) any app refresh showed it active.


#12

@iro514, could you post or email us (support@rachio.com) a screenshot? We’ll take a look at figure out what’s going on. Thanks for bringing this to our attention.


#13

If you logout/login everything should be working as normal :wink:

:cheers:


#14

Franz, I believe that worked. There’s a good chance that, had I read the entire thread, that would have been obvious. However, I didn’t read the thread to confirm.