Some of my zones are completely covered by large roof overhangs

I have 11 zone, 2 of which are completely covered by large roof overhangs. When it rains these 2 zone get zero water. I have a rain sensor that wire into my previous irrigation controller.

How can I tell Rachio that these two zones should not react to rain (via internet or my rain sensor)?

Having your zones covered from elements means that most of the smart weather intelligence does not apply. As such your best bet is to simply create a Fixed or Flex Monthly (with seasonal adjustments) schedule and adjust the days / duration settings based on your observations. Only Flex Daily uses rain data, if you don’t use that type of schedule for your covered zones, you don’t need to further specify that they do not get any rain. The rest of your zones should be set to Flex Daily as it will provide the best savings based on weather observations.